Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: The Dreaded Aero Peek Not Working!


17 Jun 2013   #1

Windows 7 Home Premium 64bit
 
 
The Dreaded Aero Peek Not Working!

Hi All,

The thread title pretty much says it all. I've been reading thread after thread on this the past 2 days to figure out why the Aero Peek feature of Windows 7 has stopped working (and option greyed out) on my ACER laptop. Up to this point none of the "tried and true" solutions has worked for me. I suspect it has to do with the video card and/or driver. Aero was working fine just a few days ago and the only thing I can think of that changed was probably some various Windows updates were applied (no new software though). I know the laptop hardware can handle it. Config: Core i5, 8GB RAM, Radeon Mobility HD5850 1GB, Windows 7 HP 64-bit, OCZ Vertex 3 SSD. So based on everything I've read including this tutorial, here's what I've tried so far:

1. Enabled/Restarted Windows Desktop Manager and Theme services.
2. Updated my video card's driver (Radeon Mobility 5850) from AMD's website. Also tried removing then updating.
3. Re-ran the WEI test, got a 6.7 score on Graphics (6.7 overall).
4. Ran the troubleshoot/fix Aero windows utility, checked the Apply Repairs Automatically box. Which indicates it can't troubleshoot the problem.
5. In the Performance Options => Visual Effects. I noticed that "Enable desktop composition" and "Enable Aero Peek" selections are missing altogether. Same with "Save taskbar thumbnail previews". Probably a few others missing that I didn't list here.
6. Played with the resolution some, True Color 32-bit is enabled (1600x900 recommended res.).
7. Opened Task Manager, I ended some processes one by one (users only not system).
8. Downloaded the registry fix to Enable Aero. Added UserMachineCheck, Animations and Blur manually, all REG_DWORD type, all three got a value of 0.
9. Cannot try System Restore as I have this disabled since I am using a SSD.
10. Tried the Microsoft "Fix-It" utility for Aero Glass not working.
11. Tried creating another user profile (admin) and the problem persists in that account as well.

Some additional information. I first noticed the problem as the laptop was coming out of sleep mode. I've read that has caused video issues occasionally but a reboot typically fixes it. Which, in my case, obviously did not. Could it be something may have gotten mucked up in the BIOS? That is one thing I haven't been in to check. Though nothing should have changed there. Any other thoughts on this? I'm really at a loss here and would appreciate any feedback. Let me know if I need to provide any additional information. Thanks in advance.


My System SpecsSystem Spec
.

17 Jun 2013   #2
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Hello knight1fox,

Did you also check to make sure that the Desktop Window Manager Session Manager and Themes Services were set as Started and Automatic?
My System SpecsSystem Spec
17 Jun 2013   #3

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Brink View Post
Hello knight1fox,

Did you also check to make sure that the Desktop Window Manager Session Manager and Themes Services were set as Started and Automatic?
Yes, confirmed those services were started and in automatic mode. Thanks for the reply.
My System SpecsSystem Spec
.


17 Jun 2013   #4
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

It looks like you pretty much checked everything.

I didn't see that you listed checking to make sure that you are using an "Aero" theme, so that's one more to check if you haven't already. If you are, then see if changing the theme to the "Windows Basic" theme, apply, then change back to an "Aero" theme and apply may help.
Theme - Change or Save
My System SpecsSystem Spec
17 Jun 2013   #5

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Brink View Post
It looks like you pretty much checked everything.

I didn't see that you listed checking to make sure that you are using an "Aero" theme, so that's one more to check if you haven't already. If you are, then see if changing the theme to the "Windows Basic" theme, apply, then change back to an "Aero" theme and apply may help.
Theme - Change or Save
I forgot to mention that. I am using an Aero theme (Windows 7) which I find odd. If Aero is not enabled, how then am I able to select an Aero theme? I have not tried switching to a basic theme and then back to an Aero theme. I don't have high hopes for that but you never know. I will report back with the results.
My System SpecsSystem Spec
17 Jun 2013   #6
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

You would still be able to select and use an Aero theme. It's just that if Aero has been disabled, the Aero theme will just loose it's Aero features and will basically just act like a "Windows Basic" theme then.

Is your Windows currently activated? Aero is one of the features that can be disabled if Windows is not activated.
My System SpecsSystem Spec
18 Jun 2013   #7

Windows 7 Home Premium 64bit
 
 

Well here's where I am at today. I switched between an Aero theme and a Windows Basic theme. Still no actual Aero upon changing back to an Aero theme. To answer the activation question, yes I double-checked to make sure my copy of Windows was still activated and it was (this is an older machine). I figured I would also share some screen shots to aid in my troubleshooting efforts. Always easier to see what people on the other end are seeing.







The last image of the registry is what really has me confused. It seems all the right options in there have a "1" entry meaning enabled, correct? Like "EnableAeroPeek", "Composition", etc. So if these are enabled in the registry, how are they disabled/not shown in Windows? Or better yet, what is disabling Aero? This is a head-scratcher for me. Any other thoughts? Or questions about my config? Thanks again as always.
My System SpecsSystem Spec
18 Jun 2013   #8
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Just as a test, uninstall your current Intel VGA driver, and install the 15.28.4.2843 version from Gigabyte's site below to see if Aero may work afterwards. You may need to restart the PC after installing the drivers first.

GIGABYTE - Motherboard - Socket 1155 - GA-H67M-D2-B3 (rev. 1.0)
My System SpecsSystem Spec
18 Jun 2013   #9

Windows 7 Home Premium 64bit
 
 

Some interesting information. In device manager, I removed the current video driver. Rebooted. Then windows proceeded to install the next best (I assume) driver it had to load. I continued to remove and reboot until the "Standard VGA Graphics" driver was loaded. For kicks, I re-ran the Aero troubleshooter and it now indicates, the current video card may support Aero, but requires a WDDM compliant driver. Contact the manufacturer. Going to play around just a bit more before loading the driver you recommended. Unless you can think of anything else based on this new information.

EDIT: Tried installing that driver, and the message I receive is, "This computer does not meet the minimum requirements for installing the software."

EDIT 2: Intel driver 15.17.10.64.2189 (from ACER website) seemed to install but didn't change anything from the standard VGA.
My System SpecsSystem Spec
18 Jun 2013   #10
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

At least we're pretty sure that it's your video driver at fault here now.

Go ahead and uninstall the driver again, then see what the Intel Driver Update Utility will automatically find for you.
My System SpecsSystem Spec
Reply

 The Dreaded Aero Peek Not Working!




Thread Tools



Similar help and support threads for2: The Dreaded Aero Peek Not Working!
Thread Forum
Aero Peek not working General Discussion
Aero Peek not working? General Discussion
aero peek is not working Themes and Styles
Aero Peek not ALWAYS working General Discussion
Aero peek not working General Discussion
BUG: Aero Peek enabled but not working General Discussion
Aero Peek not working but active... Customization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:39 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33