Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: high cpu when loading themes

03 Jan 2010   #1

windows 7 ultimate
high cpu when loading themes

hi guys

i have about 20 or so themes installed and every time i right click and go to personalize to change the theme the cpu spike up to nearly 100% and sometimes 100% till it loads all themes esp the one being used at the time....
is this normal? did any one has the same thing happening to them?
i think it shouldnt be the you think there is something causing this issue?

thanks alot in advance

My System SpecsSystem Spec
03 Jan 2010   #2

Windows 7 Ultimate x64 SP1

Can you provide your System Specs?

This may be normal as Windows 7 is designed as an appearance based OS on a hand !
My System SpecsSystem Spec
03 Jan 2010   #3

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, 64-bit

You might be able to change the priority of that in task manager/processes with a right click if it bothers you. Setting a lower priority might use less CPU, but take longer to complete.
My System SpecsSystem Spec

03 Jan 2010   #4

windows 7 ultimate

thanks guys for the quick reply
my system specs are AMD turion dual core mobile RM-70 2.00 GHz, 3gig memory .windows 7 ultimate 32 bit....

i dont realy fancy changing the priorityof the task..just wanted to know if this normal behavior or not?
why does it do that? other tasks doesnt spike so much cpu usage!!!
My System SpecsSystem Spec
03 Jan 2010   #5

Windows 7 Ultimate 32x

I believe It Has To Change Settings In Explorer.exe Which in windows 7 explorer takes up the majority of CPU usage.
My System SpecsSystem Spec

 high cpu when loading themes

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
BSOD playing games under high load, High-end Intel/Nvidia custom PC
Hi all, This is my first computer build. For the most part it is playing games fine, but three times now in the last several weeks I have gotten BSODs, in Crysis 3, Battlefield 4. I didn't have the presence of mind to write down the error code. I have attached the /zip file generated by SF. ...
BSOD Help and Support
At start up laptop does a high pitch beep for a few before loading up?
I uninstalled Google Chrome recently and ever since I've been having some issues with my computer. Can somebody tell me what it means when I shut down or restart my computer and does a very high pitch beep, its like its screaming at me and then it flashes for a few seconds and then goes to the...
General Discussion
Very high CPU usage, causing very high laptop CPU temps (90c idle)
This problem began yesterday. I noticed my CPU was at 90C constantly with very high CPU usage (>50%). I had no major programs running. I rebooted several times and the program persisted. 1. I went into safe mode and everything was normal. So this rules out hardware issues. 2. I reformatted and...
Performance & Maintenance
Ease of Access & High Contrast Themes Problems
I give up! I am trying to assist a family friend who has macular degeneration & VERY poor eyesight. He uses his new PC with Win7 (x64) primarily for creating documents in whatever the latest version of Corel's WordPerfect suite is out now (6?). On his VISTA machine, he uses the...
Themes and Styles
High download speed and signal, high ping in games, slow page loads
Recently, I reinstalled my Netgear wna3100 driver. Ever since then, I've been experiencing problems with high pings in games where I normally never had problems with. Pages load slowly even just the home page of Google. I've attached my ipconfig picture. Any help would be greatly appreciated. ...
Network & Sharing
High FPS = High Ping in games (solution anyone?)
Hey All, i'm new here this is my first post but it looked like a fairly knowldegeable place so i'm happy to give it a try, hope someone here can help :) First, a bit of background info.. Since i got my hands on the RC i've loved it. I'm running the 64bit version on this spec (I Don't think...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:29.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App