Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Safely Remove Hardware - Eject Device


15 May 2009   #9
Brink
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 
Safely Remove Hardware - Eject Device

How to Use Safely Remove Hardware to Eject a Device in Windows 7 and Windows 8

...


My System SpecsSystem Spec
05 Jan 2010   #10
Brink
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

You might reset the notification icons and the icon cache to see if it may help in case it may just be a icon glitch.


My System SpecsSystem Spec
05 Jan 2010   #11
nate42nd

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by Brink View Post
You might reset the notification icons and the icon cache to see if it may help in case it may just be a icon glitch.
I will try that Brink. What's funny is it's a NEW machine. XP was never on it and all components are new and it's always been that way. When I put my flash drive in when it was new to install drivers, it was the same way. I have never seen it on another 7 machine. I'll try to post back if that works.
My System SpecsSystem Spec
06 Jan 2010   #12
snuffed

XP
 
 

One thing I don't get though, is that on Windows 7 (at least for me) it is no longer turning my devices off after the "safely remove hardware" bubble pops up, when it used to on my old XP. As in - after using the eject function on XP my MP3's LCD message will change from "USB connected" to "USB disconnected" and the lights on my USB thumbdrives and SD card readers etc will turn off. Now nothing happens except the icons disappear from My Computer and I still need to unplug and replug to access them again. Is this normal?
My System SpecsSystem Spec
06 Jan 2010   #13
Brink
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Hello Snuffed,

It appears to be normal. I get the same thing for my USB key drive as well.
My System SpecsSystem Spec
.


08 Jan 2010   #14
sunil31

Windows 7
 
 

Hi All,

I am new to this forum. I landed here to search same question.

I am not able to Eject USB drive (Reliance Broadband++ USB Data Card). I see something different notification from you people have posted here. See attached image. In the notification HUAWEI Mobile is grey and Eject CD Drive (K Reliance Dark. I see vice versa notification what you have posted here.

Is there any problem in this type of notification? How can I remove USD this USB device safely as I have already lost (corrupted) one drive. Please help me.

Regards,

Sunil


Attached Images
 
My System SpecsSystem Spec
08 Jan 2010   #15
Brink
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Hello Sunil, and welcome to Seven Forums.

What does it eject when you click on the "Eject CD Drive (K: ) Reliance" option? Is this your data card?
My System SpecsSystem Spec
09 Jan 2010   #16
sunil31

Windows 7
 
 

Hi Brink,

Thanks.

Yes, this is Data Card and nothing ejects. One thing is there, if I use USB pen drive, it ejects successfully. But this is not the case with Data Card.

Regards,

Sunil
My System SpecsSystem Spec
09 Jan 2010   #17
Brink
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Sunil,

I have not used one before, but I would imaging that the data card is tied to the HUAWEI mobile broadband card acting as one device. This may be why it will not eject it. If available, do you have the latest driver installed for it?
My System SpecsSystem Spec
12 Jan 2010   #18
sunil31

Windows 7
 
 

Hi Brink,

Sorry for late reply as I was out of station.

No I don't have latest driver for that. I am using Windows 7 operating system and as per my knowledge HUAWEI have not released driver for the same. If you have any information about that, please let me know.

Thanks

Sunil
My System SpecsSystem Spec
12 Jan 2010   #19
Dragor1

Windows 7 Ultimate (64 bit) dual boot with Fedora KDE
 
 

Hey Sunil!

Try seeing in Devices and Printers.

The problem is that the data cards contain a small amount of flash memory that hold the drivers and they are set to be emulated as CD drives.

Since they emulate CD drive, they autorun the driver installation without user input.

That is the reason why Sunil's screenie shows The CD Drive under his mobile.

Hope this helps.

P.S.: Post the screen of devices and printers and also take a screen shot with right click menu of your mobile.
My System SpecsSystem Spec
Comment

 Safely Remove Hardware - Eject Device




Tutorial Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:32 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App