Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Run as Administrator

01 Mar 2010   #30

Windows 7 x64
"Run as Administrator" but still asks for password

I've a Media Center PC (w7 x64) with an standard account "Media Center".
Recently haded 3 programs that start with windows:
Asus PC Probe, PowerGuard (UPS) monitor and ASUS Update.
I've tried the option "run as administrator" on the "program.exe" and even in the shortcut and doesn't work.
When the PC starts always shows the prompt to place the admin password to start the programs .

Can anyone help?


Marco Costa

My System SpecsSystem Spec
01 Mar 2010   #31

64-bit Windows 10 Pro

Hello Marco,

Since these are elevated programs that require UAC approval first to run, you will only be able to stop this if these were ran in a administrator account at startup using a task in Task Scheduler instead.

Task - Create to Run a Program at Startup and Log On

Hope this helps,
My System SpecsSystem Spec
07 Mar 2010   #32

Win 7 Home Premium (OEM) - Install date: 02-2010

Hi, I think this tutorial may contain a mistake: Option Four: Using Advanced Properties - the 'Run as administrator' box exists in the 'advanced properties' of shortcuts, but not in the 'advanced attributes' of executables.
My System SpecsSystem Spec
07 Mar 2010   #33

64-bit Windows 10 Pro

Thank you THX. The error has been corrected.
My System SpecsSystem Spec

24 Mar 2010   #34

Windows 7
Not working for me

I am sorry but this is not working for me.

I am trying to get Server2Go - Self configurable WAMPP Stack to work on a HP Mini using Windows 7 starter and I keep on getting the prompt to enter the administrator password.

I try to start the program using a standard user, I have given the user full rights on the directory of the program and have selected the option to run as administrator, but none of this has helped.
My System SpecsSystem Spec
24 Mar 2010   #35

64-bit Windows 10 Pro

Hellp Flip69, and welcome to Seven Forums.

Sorry, but a Standard user will not be able to run a elevated program without getting a UAC prompt and having to enter the administrator's password.

This is to be used in a administrator account instead.
My System SpecsSystem Spec
09 Jun 2010   #36

windows 7 home premium

I have no problem following this tutorial / locking /unlocking the administrator account, but it doesn't seem to actually be working for me...
By which I mean, I'm trying to execute a file from intel (a chipset utility identifier) and no matter what I do to turn on the 'run as administrator' it still tells me it cannot run the file because it has to be run as administrator -- I'm at a loss for what to try next. I've logged on and logged off as the administrator multiple times -- both with and without restarting my computer. I've right clicked on the file and selected run as administrator, i've clicked file properties and checked the 'run as administrator' box, both for current user and all users....

Any suggestions?
My System SpecsSystem Spec
09 Jun 2010   #37

64-bit Windows 10 Pro

Hello Nssuprin, and welcome to Seven Forums.

Do you have UAC turned on? Some programs that require "run as administrator" may not run properly if UAC is turned off.

Have you tried running the program while logged in as the built-in Administrator?

Hope this helps for now,
My System SpecsSystem Spec
09 Jun 2010   #38

windows 7 home premium

Thanks Shawn -- I actually have tried it with the built-in administrator, and with the UAC both on and off...(at least, I think it's on. I never get asked for a password, though) unfortunately with the same results every time.

thank you,
My System SpecsSystem Spec
09 Jun 2010   #39

64-bit Windows 10 Pro

Could you post a link to the utility? I'll test it on my system, if able to, to see if it might be a issue with the program itself.
My System SpecsSystem Spec

 Run as Administrator

Tutorial Tools Search this Tutorial
Search this Tutorial:

Advanced Search

Similar help and support threads
Windows 7 Tutorial Category
I AM the Administrator,UAC is OFF,Yet I need Administrator Permission
Because LIFE is short and precious, it's reasonable to not have to waste time, clicks and energy FIGHTING the most simple of OS tasks: deleting a file or folder. Because it was SO DRAINING to add thousands of extra hoops to my daily work, I now log in as the Administrator and have turned off...
General Discussion
User Administrator Account won't allow Administrator Privilages
Hi, I'm running Win 7 Pro x64 and Office 2007. I installed a Bluetooth transceiver recently and developed a problem when replying to email in Outlook 2007. When I select an email to reply, the email editor pops up with a "Custom UI Runtime Error in Send to Bluetooth." The solution to this issue...
General Discussion
User is both an Administrator, and not an Administrator. Cannot change
An account on my Windows 7 installation cannot have its type changed from an administrator to a user account. I tried to change it using the cmd and I'm getting these messages: >net localgroup administrators AccountName /del System error 1377 has occurred. The specified account name is...
General Discussion
Renaming the administrator account back to Administrator
Hi, I have an Acer laptop which came with one user account, Acer, with the administrator right. When I tried to rename it to Administrator or administrator, I got an messages saying that user name has already existed. How do I rename Acer to Administrator? Thanks.
General Discussion
Administrator without administrator privileges?
I have an administrator account on my laptop, but when I display its properties it says I am a standard user and will not let me change the account type. How can I change my account type to administrator.
General Discussion
Administrator account isn't a 'real' administrator :(
I hope this is the correct forum for this question. I currently have Windows 7 32bit installed on one partition ( D: and I just installed Windows 7 (64bit) on another partition ( C:. I log into Windows 7 64bit using Administrator BUT when I try to do things like move where the...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:03.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App