Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB Driver - General Fix for Problems

27 May 2011   #29
pooch

Windows 7 Ultimate x64
 
 
USB Driver - General Fix for Problems

General Fix for USB Driver Problems

I recommend using a wired mouse and keyboard, removing all USB devices and in the section where it says Uninstall all the faded entries. take that as reading uninstall everything USB, if you...


My System SpecsSystem Spec
15 Oct 2012   #30
CEM

Win 7 Ultimate 64
 
 
THE BEST!!!!

Pooch, this bsod was driving me CRAZY!!! The usb mouse would disconnect every once in a while and unplugging/plugging back in solved the issue.
Then all of a sudden, after about 3 s/w installs and MS Updates, the fe error.

Thought it was the mobo. Then h/w. Uninstalled the new s/w. Nope.

About to go out and buy new mobo, figuring it was the mouse/keyboard inputs.

Found this tutorial. Holy Mackerel!!! The number of greyed out usbs was over 30.
The issue of Admin addition not working is because you have to add Rights to that user; are not automatically granted.

Thank you pooch, very much.


My System SpecsSystem Spec
05 Nov 2012   #31
airsakuragi

win 7 ultimate
 
 

hi pooch,







Help please,

I have an Imation Usb Flash disk 4GB nano pro,
everytime I plug in to my Toshiba Laptop A300 using Windows 7
it says windows update cannot find the driver ,
so it say usb device not recognized and I cant see it in my Devices with removable storage.

When i go to device manager, i can see the unknown device as nano pro
but no driver installed, it has an yellow exclamation mark. tried update driver but failed because Windows 7 cannot find it online.

When i run Ubuntu OS on the same laptop,
usb imation is working so i guess theres a problem only with Windows 7 driver or Windows 7 OS .

I followed your instruction here but still it doesnt work because it doesnt have a driver,

Also, i tried a different brand usb flash disk and its working, only this Imation brand is not.

Thanks a lot
My System SpecsSystem Spec
28 Nov 2012   #32
hillbillypop

7 ultimate 32bit 4off
 
 

Mmmm none of this works for me i have 2 different systems same hardware different mother boards both asus
1 a p5VD1_X(X-XP3) and a P5bw-LA (x-VISTA) both newdrives to windows 7 ultimate everthing is ok with the P5VD but none of the usb ports internal and external work on the P5BW if i put the vista drive back in all works well so problem is not hardware but is windows seven dose not like my board althoug seven adviser said all was ok.
All usb ports are live but do not read or write they show in device manager
I have done all as above but does not work so no need to go back over that!
ran driver wizard and all drivers are upto date.
When i compare device manager USB's they are titled different?
Anyone anyfurther Ideas
My System SpecsSystem Spec
16 Dec 2012   #33
bucklew1

Window 7 Pro 64 bit
 
 

For those asking about how to delete the infcache.1 file, I deduced after adding administrators it would be necessary to check the boxes regarding permissions.
My System SpecsSystem Spec
.


29 Dec 2012   #34
Harry48

Windows 7 home premium 32bit
 
 

My system has been freezing a lot so this looked like a good option. I do not have a wired mouse so had to use a USB version. Have restarted the computer but none of the USB ports seem to be active; that is to say, none of the devices respond, including the mouse and keyboard! Is there a way that I can activate the USB ports?
CANCEL - sorry, after rebooting (a couple of times) the usbs became active!
My System SpecsSystem Spec
13 Jan 2013   #35
mexako

Windows 7 Ulimate x32
 
 
USB Driver Problems

Hi,

I am having trouble with my laptop (HP Compaq 6715b) USB ports as I have followed each step by pooch about three to four times. I have searched Google and Youtube but no luck except this thread.

Before having this problem, my USB ports were working fine about five (5) to eight (8) days ago. These ports cannot be dead as I have tested an old USB stick (to create the new INFCACHE.1 file when following pooch's steps) and my USB mouse and keyboard. Both work in all four (4) USB ports and no errors.

Once I put in the devices that I need for data and transferring data to is - Seagate External HDD which is brand new bought just before Christmas 2012, Samsung smartphone and USB stick. All these devices give me the balloon error "USB Device Not Regonized". Strangely enough the USB stick that I inserted to refresh the INFCACHE.1 file by following all steps given by pooch works.

Also, these devices that I am trying to get to work, all of these devices work on my PS3 but not on my HP Compaq 6715b laptop.

If anyone can please help me that would be much appreciated as I need to get data from these devices and also copy data onto other devices for back up.

Thank you!
Mexako
My System SpecsSystem Spec
28 Mar 2013   #36
mysterpda

Windows 7 x64
 
 

I have solved my USB copy problems on my Asus P8P67 Pro motherboard by updating the BIOS to the latest version.
My System SpecsSystem Spec
04 Apr 2013   #37
scharfet

Windows 7 Home Permium, Service Pack 1, 64bit
 
 

I get stuck at following poing:

Quote:
5. Type Administrators in the window with the blinking cursor, Click OK.
After clicking on OK as you mentioned in point 5 following widows appears.



it says:
-------------------------------------------
Can not find an object named "Administrators". Check the accuracy of the selected object types and location, and make sure you typed the object name correctly, or remove this object from the selection.

( ) Correct information object and search again

( ) Remove "Administrators" selection
--------------------------------------------

What do I have to do in this window?

Thank you for your help!
Hannes
My System SpecsSystem Spec
29 May 2013   #38
Xaelra

Windows 7 Home Premium
 
 
Thank you SOOO MUCH!

I've been trying to get my wireless mouse to work for almost a week now. This tutorial finally fixed it along with a few other devices that were giving me issues on the USB front. I can't say enough how much this helps me out, I hate using a touch pad and it's been driving me crazy!
My System SpecsSystem Spec
30 May 2013   #39
madcratebuilder

Win8/8.1,Win7-U64, Vista U64, uncounted Linux distor's
 
 

Quote   Quote: Originally Posted by Xaelra View Post
I've been trying to get my wireless mouse to work for almost a week now. This tutorial finally fixed it along with a few other devices that were giving me issues on the USB front. I can't say enough how much this helps me out, I hate using a touch pad and it's been driving me crazy!
+10

I Googled for days attempting to fix my wireless mouse stuttering. This fix made a 99% improvement.
My System SpecsSystem Spec
Comment

 USB Driver - General Fix for Problems




Tutorial Tools



Similar help and support threads for2: USB Driver - General Fix for Problems
Windows 7 Tutorial Category
Solved More driver problems Drivers
BSOD driver power state / Nvidia graphics driver problems BSOD Help and Support
Solved General HomeGroup problems Network & Sharing
Can't start up my computer. (Driver problems, BSOD, other problems) BSOD Help and Support
Anybody have problems dual booting or with partitions in general General Discussion
General Help with a few problems. General Discussion
Help - RAM Diagnostic Tool and General Win7 Problems General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:20 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33