Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Libraries - Hidden and Empty Fix

09 Dec 2011   #20
Brink
Microsoft MVP

64-bit Windows 10 Pro
 
 

Quote   Quote: Originally Posted by ronster11 View Post
Thank you very much for this tutorial. I had been dealing with this issue for a while now. Fixed now. Even tried Microsoft tech-no-support. I had this issue happen to me on all the profiles in computer. I use Mcafee do you think that is the issue ?
Quote   Quote: Originally Posted by Brink View Post
@Tamara
I'm happy to hear that you got it sorted.
@Ronster
You're welcome, and welcome to Seven Forums. It would be hard to say if McAfee was or not since it could have been anything that may have hidden them by mistake.
Quote   Quote: Originally Posted by ronster11 View Post
After running your fix my libraries were visible again so I thought it was fixed. However I noticed that they were dimm or a light gray. Also everytime I edit a file for example rotate a picture with windows photo viewer that picture would dissapear. I found out that mcafee is the culprit. There is a bug with mcafee that changes the attribute from the file thats being edited, and it changes the attribute to hidden. So if anyone else is having these issues you should contact their tech support so they can run a batch file they created to take care of the light gray library issue and the hidden attribute issue or you can visit their tech support forum their is a 45 page thread on this issue. Thought Id share this with you guys.
Ronster,

Thank you for posting back with your findings and results.


My System SpecsSystem Spec
31 May 2012   #21
FRUHD

Windows 7 Home Premium 64bit
 
 
yessssSsSss

Yay! I managed to get them to show up, but they were still hidden... wasn't until I ran the file that they showed up solid. Thanks
My System SpecsSystem Spec
05 Sep 2012   #22
MrsHDixon

Windows 7 home premium 64
 
 

Ahhhhhhhhhhh...I have things hidden in my Library! I never knew about the faded etc thingies before. Brink I can't tell you how much I thank you for all these new knowledge! TYTYTY! Going to play in the library now. *Shhhhh...tiptoes in to fix it*
My System SpecsSystem Spec
09 May 2014   #23
Gras

Win 7 Ultimate, SP1 64-bit
 
 
Missing Parts

I have been looking around for a solution to a problem that I have had for about 2 days. The Windows Library is missing and incomplete at times. I can restore the defaults, but it will eventually revert back to the way it was before, and I can't see disk drives etc. The other problem is that pictures load, but the icon is blank, and for videos it shows an empty white page.

I've tried the registry fixes I have seen, but it doesn't work for long. I cannot tell if this is a hardware issue or software related? I have Windows 7 Ultimate, 64 bit and I was wondering if anyone could help? Could this be a sign of a hard drive going bad, or ram problems? Maybe a virus?
Thanks!


Attached Thumbnails
-before-restore.jpg   -after-restore.jpg  
My System SpecsSystem Spec
.

09 May 2014   #24
Brink
Microsoft MVP

64-bit Windows 10 Pro
 
 

Hello Todd, and welcome to Seven Forums.

This appears to be some sort of issue with your navigation pane instead of Libraries.

As a test, use Option One or Option Two in the tutorial below to uncheck Show all folders to see how it displays in the navigation pane afterwards.

Navigation Pane - Show All Folders

Hope this helps for now,
Shawn
My System SpecsSystem Spec
09 May 2014   #25
Gras

Win 7 Ultimate, SP1 64-bit
 
 

Thank you Shawn for your response, and attempting to help with this.

I followed your link, and checked the show all folders box. I am not 100% sure it will fix it, because I don't mess around with those settings and it randomly displays everything all screwed up. As I mentioned, when the navigation pane goes funky it displays blank documents for videos instead of icons or thumbnails and nothing at all for pictures. I didn't post screenshots of that happening, but i will if it happens again.

BTW, It became apparent to me after I installed some Windows updates, and although I doubt it; could there be any sort of issue with that?
My System SpecsSystem Spec
09 May 2014   #26
Brink
Microsoft MVP

64-bit Windows 10 Pro
 
 

Could be. You might see if doing a system restore using a restore point dated before the issues may help if it happens again.
My System SpecsSystem Spec
09 May 2014   #27
Gras

Win 7 Ultimate, SP1 64-bit
 
 

I did do a system restore to before the updates, and I had the same problem. As it is right now, there's no issues and I will keep you updated if it happens again.
Thank You,
Todd
My System SpecsSystem Spec
09 May 2014   #28
Brink
Microsoft MVP

64-bit Windows 10 Pro
 
 

That's good news so far Todd.
My System SpecsSystem Spec
09 May 2014   #29
Gras

Win 7 Ultimate, SP1 64-bit
 
 

Do you think the issue might be due to either my cpu or ram, because it happened again while I could tell the computer was under heavy cpu usage? I have 8GB of ram and an AMD A6-3620 processor that's 2.2 Ghz. Also, I have been running 7 Ultimate since around December of last year, so its fairly new. I am guessing 7 Ultimate has different RAM requirements than 7 Home Premium. If that's the case, it's no big deal because I have been wanting to upgrade anyway.
My System SpecsSystem Spec
Comment

 Libraries - Hidden and Empty Fix




Tutorial Tools





Similar help and support threads
Windows 7 Tutorial Category
All folders in all libraries display as "empty" (but are not)
I just finished repelling a nasty rogue (HDD Repair). My system is clean, all of my files/folders/apps have been unhidden... everything is back to normal. Almost... All of my folders in all of my libraries say they are "empty" when the pointer hovers over them. The folders are not really empty;...
General Discussion
Libraries do not exist, not hidden
I am looking for an answer for a niece's computer. It is an HP laptop running win7 home premium. In the explorer view there is no libraries folder/icon. Only the upper favorites/desktop and icons that are normally right above the libraries folder. Below that is just a plain vanilla icon that...
General Discussion
Windows 7 Startup Folder Empty (visible, but empty)
My computer was hit a malware. I was able to clean/quarantine the malware, but my startup folder is empty. From the Windows logo start, I am able to see the folders in "All Programs". But all the folders are empty. These startup folders are also empty when I navigate to their locations in Window...
General Discussion
Hidden files in libraries
In my Pictures library, all my pictures are hidden and I can't unhide them...
Music, Pictures & Video
Hidden volumes empty or not?
Hi all, new forum member here :) (I’m currently training as a technician so advance apologies for any daft questions or omissions!) ............................................................................. Disk management/diskpart show that I've got 3 volumes - see attached...
General Discussion
My pc is not showing Hidden Folders even after enabling - "Show Hidden
My pc is not showing Hidden Folders even after enabling - "Show Hidden Files, Folders and files"... now here is how it goes... i open folder options in the explorer, and saw that none of the options "DON'T Show Hidden Files, Folders and files" or "Show Hidden Files, Folders and files" is...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:45.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App