Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with

01 May 2015   #280
ntsarb

Windows 8.1 Pro
 
 
Doesn't work with this setup

Hi,

I found the installation process in this thread very promising and I did give it a try but it doesn't work on my PC (ASRock X99 WS + i7 5820K).

I'm using Windows 7 Home Premium, OEM DVD. The activation key only works with the OEM version of Windows. Windows can be installed perfectly fine using BIOS.

When booting from the DVD with the motherboard set up in EUFI mode (Secure Boot Disabled, BIOS Compatibility Disabled), the boot process reaches the Windows animated Logo. At that point, sometimes it freezes completely, other times the logo is glowing forever - it never reaches the setup wizard.

I prepared a USB stick in accordance with the instructions and that doesn't work either (using the ISO I exported from the OEM DVD). I get a "Windows Boot Manager" error: "Windows failed to start. A recent hardware or software change might be the cause....", "File: \EFI\Microsoft\Boot\BSD", "Status: 0xc000000d", "Info: An error occurred while attempting to read the boot configuration data.". I have to options: Continue or Exit. Both take me to the firmware.

I suspect this is due to the OEM version of the DVD but I'd be grateful if other users could confirm. If we verify this, I'd be grateful if the article was updated, accordingly, so as to help other users - save time!

Many thanks!


My System SpecsSystem Spec
.
23 May 2015   #281
xylium

Windows 7 Home Premium x64
 
 

I am having issues with my new build and Windows 7 Home Premium x64 Retail. I first installed as standard MBR but decided I wanted to used the new GPT UEFI method. So I deleted all the partitions, converted to GPT, booted the Windows installer via the UEFI selection and proceeded with installation. I verified it was installed via UEFI by checking I had the System, MSR, and Windows Partitions. I also checked some log that indicated that the detected boot environment was EFI.

Everything is running fine but I plan on dual booting to OSX later and discovered I need to have CSM disabled. I contacted EVGA and asked them for a UEFI compatible BIOS and they gladly obliged. I went into my bios and turned CSM off. The computer will POST and starts loading Windows. The animated logo will show and just prior to showing the desktop, it reboots.

The bios gives the following message: "The current BIOS setting do not fully support the Windows UEFI mode. The CSM (Compatibility Support Module) settings have been changed for better compatibility. For further adjustments, press <F1> to enter BIOS Setup. If No adjustment are needed, press <F2> to confirm the current settings and enter OS directly."

I thought oh Great, now I have to reinstall. So before I wiped the drive again, I unplugged my SSD and storage drive to try installation to the 180GB drive I intend to use for OSX later. I again turned CSM off and tried booting to the UEFI Windows DVD. It does the same thing, just prior to showing the installer, it reboots. I'm not sure what is wrong. Do I have a Bios setting wrong? I updated all the drivers directly from the manufacturer for Intel and Nvidia. I'm pretty sure Secure Boot is turned off, I have "Other OS" selected. It still says Secure boot is enabled but not Loaded but I guess that's normal for Asus Bios's? I also turned off Fast Boot because I thought it doesn't work with Windows 7, not sure.

My hardware:
Asus Gryphon Z97 running latest BIOS
Intel 4690K Slightly OC'd
EVGA Geforce 660 FTW ACX w/ UEFI Bios
LG BluRay Drive
Samsung Evo 850 SSD 250GB
HGST 7K1000 Travelstar 1TB
Hitachi 180GB
My System SpecsSystem Spec
23 May 2015   #282
gregrocker

 

Disable Secure Boot fully.

CSM may not always allow UEFI install. Do you have the latest BIOS firmware?

Otherwise it may be an OSX issue for which you'd need to contact an Apple forums since we do not support that here.
My System SpecsSystem Spec
23 May 2015   #283
xylium

Windows 7 Home Premium x64
 
 

I actually haven't even touched OSX yet, that's a future project for the 180GB HD when I get around to it. I wanted to make sure Windows was setup properly before I even attempt that, I don't need to be compounding problems.

Yes, I have the latest BIOS, ver 2205

Do you know how to disable secure boot fully on Asus boards? I do not have an option for that and I thought I read somewhere that just selecting Other disables it. But then again I also read somewhere that you need to clear the keys. If I have to clear my keys and I need them later how do I get them back? Will a new set regenerate?
My System SpecsSystem Spec
.

23 May 2015   #284
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Fast startup and secure boot what a pain in the rear end.
My System SpecsSystem Spec
23 May 2015   #285
xylium

Windows 7 Home Premium x64
 
 

I fully disabled secure boot by saving the keys to an old jump drive and then clearing them. I still cannot boot windows with CSM disabled. Any ideas?
My System SpecsSystem Spec
23 May 2015   #286
xylium

Windows 7 Home Premium x64
 
 

I am using a Retail copy of Windows 7 x64 with no service pack. Could that be the issue?
My System SpecsSystem Spec
23 May 2015   #287
gregrocker

 

Possibly. Read Step 1 of Clean Reinstall Windows 7 about options to obtain the latest media.
My System SpecsSystem Spec
23 May 2015   #288
xylium

Windows 7 Home Premium x64
 
 

I am attempting to download a new copy from Microsoft right now. In case anybody is having issues, the link no longer works in anything but internet explorer.
My System SpecsSystem Spec
23 May 2015   #289
gregrocker

 

Thanks for that update. We have had lots of reports of Microsoft Software Recovery not working.
My System SpecsSystem Spec
Comment

 UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with




Tutorial Tools Search this Tutorial
Search this Tutorial:

Advanced Search




Similar help and support threads
Windows 7 Tutorial Category
How to install Windows 7 in UEFI Mode with a USB
Hey guys, I've never seen a full guide to installing Windows 7 in UEFI mode before anywhere, trust me I've looked. But I managed to pull it off a few days ago. So I thought I'd share it with you guys :) What you'll need: A Windows 7 64 bit ISO (doesn't matter what edition and can be an All in...
Installation & Setup
Install Windows 7 Ultimate x64 as UEFI with GPT
I bought a Samsung laptop (Model: NP350V5C-S0BIN) which came preinstalled with Windows 8. I dont like Windows 8 and want to install Windows 7. I have disabled FAST BOOT and SECURE BOOT. My questions are. 1) On disabling Secure Boot, I found three OS Selection Modes namely, "UEFI", "CSM...
Installation & Setup
Problems with UEFI windows 7 install!
Hi guys. I have been sitting with this problem for 3 days now. So, I just bought a HP Pavilion 15 notebook with a 1TB hard disk and a preinstalled windows 8. I absolutely HATE win 8 but nevertheless I need to keep it on my comp for certain things I might need to do in the future. And I want to...
Installation & Setup
Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)
**** This issue has been resolved **** **** Look at Page 4, posts 4 and 5 **** **** You need to enable Legacy MBR by Enabling Launch CSM in the EFI Setup **** Hello all, This is my first post. I am a Windows 7 user and now (against my will) Windows 8. I bought an ASUS N76 laptop...
Installation & Setup
How to use UEFI boot to install windows 7?
Hello, I bought a 3TB harddisk and I can only use 2TB of it I read some forum and it said I have to install windows by uefi boot And change format from mgb to gpt so I can use 3TB My motherboard is Asrock H81M I want to know how can I use uefi boot, I am total idiot in computer, thanks for...
General Discussion
What's the benefit of UEFI and install Windows in UEFI mode?
I am not sure if this subforum is the right place, if not, pleases help me transfer to the right forum... I recently just build a new setup with Asus P8Z77-V LK, this motherboard comes with UEFI boot and legacy BIOS boot support. So I tested install windows 7 in both mode, and I didn't find...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:50.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App