Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Icon Cache - Rebuild

21 Jun 2012   #120
dwilkows

Windows 7 Home Premium 64 bit
 
 
Clean Install Windows 7

I think I'll develop a tolerance for the little quirks of my existing Windows 7 rather than reinstall everything. Thanks for the education--it's much appreciated and I'll keep in on the back burner in case things deteriorate!


My System SpecsSystem Spec
21 Jun 2012   #121
Brink
Microsoft MVP

64-bit Windows 10
 
 

I don't blame you for only this issue.
My System SpecsSystem Spec
29 Jul 2012   #122
Frank1

Desk Top with Win 7 Home Premium 64 bit and Lap Top with Windows 8.1 Pro 64 bit
 
 

Downloading and running the Rebuild_Icon_Cache.bat solved the problem for me.
Thanks
My System SpecsSystem Spec
29 Jul 2012   #123
Brink
Microsoft MVP

64-bit Windows 10
 
 

You're welcome Frank. I'm happy to hear it was able to help.
My System SpecsSystem Spec
.


10 Aug 2012   #124
Sigma

Windows 7 Professional x64
 
 

Amazing. I simply downloaded and ran the .bat file and voila my problem was instantly solved!

Thanks a lot, you're a lifesaver!
My System SpecsSystem Spec
10 Aug 2012   #125
Brink
Microsoft MVP

64-bit Windows 10
 
 

You're most welcome Sigma, and welcome to Seven Forums.
My System SpecsSystem Spec
13 Aug 2012   #126
snurfer

(1)Microsoft Windows 7 Home Premium 64-bit (2) Windows 8
 
 

Awesome! Thank you very much for the quick fix! I manually rebuilt the cache and now I have my icons back. You have a ton of good tutorials on here and this is definitely one of them!
My System SpecsSystem Spec
13 Aug 2012   #127
Brink
Microsoft MVP

64-bit Windows 10
 
 

You're most welcome Snurfer. I'm glad that it was able to help.
My System SpecsSystem Spec
02 Sep 2012   #128
grillmaster423

Windows 7
 
 
Simply Awesome

Just edited imageres and windows would not load the ico group properly.

A run of your script and boom, tadah, shazaam.

Thanks a bunch bud.
My System SpecsSystem Spec
02 Sep 2012   #129
Brink
Microsoft MVP

64-bit Windows 10
 
 

You're most welcome grillmaster. I'm happy to hear it was able to help.
My System SpecsSystem Spec
Comment

 Icon Cache - Rebuild




Tutorial Tools





Similar help and support threads
Windows 7 Tutorial Category
How to rebuild system icon ?
Hello :) First sorry for my bad english :( I hope That will it be understandable. So, i got a problem with icon in my documents in Windows 7 Home Premium It looks like normal directory, not like windows desktop. Any chance for recovering this icon or something? Thanks for help
Customization
how to rebuild the cache for iconcache.db and readthe error log
Recently firefox icon is not being displayed with the .htm files and as per the instruction i tried to rebuild the cache but the iconcache.db is not present so how to rebuild or get back the same and there are several errors in the windows also and in the registry please some one send the name of...
Performance & Maintenance
Icon Cache Problems
I tried to rebuild my icon cache with one of your tutorials. Now my icons just have the name underneath(no blank page thing). My task bar doesn't show icons and my start button does nothing when pressed. Please helpppp!!!!!
General Discussion
Automatically rebuild icon cache problem?
Originally had this problem a while back (http://www.sevenforums.com/general-discussion/119880-spywareblasters-icon-generic-taskbar.html)-generic icon for Spywareblaster file application and for taskbar pinned shortcut, but it was solved. Now for some strange reason, Spywareblaster's icon has...
General Discussion
Icon Cache Issues
On my previous installation of Windows 7, I frequently got a corrupt icon cache. The shortcut icon which I had removed from the icons would get replaced by a black box. Clearing the cache would fix it but eventually it'd happen again. Now, on b7600, I'm having a similar issue. For some...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:27.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App