Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Manage - Fix "File does not have a program associated"

23 Jun 2010   #10

64-bit Windows 10 Pro


Download and merge the reg option in the tutorial below to add it back to the registry, and hopefully allow you to be able to user the one here.

Default File Type Associations - Restore

My System SpecsSystem Spec
27 Jun 2010   #11

windows 7

I dont have a merge option when i right click
My System SpecsSystem Spec
27 Jun 2010   #12

64-bit Windows 10 Pro

Hello Rodekyll,

Double check in Default Programs to make sure that the .reg file extension has it's "Current Default" program set as Registry Editor (C:\Windows\regedit.exe). Afterwards, see if you are able to merge it.

Hope this helps,
My System SpecsSystem Spec
27 Jun 2010   #13

windows 7

I went and manually put in the IsShortcut and still nothing there is no .reg or .exe in the default and when I download all the file in the tutorial there is no option for merge there is also no .reg in the regedit
My System SpecsSystem Spec

27 Jun 2010   #14

windows 7

The only options I get when i right click are the following open norton internet security, restore previous version cut copy create shortcut delete rename properties. This is very fustrating
My System SpecsSystem Spec
27 Jun 2010   #15

64-bit Windows 10 Pro


As a test, temporarly disable or uninstall Norton to see if you have this issue afterwards.

If you do not have an exe or reg entry in the registry, then you may be infected with a virus or some other malware. I would recommend scanning your computer with a good antivirus program, and a good anti-malware program like the free Malwarebytes.

Afterwards, see if doing a system restore at boot using a restore point dated before you had this issue may be able to fix this for you.
My System SpecsSystem Spec
22 Aug 2010   #16

Windows 8 (64bit)
It Works!

thanks for the tutorial.
It works for me. I've been looking for this fix for a looooong time!

Thanks once again!
My System SpecsSystem Spec
22 Aug 2010   #17

64-bit Windows 10 Pro

You're most welcome Henry, and welcome back to Seven Forums.
My System SpecsSystem Spec
15 Oct 2010   #18

Windows 7 Ultimate 64 bit

Here is another workaround :
Go to :
and modify the existing value in
mmc %SystemRoot%\system32\compmgmt.msc
Works at once , no need to reboot .
Best regards ,
Fanaudi .
My System SpecsSystem Spec
15 Oct 2010   #19

64-bit Windows 10 Pro

Thank you Fanaudi. I have added this into the tutorial to cover this as a possible cause as well.
My System SpecsSystem Spec

 Manage - Fix "File does not have a program associated"

Tutorial Tools Search this Tutorial
Search this Tutorial:

Advanced Search

Similar help and support threads
Windows 7 Tutorial Category
How do I associate an "unknown file type" to a program?
Long story short, I used Handbrake to add soft subtitles to some video clips and the finished result are "unknown file types" which I have to open with vlc every time, the "Always use the selected program to open this kind of file box is greyed out. The first file is a .m4v file and Handbrake...
Performance & Maintenance
I get a file name warning for some folder called "C:\Program" ?
Today I started my computer and when I reached the desktop this little message popped up: File name warning. There is a file or folder on your computer called "C:\Program" which could cause certain applications to not function correctly. Renaming it to "C:\Program1" would solve this problem. Would...
General Discussion
Cant find "System Image" of 36 GB but its shows on "Manage Disc Space"
Dear Experts, I have created windows image on Drive F: but delete it after some time manually due to some space prob. But while backup shows about 40 GB only few GB space got free after deletion. When i try to again take the the backup using windows 7 backup & restore option, its still shows 35...
Backup and Restore
Random program "save file" popping up?
In the last 2 hours, I've gotten 2 messages like this: One was for Google Chrome, one was for MSI Afterburner. These are both programs I have installed on both of my hard drives, so one hard drive is not the problem. The directories they...
How To Solve the "the program cannot access the file..." message
Recently, for the umpteenth time, I tried the Windows DVD Maker and it actually worked! However, on the next attempt I get: "The program cannot access the file because it is being used by another program" I am burning a dvd-rw with several files, but I am not told which one is being...
Hardware & Devices
Get "open in another program" error when moving file
Thank you for your help. Sometimes when I want to move a folder, I receive the following message: "The action can't be completed because the folder or a file in it is open in another program..." This is frequently caused by a Thumbs.db file, which I believe generates thumbnail images. Is...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:39.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App