Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Force DVI/HDMI resolutions and refresh rates

02 Feb 2011   #260

Windows 7 Ultimate x64

It seems that this problems are very very common just found someone whos hdmi ports (2 of them) failed in the same way. The hmdi inputs where working one day and the next one they didnt. Its the same problem i have.
Check this at here.

Quote   Quote: Originally Posted by chivoX View Post
Hello guys, I will highly appreciate your assistance.
I am sure that there are many topics about this but I think I have read most of them and didn't find the solution to my problem.

Recently I have purchased a new Sharp AQUOS LCD 32'' (HD ready, 2 HDMI ports etc.). I have NVIDIA GeForce 9500GT 512RAM (it has VGA, DVI and S-Video output), the current driver is 181.20 (I think the latest). In order to connect the PC with the TV I have purchased a 5m cable DVI-HDMI. The first time I connected the PC and the TV, I started the NVIDIA TV Wizard / Display Wizard - it has detected the HDMI and asked for resolution..., everything went smooth and I have successfully setup a Dualview and Clone modes (I was able to set the HDMI format to 1080i).

Couple of days later, I started the PC and I noticed that my mouse doesn't move out of the primary display. I started the TV to the correct input and there was no signal, when I went to the NVIDIA Control Panel the Sharp TV was not listed. This was very strange and I started testing different settings, resolutions, rebooting, changing the HDMI port etc. Once I changed the HDMI port, I was able to run new Display Wizard which asked me for the HDMI format and it was ok (after numerous tests). Then I tried changing to the first HDMI port and everything was fine for another couple of days.

Now I had to make some house arrangements and I had to disconnect the TV. When I connected everything as it was there was no signal.
I tried running the wizard once again without any success. It seems that now the NVIDIA is not receiving any signal from the TV, there is no Sharp TV recognized and the only thing I can see when I try to setup multiple displays is simply TV. The Television Setup Wizard says that this is TV, Connector type: Auto-select, Signal type: M/NTSC

I can no longer detect the HDMI signal (on both HDMI ports) and I don't have any ideas how and why this has happened - it was working fine!!!

Does anyone had such issue and is there any solution to this? Is the problem with NVIDIA dirvers or something else? I will be glad to receive suggestions and some basic step-by-step guide to fix this problem.

I just left my TV in a service center to see if they could fix it since i tried everything on this guide with no results.

Im even thiking about buying a new TV since the LG`s seem to have lots of HDMI issues.

Something extra, i tried to use my hdmi cable with a new Sony HDTV and it works so its not a cabling issue my hdmi sony cable works. Its definitely a problem with the hdmi port. Everything else is working, component and A/V inputs are working.

And I also found this. Something called hdmiOn a program wich resends the EDID to revive your connection. Hope this helps someone. Check it out here.

Any help ??


My System SpecsSystem Spec
02 Feb 2011   #261

Envision G22LWk EDID broken?


I need some help please! I've scoured the internet and keep coming back to this forum, but I can't get anything working correctly for my Envision 22" LCD, model G22LWk.

1. Any 3rd party program I've tried doesn't see any EDID for my monitor. They will not pull one from the monitor directly, and they do not see one in the Windows Registry. I've tried modifying the Envision .INF file but it doesn't seem to do anything.

2. The MAIN issue is tearing. Tears bad when gaming, tears bad when watching movies, tears bad when movement occurs in general like dragging windows around.

3. I first thought it was limited to my 3D applications like games, but it's not. The screen tears and doesn't run correctly.

4. Windows shows a resolution possible of 1680 x 1050 @ 32 bit color. nVidia Control Panel shows a "native" resolution of 1680 x 1050 @ 16 bit color.

5. I should state I'm using DVI cables for BOTH monitors, and programs like MonInfo and PowerStrip DO see my secondary DELL 1707FP LCD's EDID.

6. I tried calling Envision, and the tech stated that they do not have Windows 7 drivers for my G22LWk. I said I realize that, and that I wanted them to send me a file of the EDID info the screen should have. He said no, ie. they want me to buy a new monitor instead of looking at the one I purchased as an investment, ie. I'm never buying another Envision device in my lifetime.

7. The biggest issue is this: I cannot edit the EDID info for this G22LWk screen as shown in your tutorial if these 3rd party programs don't see an EDID to edit in the first place, and editing Hex code manually from scratch is well beyond my capabilities.

8. From what I can tell, nVidia's custom timings are fighting Windows 7 concerning the 59Hz vs. 60Hz. Windows 7 sees the G22LWk as either a "Generic plug-n-play device," or a "Display Device on DVI" depending on whether I manually install the driver from Envision.

9. The Envision driver doesn't seem to help anything, and the tech saying there are no drivers for this screen for Windows 7 confirms it.

10. I did try to manually edit the Envision INF, but I'm not sure it changed anything.

Here is a copy of the stock Envision .INF:

; Envision INF File for Windows(R) 95/98/Me/2000/XP/Server 2003/XP/Vista x64
; Revision Date: Jan 25,2007

CatalogFile =G22LWk.CAT




DefaultDestDir= 11











Envision="Envision Peripherals, Inc."

G22LWk="Envision G22LWk"

I'm not sure what to do, and ANY reply would be greatly appreciated, thanks!
My System SpecsSystem Spec
05 Feb 2011   #262

Windows 7 Ultimate x64

the hdmi port was damaged form the inside . it seems like someone pulled it to hard.
My System SpecsSystem Spec
12 Feb 2011   #263

Win7 x64 Pro

I'm trying to make an .inf file to EDID override my Acer GH245HQ inf. I've used Phoenix/Moninfo to create the new inf but "Have Disk" will not let me load the file. Windows just beeps when i click "open" on the openfile dialog. Any idea why Win7 x64 won't allow me to install the override .inf?

What i am trying to do is create an inf that only has the 1920x1080@120 timing available in the hope that this will force Eyefinity to run at 120hz for my racing game addiction. Since it seems ATI hasn't quite made CCC capable of doing this the easy way!

My System SpecsSystem Spec

12 Feb 2011   #264

El Capitan / Windows 10

Quote   Quote: Originally Posted by gameover350 View Post
I'm trying to make an .inf file to EDID override my Acer GH245HQ inf. I've used Phoenix/Moninfo to create the new inf but "Have Disk" will not let me load the file. Windows just beeps when i click "open" on the openfile dialog. Any idea why Win7 x64 won't allow me to install the override .inf?

What i am trying to do is create an inf that only has the 1920x1080@120 timing available in the hope that this will force Eyefinity to run at 120hz for my racing game addiction. Since it seems ATI hasn't quite made CCC capable of doing this the easy way!

Open Start, type PSR and press enter. Start recording and record the steps you're taking to install the INF. Post results here. Thanks!
My System SpecsSystem Spec
13 Feb 2011   #265

Win7 x64 Pro

i've since discovered that Eyefinity cannot do 120hz regardless of EDID override, so i'm moving back to nVidia hardware that has 120hz capability. Thanks for the offer of support!

My System SpecsSystem Spec
13 Feb 2011   #266

Win7 x64 Pro

BTW, i at least solved the beeping when trying to install the .inf

It seems win 7 x64 doesn't like using the My Docs folder for them, i moved it to c:\ and it loaded right up.

still didn't solve my eyefinity problem but at least got the inf loading.

My System SpecsSystem Spec
03 Mar 2011   #267

Windows 7 Ultimate x64

Hi guys, i'm really desperate, i've done everything the tutorial says to change the refresh rate but i get an error when i try to switch to it
my monitor is Philips 107E, a CRT one,
i prefer 1024x768@100 Hz, in windows XP it works perfect
in Win 7 it doesnt

so,the error i get is
something about frequency range not beeing good..its a black screen

please help
My System SpecsSystem Spec
07 Mar 2011   #268

Windows 7 Ultimate x64
Problems WIN7 x64 - Medion 1772LA

Hey guys,

it took me hours to find soemthing like a "semi-solution" for my CRT in Windows 7 x64...
(Excuse me for my "strange" english, but I'm a foreign person.)

But one after the other:

1) Downloaded: - softmccs - pheonix - moninfo.exe
2) Got Monitor-Information with softmcs (but no DDC/CI)
3) Removed pin Number 7. (I have VGA-DVI)
4) At last (after a long experience) got a new *.inf.
5) Rebooting with the new *.inf installed meant "60 HZ-BUG". So I changed back to only nonPNP-Monitor. But it's hard to force the right rates. I can only manage this with ATI-Tray Tools; and only if I change the rates manually. I can't force to fix the rates.
Nearly every rate from 640x480 to 1600x1200 is shown, but I only need the rates till 1280x1024.
Very important for me are 1280x960 and 1280x720.

Maybe someone can make an inf for me which can solve this! That would be so nice!

A list of supported displays with refresh rates (although in the attached manual): 640x480 - 120 hz
800x600 - 100 hz
1024x768 - 85 h
1152x864 - 75 h
1280x720 - 85 h
1280x960 - 72 h

(If nearly all "normal" display-rates are shown till 1280x1024 would be nice!)

I have attached a manual (it`s not 100% the same monitor, but it's from the same manufacter and I think it has the same data.)
And the *.inf that I created. Renamed it in pdf, because got error when trying to attach it as inf.

Attached Files
File Type: pdf bda1772lbde.pdf (137.8 KB, 489 views)
File Type: pdf supermonitor.pdf (2.2 KB, 107 views)
My System SpecsSystem Spec
12 Mar 2011   #269

Windows 7 Ultimate x64

Forget about my first post.

I got it!

Two things that are a little annoying (The Rest is fine!):

1) I can only play games with max. refresh-rate if I put the desktop to the same resolution.
I want to get through that by staying always at 1024x768 at Desktop.

2) I am using ATI TRAY TOOLS. When I start the PC everything is fine, but little time before the task-symbol of ATT appears the monitor gets black and seems to switch. That takes about 3 seconds and than it is Ok. If I use standard-nPn-monitor drivers it does not appear.
What can I do to solve that?

(Attached working dat and inf)

TY for help!

Attached Files
File Type: rar supermonitor(inf).rar (998 Bytes, 100 views)
File Type: rar MED0427(dat).rar (336 Bytes, 79 views)
My System SpecsSystem Spec

 Force DVI/HDMI resolutions and refresh rates

Tutorial Tools Search this Tutorial
Search this Tutorial:

Advanced Search

Similar help and support threads
Windows 7 Tutorial Category
How can I limit refresh rates?
I seem to have an issue opposite of what is normally desired. In my case, my monitor only supports 60Hz but some 3D apps try to change the refresh rate to something higher, leaving only "Out of Range" displaying on my monitor. So, I need to find a way to make Windows 7 only use 60Hz. My video...
Graphic Cards
Same monitor refresh rates on A/C and battery
I am using a Dell Latitude E5520-4 laptop, and a few days ago I found out that the refresh rate of the laptop's monitor was changed to 40 Hz. I changed it back to 60Hz, but ever since everytime I plug out the charger, the monitor flashes for a few seconds, and it changes back to 40Hz. When I plug...
Graphic Cards
Monitor refresh rates problem
My monitor is SyncMaster 793DF(Samsung). Problem is : I can't see my current refresh rates only I can see the "default setting " . I want to see my current refresh rates and change it ? note : i have already install monitor driver. (If I post this Thread wrong section then plz swap it ) ...
Graphic Cards
CRT monitor - refresh rates disappeared
So I have Win 7 RTM and my iiyama MM904UT doesn't have any refresh rates except 75 and 85. I never installed monitor driver before - I didn't even know that they are there. So windows 7 automatically installed it and seems like problem. Because i need to set 60Hz here. I tryed to uninstall driver...
Refresh rates on LCD monitors
I just picked up a new monitor. It's a Samsung 2033 SW. 1600 X 900 with a 5Ms response time. It's only giving me one option. 60 hertz. Is this normal? My...
Graphic Cards
HELP: Cannot change refresh rates on Win 7 (CRT-monitor
Hi People Im having a weird issue....I ve worked in tech supp before but I m unable to find an answer to this one: System specs: C2D 3.0ghz, 2 gb ram, 1000mhz, OS WIn 7 64 bit RC 7100, Graphics-8600GT Now Im using an old monitor LG 700s, and for some weird reason I cannot change the...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:29.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App