Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Force DVI/HDMI resolutions and refresh rates

27 Apr 2009   #299
baarod

Windows 7 Ultimate 64-bit
 
 
Force DVI/HDMI resolutions and refresh rates

How to Force DVI or HDMI Resolutions and Refresh Rates in Windows 7

...

My System SpecsSystem Spec
.

09 Jul 2012   #300
badugi

Windows 7 home premium 64bit.
 
 

I have a crt monitor hp p1230 and it has 140khz horizontal refresh rate max. I just want to get up to 240hz vertical refresh rate at 640x480. Is that possible if I did the pin removal guide? I tried using powerstrip, but that gave me out of sync. If not is there any other way? or is it just impossible?
Please dont ask why i'm doing this, just answer the question plz.

My System SpecsSystem Spec
.

29 Jul 2012   #301
todexfalle

Windows 7 Ultimate x64
 
 

Can u help me guys. I have a samsung CRT monitor with Windows 7 x64. Problem is the same about 100hz. I cant change my resolution 1024*768 with 100Hz. I did all of things but here is my problem
-Change the EDID settings to reflect you display's true capabilities :
how can change my capabilities actually where did i know my monitors true capability ? thanks your advice

my monitor : Samsung 757mb
My System SpecsSystem Spec
16 Sep 2012   #302
maiaibing

win7 64 bit
 
 
Need help: Force HDMI to show 1900x1200

A little long, but want to make sure I give all relevant info:
Tried again and again to force the HDMI to show a higher resolution using the "INF"-method. But my problem is that when I want to select my "new" improved INF-file it does not load at the "have disk" pop-up window. I can see it there alright. But no dice... Tried many versions of "home grown" INF's to make sure I was not making a mistake but every time I get stuck when trying to select it.

Here's the problem: I have a high end EIZO bought while I lived in Japan where the DVI connection has died on me (no idea why - and its NOT the video card which I already changed). The model is not sold here in Europe so no EIZO repair possible. The HDMI connection works fine and I can get 1900x1080 in excellent quality. What I cannot have is 1900x1200. I am "sure" this is due to some kind of EDID limitation.

Sadly ATI CCC will let me override EDID on a VGA connection - but not HDMI.

Clues/suggestions would be very welcome!!!!!

I will continue to post all that I can imagine could be relevant for identifying the problem:

1a) My home made INF file using Barood's excellent guide:

Code:
 
; INF file generated by Monitor Asset Manager (2.60.0.972), 15-09-2012
; Copyright (c) EnTech Taiwan, 1995-2011.
; Internet: EnTech Taiwan
 
[Version]
Signature="$WINDOWS NT$"
Class=Monitor
ClassGUID={4d36e96e-e325-11ce-bfc1-08002be10318}
Provider=%MFG%
DriverVer=15-09-2012, 1.0.0.0
;CatalogFile=YourSignedCatalogFile.cat
 
[DestinationDirs]
DefaultDestDir=23
 
[SourceDisksNames]
1=%DISC%
 
[SourceDisksFiles]
;YourColorProfileFile.icm
 
[Manufacturer]
%VENDOR%=EDID_OVERRIDE,NTx86,NTamd64
 
[EDID_OVERRIDE.NTx86]
%PRODUCTID%=OVERRIDDEN-EDID.Install, MONITOR\ENC1973
 
[EDID_OVERRIDE.NTamd64]
%PRODUCTID%=OVERRIDDEN-EDID.Install.NTamd64, MONITOR\ENC1973
 
[OVERRIDDEN-EDID.Install.NTx86]
DelReg=DEL_CURRENT_REG
AddReg=OVERRIDDEN-EDID.AddReg, MODE1, DPMS
CopyFiles=OVERRIDDEN-EDID.CopyFiles
 
[OVERRIDDEN-EDID.Install.NTamd64]
DelReg=DEL_CURRENT_REG
AddReg=OVERRIDDEN-EDID.AddReg, MODE1, DPMS
CopyFiles=OVERRIDDEN-EDID.CopyFiles
 
[OVERRIDDEN-EDID.Install.NTx86.HW]
AddReg=OVERRIDDEN-EDID_AddReg
 
[OVERRIDDEN-EDID.Install.NTamd64.HW]
AddReg=OVERRIDDEN-EDID_AddReg
 
[OVERRIDDEN-EDID_AddReg]
;Base EDID
HKR,EDID_OVERRIDE,"0",0x01,0x00,0xFF,0xFF,0xFF,0xFF,0xFF,0xFF,0x00,0x15,0xC3,0x73,0x19,0x01,0x01,0x01,0x01,0x0D,0x12,0x01,0x03,0x80,0x34,0x21,0x78,0xEA,0xEF,0x95,0xA3,0x54,0x4C,0x9B,0x26,0x0F,0x50,0x54,0xA1,0x08,0x00,0xA9,0x40,0x81,0x80,0x81,0x40,0xB3,0x00,0xD1,0x00,0x01,0x01,0x01,0x01,0x01,0x01,0x28,0x3C,0x80,0xA0,0x70,0xB0,0x23,0x40,0x30,0x20,0x36,0x00,0x07,0x44,0x21,0x00,0x00,0x1E,0x8C,0x0A,0xD0,0x8A,0x20,0xE0,0x2D,0x10,0x10,0x3E,0x96,0x00,0x00,0x00,0x00,0x00,0x00,0x18,0x00,0x00,0x00,0xFD,0x00,0x3B,0x3D,0x0F,0x44,0x0F,0x00,0x0A,0x20,0x20,0x20,0x20,0x20,0x20,0x00,0x00,0x00,0xFC,0x00,0x48,0x44,0x32,0x34,0x35,0x32,0x57,0x0A,0x20,0x20,0x20,0x20,0x20,0x01,0xF3
 
[DEL_CURRENT_REG]
HKR,MODES
HKR,EDID_OVERRIDE
HKR,,MaxResolution
HKR,,PreferredMode
HKR,,DPMS
HKR,,ICMProfile
 
[DPMS]
HKR,,DPMS,,1
 
HKR,,PreferredMode,,"1920,1200,60"
[MODE1]
HKR,,MaxResolution,,"1920,1200,60"
 
[OVERRIDDEN-EDID.AddReg]
HKR,"MODES\1920,1200,60",Mode1,,"15.0-68.0,59.0-61.0,+,+"
 
[OVERRIDDEN-EDID.CopyFiles]
;YourColorProfileFile.icm for non-sRGB displays
 
[Strings]
MFG="EnTech Taiwan"
DISC="Monitor EDID Override Installation Disk"
PRODUCTID="Eizo HD2452W (ENC1973 EDID Override)"
VENDOR="Eizo"

1b) Moninfo screen DUMP
I have noticed the DDC/CI "Not supported" line - is this the problem???


2a) MONINFO screendump ii with the dreaded 1920x1080 limitation...



2b) DDI/CI Communibcation log - screendump i




3) DDI/CI Communibcation log - screendump ii



3) Finally, an original monitor INF file for this screen from Windows 7 (I think Windows 7 as default just uses the standard INF file for this monitor, but maybe some clues here??)

Code:
 
; [HD2452W.INF]
; Revision 1.10
; Copyright(c) 2008 EIZO NANAO CORPORATION
;
 
[Version]
signature="$CHICAGO$"
Class=Monitor
ClassGuid={4D36E96E-E325-11CE-BFC1-08002BE10318}
Provider=%EIZONANAO%
CatalogFile=HD2452W.cat
DriverVer=04/11/2008,1.10
 
[ControlFlags]
ExcludeFromSelect.nt = Monitor\ENC1980
ExcludeFromSelect.nt = Monitor\ENC1979
 
[ClassInstall32]
AddReg=ClassAddReg32
 
[ClassAddReg32]
HKR,,,,%MonitorClassName%
HKR,,Icon,,"-1"
HKR,,NoInstallClass,,1
 
[DestinationDirs]
DefaultDestDir = 11
;
HD2452W.CopyFiles = 23
 
[SourceDisksNames]
1=%Disk1%,,,
 
[SourceDisksFiles]
HD2452W Custom 6500K G2.2.icm=1
 
[Manufacturer]
%EIZONANAO%=EIZONANAO, NTamd64, NTia64
 
[EIZONANAO]
%HD2452WD%=HD2452WD.Install, Monitor\ENC1980
%HD2452W%=HD2452W.Install, Monitor\ENC1979
 
[EIZONANAO.NTamd64]
%HD2452WD%=HD2452WD.Installamd64, Monitor\ENC1980
%HD2452W%=HD2452W.Installamd64, Monitor\ENC1979
 
[EIZONANAO.NTia64]
%HD2452WD%=HD2452WD.Installia64, Monitor\ENC1980
%HD2452W%=HD2452W.Installia64, Monitor\ENC1979
 
[HD2452WD.Install]
DelReg=DEL_CURRENT_REG
AddReg=HD2452WD.AddReg, 1920, DPMS
CopyFiles=HD2452W.CopyFiles
 
[HD2452W.Install]
DelReg=DEL_CURRENT_REG
AddReg=HD2452W.AddReg, 1920, DPMS
CopyFiles=HD2452W.CopyFiles
 
[HD2452WD.Installamd64]
DelReg=DEL_CURRENT_REG
AddReg=HD2452WD.AddReg, 1920, DPMS
CopyFiles=HD2452W.CopyFiles
 
[HD2452W.Installamd64]
DelReg=DEL_CURRENT_REG
AddReg=HD2452W.AddReg, 1920, DPMS
CopyFiles=HD2452W.CopyFiles
 
[HD2452WD.Installia64]
DelReg=DEL_CURRENT_REG
AddReg=HD2452WD.AddReg, 1920, DPMS
CopyFiles=HD2452W.CopyFiles
 
[HD2452W.Installia64]
DelReg=DEL_CURRENT_REG
AddReg=HD2452W.AddReg, 1920, DPMS
CopyFiles=HD2452W.CopyFiles
 
[DEL_CURRENT_REG]
HKR,MODES
HKR,,MaxResolution
HKR,,DPMS
HKR,,ICMProfile
 
[1920]
HKR,,MaxResolution,,"1920,1200"
 
[DPMS]
HKR,,DPMS,,1
 
[HD2452WD.AddReg]
HKR,"MODES\1920,1200",Mode1,,"31.0-76.0,59.0-61.0,+,-"
HKR,,ICMProfile,0,"HD2452W Custom 6500K G2.2.icm"
 
[HD2452W.AddReg]
HKR,"MODES\1920,1200",Mode1,,"31.0-80.0,56.0-76.0,+,-"
HKR,,ICMProfile,0,"HD2452W Custom 6500K G2.2.icm"
 
[HD2452W.CopyFiles]
HD2452W Custom 6500K G2.2.icm
 
[Strings]
MonitorClassName="Monitor"
EIZONANAO="EIZO NANAO"
Disk1="EIZO LCD Utility Disk"
 
HD2452WD="HD2452W Digital"
HD2452W="HD2452W Analog"
My System SpecsSystem Spec
13 Nov 2012   #303
minke011

win 7 ultimate 64bit
 
 
Thanks

This article was very helpful. I was struggling to solve resolution problem for whole day until I found this post. Thank you very much.
My System SpecsSystem Spec
26 Nov 2012   #304
L Denton

Win7 64
 
 
Adapting instructions to Elgato HDMI capture card.

I've been trying to adapt these instructions for my uses, though not with such success as others. I have an Elgato Game Capture HD which I want to use to record the HDMI output of my computer.

The elgato is capable of accepting 1080p at 60 frames per second, this is both by specification and in my practical tests (hooked it up to my Xbox 360 running at that resolution). But either the Elgato's EDID isn't reporting the full capabilities of the device or my Radeon 6870 isn't reading them correctly. There isn't an option for 1080p output when the Elgato is plugged in, so I tried the instructions here.

I got the EDID fine (EGA0001) and added a standard timing block in Phoenix with the attributes; 1920 image width, 16:9 and 60hz. Installed it using Have Disk and restarted. Unfortunately, I encountered a blue screen at every boot and had to roll back to a previous recovery state.

I'm keen to get this working, but I'm not sure where to start tweaking values.

Follow up while writing; I was writing this post on my laptop (Radeon Mobile 4500) and wanted to see if the HDMI port here might show different results, and to my surprise, it did. I can output 1080p to the HDMI at 59hz and it records without issue. I think I can say I'm definitively stumped.

Here's the report from Moninfo;

Code:
Monitor
  Model name............... Elgato
  Manufacturer............. EGA
  Plug and Play ID......... EGA0001
  Serial number............ n/a
  Manufacture date......... 2012, ISO week 42
  Filter driver............ None
  -------------------------
  EDID revision............ 1.4
  Input signal type........ Digital
  Color bit depth.......... 10 bits per primary color
  Color encoding formats... RGB 4:4:4, YCrCb 4:4:4, YCrCb 4:2:2
  Aspect ratio (portrait).. 1:1.01
  Power management......... Not supported
  Extension blocs.......... 1 (CEA-EXT)
  -------------------------
  DDC/CI................... Not supported

Color characteristics
  Default color space...... Non-sRGB
  Display gamma............ 2.20
  Red chromaticity......... Rx 0.640 - Ry 0.340
  Green chromaticity....... Gx 0.300 - Gy 0.690
  Blue chromaticity........ Bx 0.138 - By 0.038
  White point (default).... Wx 0.282 - Wy 0.297
  Additional descriptors... None

Timing characteristics
  Horizontal scan range.... 25-70kHz
  Vertical scan range...... 23-61Hz
  Video bandwidth.......... 150MHz
  CVT standard............. Not supported
  GTF standard............. Not supported
  Additional descriptors... None
  Preferred timing......... Yes
  Native/preferred timing.. 1920x1080p at 60Hz (16:9)
    Modeline............... "1920x1080" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync

Standard timings supported
    1280 x  720p at  60Hz - VESA STD
    1920 x 1080p at  60Hz - VESA STD

EIA/CEA-861 Information
  Revision number.......... 3
  IT underscan............. Supported
  Basic audio.............. Supported
  YCbCr 4:4:4.............. Supported
  YCbCr 4:2:2.............. Supported
  Native formats........... 4
  Detailed timing #1....... 1440x480i at 60Hz (16:9)
    Modeline............... "1440x480" 27.000 1440 1478 1602 1716 480 488 494 524 interlace -hsync -vsync
  Detailed timing #2....... 720x480p at 60Hz (16:9)
    Modeline............... "720x480" 27.000 720 736 798 858 480 489 495 525 -hsync -vsync
  Detailed timing #3....... 1280x720p at 60Hz (16:9)
    Modeline............... "1280x720" 74.250 1280 1390 1430 1650 720 725 730 750 +hsync +vsync
  Detailed timing #4....... 1920x1080i at 60Hz (16:9)
    Modeline............... "1920x1080" 74.250 1920 2008 2052 2200 1080 1084 1094 1124 interlace +hsync +vsync

CE video identifiers (VICs) - timing/formats supported
    1920 x 1080i at  60Hz - HDTV (16:9, 1:1) [Native]
    1280 x  720p at  60Hz - HDTV (16:9, 1:1)
     720 x  480p at  60Hz - EDTV (16:9, 32:27)
     720 x  480p at  60Hz - EDTV (4:3, 8:9)
     720 x  576p at  50Hz - EDTV (16:9, 64:45)
    1280 x  720p at  50Hz - HDTV (16:9, 1:1)
    1920 x 1080i at  50Hz - HDTV (16:9, 1:1) [Native]
     720 x  576i at  50Hz - Doublescan (16:9, 64:45)
     720 x  480i at  60Hz - Doublescan (16:9, 32:27)
     720 x  480i at  60Hz - Doublescan (4:3, 8:9)
     720 x  576p at  50Hz - EDTV (4:3, 16:15)
     720 x  576i at  50Hz - Doublescan (4:3, 16:15)
    1920 x 1080p at  25Hz - HDTV (16:9, 1:1) [Native]
    1920 x 1080p at  30Hz - HDTV (16:9, 1:1) [Native]
    1920 x 1080i at  50Hz - HDTV (16:9, 1:1)
    1920 x 1080p at  50Hz - HDTV (16:9, 1:1)
    1920 x 1080p at  60Hz - HDTV (16:9, 1:1)
    NB: NTSC refresh rate = (Hz*1000)/1001

CE audio data (formats supported)
  LPCM    2-channel, 16-bit              at 32/44/48 kHz

CE speaker allocation data
  Channel configuration.... 2.0
  Front left/right......... Yes
  Front LFE................ No
  Front center............. No
  Rear left/right.......... No
  Rear center.............. No
  Front left/right center.. No
  Rear left/right center... No
  Rear LFE................. No

CE vendor specific data (VSDB)
  IEEE registration number. 0x000C03
  CEC physical address..... 1.0.0.0
  Supports AI (ACP, ISRC).. No
  Supports 48bpp........... No
  Supports 36bpp........... Yes
  Supports 30bpp........... No
  Supports YCbCr 4:4:4..... No
  Supports dual-link DVI... No
  Maximum TMDS clock....... 225MHz

Report information
  Date generated........... 26/11/2012
  Software revision........ 2.60.0.972
  Data source.............. Real-time 0x0011
  Operating system......... 6.1.7600.2

Raw data
  00,FF,FF,FF,FF,FF,FF,00,14,E1,01,00,00,00,00,00,2A,16,01,04,B0,00,02,78,1A,CF,74,A3,57,4C,B0,23,
  09,48,4C,00,00,00,81,C0,D1,C0,01,01,01,01,01,01,01,01,01,01,01,01,02,3A,80,18,71,38,2D,40,58,2C,
  45,00,C4,8E,21,00,00,1E,00,00,00,18,00,1C,16,20,58,2C,25,00,C4,8E,21,00,00,9E,00,00,00,FC,00,45,
  6C,67,61,74,6F,0A,20,20,20,20,20,20,00,00,00,FD,00,17,3D,19,46,0F,00,0A,20,20,20,20,20,20,01,9C,
  02,03,26,F4,51,85,04,03,02,12,13,94,16,07,06,11,15,A1,A2,27,1F,10,23,09,07,01,83,01,00,00,67,03,
  0C,00,10,00,20,2D,8C,0A,A0,14,51,F0,16,00,26,7C,43,00,C4,8E,21,00,00,98,8C,0A,D0,8A,20,E0,2D,10,
  10,3E,96,00,C4,8E,21,00,00,19,01,1D,00,72,51,D0,1E,20,6E,28,55,00,C4,8E,21,00,00,1F,01,1D,80,18,
  71,1C,16,20,58,2C,25,00,C4,8E,21,00,00,9E,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,0F
My System SpecsSystem Spec
28 Nov 2012   #305
Ninja45

Windows 7 64 bit
 
 
would this work to edit audio settings as well?

I'm having trouble getting my Nvidia gtx 650 to output to a 5.1 audio system connected to my monitor. Nvidia says its because the EDID only shows up with stereo enabled. Im assuming if information is stored in the EDID then I can edit it as well. Is that correct?
My System SpecsSystem Spec
02 Dec 2012   #306
L Denton

Win7 64
 
 

To follow up in case anyone stumbles on this through Google et al. I found that the issue with my Elgato was that it was broadcasting a different EDID based on whatever output device was connected to. So when I had my Dell ST2210B monitor connected to the output HDMI the Elgato decided that it would broadcast an EDID with a low video bandwidth reading. Not sure why it did that; the monitor was perfectly capable of displaying full HD.

Anyway, when I connected the unit independently or with a newer monitor (I've now got a Viewsonic VX2260wm) it broadcast a more suitable EDID allowing the 1080p60 option to be selected. So on that front all is good. Though I do still find that if the Elgato is plugged in while booting up I still reliably hit a blue screen. More work to be done, but the main goal is accomplished!
My System SpecsSystem Spec
27 Dec 2012   #307
steve42

Windows 7 Pro
 
 
Success. 2560x1440 resolution for HDMI/Intel HD4000 on VAIO S13 extern

I have a Dell U2711 I wanted to drive at its native resolution of 2560x1440. Unfortunately the Vaio tools and the Intel driver classify this monitor as a TV and only capable of 1920x1080. I asked Vaio support what was the revision compliance level of the HDMI hardware and they did not understand the question. Small amount of work with the Intel tools, timing specs etc showed that this Vaio(S13 Premium) is HDMI1.4 compliant so should be able to drive 2560x1440, as long as you have a 1.4 compliant HDMI cable. The U2711 supports this as well.

However getting the hardware to do this through the Intel Graphics and Media Control Panel is a bit convoluted and does not always work. The U2711 just did it without adjustment. Some fiddling required. I now have it stable at:-
2560x1440
32bit
54p
CVT-RB

How I did it:-

Modify the Dell monitor driver to show a max resolution for HDMI of 2560 (was 1920). Files attached. Use the manual "I have a disk" method to load these. Note that when you plug the U2711 in it comes up on Device Manager as a second General PnP Monitor. I had to try both to work out which was the U2711 and which was the built in display.
Restart Windows.
Open the Intel Graphics and Media Control Panel in Advanced Mode.
On Multiple Displays page select "Single Display" and in my case "Digital Television Dell U2711"
On the General Settings page ensure Display is showing your external monitor. Probably 1920x1080 32 bit 23p.
Go to the Custom Resolutions page. Click past the warning, mine's been running at this high resolution for a month so I doubt it will fail now.
You need to create a number of custom resolutions so you can then change the settings on the General Settings page one at a time to go from low resolution low scn rate to higher ones. However, the max that the Intel hardware seems happy with is:
2560x1440
32bit
54p
CVT-RB

Now the fiddling begins.

Go to the General Settings page.
Select various of your custom settings until you get 2560x1440 appear in the drop down list under "Resolution", then select that. I then had to decrease the scan rate to 23p, and then to 24p as the driver said the U2711 did not support 23p even though it seemed to at 1920x1080. I also found that if you did not decrease the scan rate the driver said it had applied the new parameters but actually did nothing. When it does apply new parameters the screen blanks for a few seconds. If it comes straight up with the "Accept or change back in 15 seconds" screen then it is fibbing.

With luck you now have 2560x1440 32 bit 24p working.

I also tried starting with 2560x1440 8 bit 23p.

Once you have any 2560x1440 resolution working you can incrementally change each of the Color Depth and Refresh Rate to get to your max parameters.

Note that at 2560x1440 32bit CVT-RB then 54p is stable, 55p blanks out once in a while (presumably it loses synch) but 56p does not work at all.

So the principal is to start with low bandwidth setttings and build up. Sort of sneak around the software. I guess this is just another example where software is less capable than the hardware.

You then just need to ignore all the offers to reset the HDMI resolution and don't go to the Vaio Control Centre and reset the HDMI settings.
BTW works Ok with the nVidia GPU on or off (Speed/Stamina switch) and autorecognises the U2711 when you come home from travelling and puts it into 2560x1440.


Attached Files
File Type: zip U2711.zip (58.2 KB, 70 views)
My System SpecsSystem Spec
05 Apr 2013   #308
j19861986

East
 
 

The PED Helper Link is dead, re-up it
My System SpecsSystem Spec
05 Apr 2013   #309
Brink
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Hello J, and welcome to Seven Forums.

Which PED Helper link are you referring to?

All links in the tutorial are working for me.
My System SpecsSystem Spec
Comment

 Force DVI/HDMI resolutions and refresh rates





Tutorial Tools



Similar help and support threads for2: Force DVI/HDMI resolutions and refresh rates
Windows 7 Tutorial Category
How can I limit refresh rates? Graphic Cards
Same monitor refresh rates on A/C and battery Graphic Cards
Jerky aero and video when 2 screens at different refresh rates Graphic Cards
Monitor refresh rates problem Graphic Cards
CRT monitor - refresh rates disappeared Drivers
Refresh rates on LCD monitors Graphic Cards
HELP: Cannot change refresh rates on Win 7 (CRT-monitor Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:46 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33