Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No sound in virtual pc


22 May 2009   #1

Windows 7 Ultimate 32 bit
 
 
No sound in virtual pc

Hey I cant seem to get windows 7 to output any sound whatsoever. Im using virtual pc and im not sure what my sound card is. But it might be this: Realtek ALC888/1200

Its a "High Definition" sound card, or is supposed to be, but I cant get windows 7 to detect it. Im running it from virtual pc 2007 and I read somewhere that telling virtual pc your trying to install vista will let you have sound. I uninstalled, reinstalled, and it doesnt work.

My System SpecsSystem Spec
.

23 May 2009   #2
Microsoft MVP

Vista Windows 7 Windows XP
 
 

I had that same problem with Virtual Pc 2007 and the Windows 7 Beta. I found this comment by someone named Hermes, which fixed the problem for me:

Virtual PC Guy's WebLog : Windows 7 on Virtual PC on Windows 7
re: Windows 7 on Virtual PC on Windows 7
I just fixed the sound problem!
I turned off, disabled the sound card and started Windows 7 again and just after it starts, I shut it down.
Enabled again the sound card on virtual pc.
Removed the Virtual PC Additions
Restarted and reinstalled VPC Additions.
Done!
I have sound on Windows 7 over VPC! =D
My System SpecsSystem Spec
23 May 2009   #3

Windows 7 Ultimate 32 bit
 
 

How do i remove the VPC additions?

EDIT: I found a file called Virtual Machine Additions

should I just delete that?
My System SpecsSystem Spec
.


23 May 2009   #4

Windows 7 Ultimate 32 bit
 
 

I think i have it working now, my sound icon now has several "sound waves" next to it instead of that ugly red x.

EDIT:Aww crap, once I restarted it its asking me if I want to boot into recovery mode or normal. I chose normal and now its asking me again. Ill choose recovery mode this time i guess

EDIT(again): oooo theres a green loading bar, reminding me of xp, but i think its working. Im at the startup screen

oh no theres a box asking me to do a system restore, im gonna go ahead and click yes
My System SpecsSystem Spec
23 May 2009   #5
Microsoft MVP

Vista Windows 7 Windows XP
 
 

You remove Virtual Machine Additions by going to Programs and Features (Vista's replacement for XP's Add/Remove Programs) and uninstall it. Then you add it again by going to the Action menu of VPC and choosing Install or Update Virtual Machine Additions.
My System SpecsSystem Spec
24 May 2009   #6

Windows 7 Ultimate 32 bit
 
 

Got it all working now, thanks!
My System SpecsSystem Spec
Reply

 No sound in virtual pc




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:53 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33