Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Problems with utorrent on a Windows XP guest with VMWorkstation 7.1

02 Oct 2010   #1

Windows 7 64 bit
Problems with utorrent on a Windows XP guest with VMWorkstation 7.1

My Windows XP guest runs on VMWorkstation 7.1 on Windows 7 Pro 64 bit and connects to the internet via my wireless router using the virtual NAT adapter. I cannot get utorrent to open a port so I've tried the following solution using the port foward option in NAT.
1. Port foward the utorrent port on the router using the IP address of the host computer.
2. Port foward the virtual NAT adapter using the same port numbers for physical and the virtual ports and using the IP address of the guest computer.
This has not worked so is the configuration wrong?

I tried the bridged mode to connect directly to the wireless router using a static ip address on the Windows XP guest the DNS servers where set to the same as the router but the connection fails due to duplicate IP addresses. (Tried the microsoft loopback adpapter option also but cannot connect to the wireless router as guest when VMWorkstation is installed)
In fact I tried the bridged mode before and its never worked for me so I need to get the port fowarding on the NAT adapter working. As anybody got this working ok using the NAT adapter?

My System SpecsSystem Spec
02 Oct 2010   #2


Don't take this the wrong way, but if you can get it to work, running utorrent on a virtual machine would be a good way to kill your HDD. I'm not saying there's anything wrong with using utorrent, but running it from a VM is going to triple the load on your HDD
My System SpecsSystem Spec
02 Oct 2010   #3

Windows 7 64 bit

Ok fair comment. Perhaps this is pushing the limit of the virtual machine. Orginally I was trying this out to see if there was any port connections to the internet using the bridged mode because for some reason I keep getting the same duplicate IP addresses and the connection fails. ls it not possible to achieve a internet connection to the virtual machine in this mode via a wireless router? I read a forum that suggested using the microsoft loopback adapter option but when I tried to connect this as a guest to the wireless adapter card it fails. It seems VMWorkstation stops this, without it installed it works ok.
Any body know of this type of problem with a wireless router?
My System SpecsSystem Spec

02 Oct 2010   #4


It may be that there's no guest support for the p2p protocol in WMware... I've never tried to set it up but maybe there's someone here that knows how to do it..

otherwise, if you're trying to set it up in a guest OS for the purpose of testing software that won't run in the host, why not run uTorrent in the host OS instead, set to save to a shared folder with the guest. Then it's not necessary to have the virtual machine running while downloading
My System SpecsSystem Spec
03 Oct 2010   #5

Linux CENTOS 7 / various Windows OS'es and servers

Hi there
I've NO problem in running Utorrent on a Virtual 2003 Server (XP code is based on 2003 server anyway).
Using vmware workstation 7.1 in Bridged mode.

Not sure why you would have any problem with this unless you've got extra firewalls or AV software blocking ports.

Maybe give your VM a fixed LAN address instead of getting it assigned via the routers DHCP.

If you can run it on your HOST it won't be the VM softwarte thats the problem.

My System SpecsSystem Spec
06 Oct 2010   #6

Windows 7 64 bit

Thanks for the advise. Still no luck with the bridged mode connection. I have duplicate IP addresses on the XP guest so I suspect that the wireless router is not able to connect directly to the guest so maybe the virtual switching between router and guest is blocking the signal! This was using a static IP address in this case set up from the guest and using the same DNS servers as set up in the wireless router. Attempting this with the automatic method using the routers DHCP also does not work. What causes the duplicate IP addresses?
Its possible to use the NAT mode ok but I still am not sure if the settings I mentioned in the first post for port fowarding are correct. Any way a method that I read about using the microsoft loopback connector does not appear to work if vmworkstation is installed. If you try to connect this as a guest to your wireless router all you get is a error. I tryed this without vmworkstation and it works fine.
My impression is not maybe not all wireless routers will work correctly with vmworkstation using the bridged mode.
Is this correct?
My System SpecsSystem Spec

 Problems with utorrent on a Windows XP guest with VMWorkstation 7.1

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Is guest mode available in windows 7?
I need something like guest mode for a couple of computers I'm working on. I have guest accounts but I'd like their histories to be wiped when the users log out of the accounts. Thank you for your help.
General Discussion
Problems with guest account set to Admin
Hey, I am really frustrated. I suggested that on my grandmother's computer that there was a user account and an admin account. Ok, fine, but when I got there to update windows and other programs I found out that the Admin account they set up was not a user account but the guest account. I logged...
General Discussion
Utorrent speed problems. Ive googled for months. I need some1 smart
Hey I have been looking for help for months. I have win7 and i cant get any port to download my torrents fast. im geting like 150kbs on my old vista laptop I could download at 1.3mb/s il paste my spevs below I dont know what all specs yall need but you can reply if you need more. So...
Problems with uTorrent
First of all, sorry if i'm creating the same theme, because i haven't spend too much time to search for my problems solve here, but still: recently i'm having strange problem with uTorrent. While i'm trying to create torrent and choose my D partition, my utorrent stops working and automatically...
Problems with network bridge and utorrent in Win 7
I am having some issues with Windows 7 and my network bridge. I currently have it setup like this...modem -> router -> laptop -> wireless bridge. The problem is whenever I have the bridge enabled, the port I have open for utorrent is blocked. When I disable the network bridge the port is open...
Network & Sharing
Utorrent (torrent) problems
Okay so I've finally upgrade from 7068 to 7077 then to 7100. On 7068, I was able to download on utorrent, play games, browse the net etc. On 7100, it seems to shut off my internet when a torrent is active. My router does not go off as other computer's are still fully connected. Any help...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:41.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App