Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problems bringing up XP Mode


11 Sep 2011   #1

Windows 7 Professional 64-bit
 
 
Problems bringing up XP Mode

Ever since I first got my Windows 7 machine, I have been able to run the XP mode virtual machine without problem. A few months ago, I started getting a message that the XP mode couldn't come up without integration problems, or something like that. I was able to dismiss the message and have WinXP boot.

Suddenly a few days ago, in the middle of a normal Windows 7 session with a WinXP virtual machine running, XP crashed with a system dump and hasn't been bootable since. I can try to bring it up, but it just gets up to maybe 20% progress bar of boot, then cycles back to 0%.

How do I get back into XP or at least copy my data out? Thanks!


My System SpecsSystem Spec
.

12 Sep 2011   #2

Windows 7 Professional 64-bit
 
 

I'm not sure what I did differently today, but I was able to get back to the crash screen, rather than constantly cycling toward a boot. I get a TRAP (I took a snapshot image and have a .jpg image on my hard disk I can share).

After closing that attempted boot (the virtual machine hibernated), I tried mounting the VHD file via following directions at Virtual Hard Disk - Create and Attach VHD . I found this likely VHD disk:

C:\Users\Dilip\AppData\Local\Microsoft\Windows Virtual PC\Virtual Machines\Windows XP Mode.vhd

and was able to mount it read-only; I declined formatting it. I found it to have a 127GB healthy active, primary partition with 13 mb unallocated space. It was corrupt or uninitialized, but I didn't try formatting it or anything - I want to get my data off, of course!

Am I getting closer? I don't want to lose the data even if I have to reinstall the virtual machine after copying the data. I do have a backup but it's not as current as I'd like. Thanks.
My System SpecsSystem Spec
Reply

 Problems bringing up XP Mode




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:45 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33