Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: XPMode DOS Print woes


09 Jan 2012   #1
kpgraci

 
 
XPMode DOS Print woes

Trying to print from DOS in XPMode.
Here is what I've done:
win 7 host and XPMode are all members of same workgroup.
Printer installed and tested on win 7 host
Win 7 host has an 8.3 name.
Both Win 7 and XP dirvers for printer obtained
Shared printer from Win 7 host.
Confirmed that other networked xp boxes could print to share.
Attempt #1:
1. In XPMode, click USB, attach printer, installed drivers.
2. Printed test page from XPMode, prints OK.
3. DOS printing did not work at this point, understandable as LPT1 was not mapped,
at some point while I was playing around with this the virtual machine locked up
and I had to reinstall xpmode.
Attempt #2:
1. In XPMode, cmd prompt: NET USE LPT1 \\win7host\printer /persistent:yes
2. Receive error 88.
3. Went to XPMode printers/faxes - File - print server, dirvers, add...
4. installed xp dirvers to XPMode machine
5. Attempted to open printers/faxes in xpmode, virtual machine locked up, had to reinstall xp mode.
For attempt #3 I plan on doing the same as attempt #1 (usb/attach) but this time share
the printer from xpmode, then try NET USE on that XPMode share.
If that fails, then for attempt #4 I will retry Attempt#2, but at XPMode cmd I will try
NET USE LPT1 \\tsclient\printername
If that fails I don't know what to try.
The machine is at a client's office and I don't have ready access to it. I have locked up the vitrual machine 3 times
and reinstalling xpmode takes a while, so I'm limited on how much I can do in a session.
Does anyone know how to actually get this to work (LPT1 DOS print from XMMode to win 7 host local printer)?
Could the printer driver be causing the vitrual machine to lock up? Should I try a different printer?
Sorry, I don't remember the exact printer - it's an HP officejet model.
So to summarize there seems to be a few possible options:
1. Share from win 7 host, in XPMode NET USE that share (fails with error 88)
2. Share from win 7 host, in XPMode NET USE \\tsclient\printer (have not tried this yet)
3. USB attach in XPMode, then share in XPMode, then NET USE the XPMode share (have not tried this yet)
Obviously a NET USE LPT1 has to be in the equation but I don't know the proper way to share the printer and then access that share.


My System SpecsSystem Spec
12 Jan 2012   #2
kpgraci

 
 

I retried my attempt #1, that is, installed printer on win 7 host, then used usb menu option to attach printer. Installed xp printer drivers on xpmode and the printer did not show up in printers and faxes for about 20 minutes - very odd. Then 2nd time open printers and faxed it shows the hour glass for a few seconds then changes back to normal icon and leaves me on the desktop. At this point I cannot open printers and faxes at all.

printer is hp officehet, don't remember model.
My System SpecsSystem Spec
21 Jan 2012   #3
pjhutch

Windows 7 Home Premium 32bit
 
 

My System SpecsSystem Spec
Reply

 XPMode DOS Print woes




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:45 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App