Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: VMware Player 4.0 - network config choices

20 Jun 2012   #1
BobB9

Win 7 Home 64-bit
 
 
VMware Player 4.0 - network config choices

The VMware manual "Getting Started w VMware Player" describes 3 choices to config a virtual network: (1) NAT (2) Bridged (3) Host only. But it's not clear to me which one(s) is most appropriate for my simple VM - the host OS is Win 7 Home, the guest OS is Win XP Pro (couldn't be any simpler right ?).

I've tried the NAT config but was unable to connect to the internet. The "network connections" for the VM showed a big red 'X' over the connection icon and said that the cable was disconnected. But the host is able to access the internet using the same cable. I'm a newbie to VM so don't know if i failed to config properly or there is a bug in VM Player 4.0.4

Any suggestions will be greatly appreciated. Thanx.

Bewildered Bob


My System SpecsSystem Spec
20 Jun 2012   #2
Golden

Microsoft Community Contributor Award Recipient

Windows 7 Ult. x64
 
 

Hi again Bob,

Usually NAT is the appropriate one, but from your earlier thread I seem to recall it never worked, and I recommended you try Bridged instead. How did that go?

Can you post an image of what you are seeing? I'm finding it hard to visualise the red X and where it is occuring.

regards,
Golden
My System SpecsSystem Spec
20 Jun 2012   #3
BobB9

Win 7 Home 64-bit
 
 
Virtual network config for internet access

Hi again Golden: using "bridged" (rather than NAT) does not seem to make any difference - still unable to access internet.

The err msg abt "unplugged network cable" appears in 2 places in Win XP:
(1) lower right task bar (near time) - icon seems to be 2 monitors with a red 'X'
(2) control panel - network and internet connections

So it's still unknown whether i'm not doing the config properly or there is a bug in VMplayer 4.0.4.

Also probably not important but adds to the confusion - on the "home screen" for VMware the version shown is NOT VMware Player (as expected) but WORKSTATION 8.0 virtual machine which i believe is a separate product.

ps: i cannot send a screen shot since the file is on desktop of VM only but internet access is need to post screen shot file on the forum.

ps #2: i tried to "repair" already installed VMtools but the TPVMMON.DLL was not found.
My System SpecsSystem Spec
20 Jun 2012   #4
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Technical Preview 64-bit 9926 Multiprocessor Free
 
 

Just a thought, not confirmed .... maybe the network adapters are not properly installed during the installation of the VMWare Player?

Move your guest OS to some other place (Just copy the Windows XP folder from the VMWare folder in Documents), uninstall VMWare, and reinstall it. Install VMWare tools, and finally run Windows XP Professional.vmx from the moved location, it may work properly.

Just a hopeful thinking, I am using an older version, and as I dont use it frequently, I haven't upgraded to the latest .
My System SpecsSystem Spec
21 Jun 2012   #5
BobB9

Win 7 Home 64-bit
 
 

GOOD NEWS FOLKS - It works !! Golden had it right! The winning combo is: a BRIDGED connection + "replicate physical network connection state" (check box) + "connect at power on" (check box). I don't know what all this means and there may be other successful combos but i'm very happy that it works at last. My sincere appreciation to Golden & others who offered suggestions.

(no-longer) Bewildered Bob
My System SpecsSystem Spec
Reply

 VMware Player 4.0 - network config choices




Thread Tools





Similar help and support threads
Thread Forum
VMware Player Lost Network Connection
Not sure when it happened as I don't use VMware player too often. My main desktop is Win 7 Pro. VMware Player: 6.0.2 build - 1744117 In the player, is XP Pro. In XP Pro inside the player, when I opened up Windows Explorer, Network, I briefly saw my desktop drives (in the Win 7 system),...
Virtualization
External Network Access from VMware player
Hi, I have a VM shared to me by a colleague. I installed VMware 6.0.1 and able to start the VM. Now i want to setup the communication for VM so that i can access the internet from the VM using my Host's connection. On my host machine, i can use a wired or a wireless broadband connection and...
Virtualization
Android x86 in VMware Player - no network
I installed Android in VMware Player. Works quite well but I cannot get a network connection. I don't have that problem with my other 6 Linux and Windows virtual systems. Anybody know how to get the network connection going because Android without the connection is really dull. Also how to get...
Virtualization
No network connection with VMware Player?
Hi, Would like some advice please, I have been using vmware player for just a few weeks and have had no problem with network connection up until last week when I did some changes (Windows re-activation and removals using 'Hijack This'. I have obviously deleted lots of stuff I am not...
Virtualization
VMWare Player network adapter settings - which one?
G'day, I've been using VMWare Player to run a Linux virtual machine (Mint 12 to be precise, but I occasionally run Ubuntu and Debian). At the moment, I am using the BRIDGED network adapter settings as shown in the image below. I noticed that there is also a NAT and HOST-ONLY setting. Can...
Virtualization
Vmware WKS 7.1 and vmware player 3.1 KILLS XP Mode
Hi all You can try the new versions of vmware player (3.1) FREE and Workstation (7.1) - Commercial http://communities.vmware.com/community/beta/ws I think now that you can launch applications directly in UNITY mode with these new releases it should eliminate the need to use XP mode at all -...
Virtualization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:20.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App