Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: virtual xp restarts with errors


30 Mar 2013   #1

Win 7 pro x64
 
 
virtual xp restarts with errors

I have been running XP mode in a virtual window for several months. The VPC I am using is what I got from Microsoft, and so is the XP. I have some persistent, but intermittent problems and could use some help making it run more smoothly.

1, I have created another user with admin privileges in addition to the default xpmuser. I am having difficulty getting it to work the way I'd like. I used control panel to set the option to allow for login fast user switching and to use the welcome screen (i.e. where it shows user names and lets you log in via clicking on a name). Neither of those options is taking hold. Instead, it keeps opening up the virtual XP using that default xpmuser.

2. I am getting frequent errors, especially with the xpmuser. There will be the usual error message asking me to send info to MS. Usually when I click that or the don't send, the virtual window closes and restarts itself. Sometimes I am able to get xpmuser to log off and then login my normal user.

3. If I can get to my normal user, I can look at event viewer to see various error and warning messages. Often trying to look at event view under xpmuser causes the system to restart and reload the virtual xp.
A sample of the recurring error and warning messages is:
Errors:
Driver Amyuni Document Converter 400 required for printer Quicken PDF Printer is unknown. Contact the administrator to install the driver before you log in again.
Error code 1000007e, parameter1 c0000005, parameter2 00000000, parameter3 b51cd1a8, parameter4 b51ccea4.
Warnings:
Printer Microsoft XPS Document Writer (from DALES-COMPUTER) was deleted.
Printer Microsoft XPS Document Writer (from DALES-COMPUTER) is pending deletion.
Printer Microsoft XPS Document Writer (from DALES-COMPUTER) was purged.
plus a similar set of three messages for each of printer pdf995, printer fax, and
Printer hp LaserJet 1320 PCL 6 on GAILS-COMPUTER (from DALES-COMPUTER) was deleted.

These messages strike me as strange because my virtual XP is not attempting to print *and* I can find no evidence in the printers property that any of those printers is installed in the virtual XP (although Quicken is installed on the host and the laserjet is a printer installed on another computer in the local net).

I'd appreciate any hints as to how to make my virtual XP more stable -- and how to enable the logon procedure to be the way I want it.

My System SpecsSystem Spec
.

01 Apr 2013   #2

Win 7 pro x64
 
 

I'm still hoping for some answers to the frequent crashes and errors looking for printers that are not being used. Can anyone help?
My System SpecsSystem Spec
01 Apr 2013   #3

Windows 7 x64 and numerous virtual machines
 
 

Hi Dale.In the virtual machine I would select the C:drives properties and select tools and run check disc to check for errors, you will most likely have to reboot. Checking your real drive for errors if the virtual one has errors would be a good idea too. To reboot use the Control Alt Del from the XP modes window.
My System SpecsSystem Spec
.


02 Apr 2013   #4

Win 7 pro x64
 
 

Thanks, I'll try that tomorrow and report back. One place where I get a consistent error is trying to open a file on one of the mapped drives which is on yet another computer. I'll do chkdsk on that directory also.
My System SpecsSystem Spec
02 Apr 2013   #5

Win 7 pro x64
 
 

I did the chkdsk on the virtual C: drive, and also on the networked drive from the other computer. The virtual C: drive had a few corrections, but nothing that seemed serious.

I have been doing some experimenting, and I have information to share. It might shed light for you or others, but it totally confuses me.

I have a drive on another computer, labeled H:. I have it mapped to H: on my virtual XP. It has folders and folders within folders. If I use internet explorer and attempt to navigate on H: I can get it to display the first layer of folders. Then if I try to drill down another layer, or if I attempt to access a single file in a first layer folder, the system immediately restarts the virtual XP. After it starts, there is the standard window error message for send/don't send. The event viewer will show the error code message that I posted above, which is:
Error code 1000007e, parameter1 c0000005, parameter2 00000000, parameter3 b51cd1a8, parameter4 b51ccea4.

Thinking that perhaps this was some sort of sharing problem I went to the other computer and double checked that sharing was on -- it was.

My favorite windows text editor program is called editpad light. If I use it and attempt to open a text file that is in a top level folder, I get the same sort of crash and reboot.

Now for the weird part. If I use the MS notepad program, I can access such a file. If I navigate using my favorite 4NT console window, I can move to that same file and open it in a DOS based editor.

*SO*, it seems that something has gone wrong with the MS explorer program, and with my editpad lite program, but not with other means of accessing the file. I am totally perplexed, but hope that someone can make a suggestion that allows me to get to the bottom of this problem.
My System SpecsSystem Spec
03 Apr 2013   #6

Microsoft Community Contributor Award Recipient

Windows 7 enterprise 64 bit, Windows 7 Pro 64 bit ,Windows 8 64bit
 
 

It sounds like, and I say this from working with VMs in a lab environment and breaking litteraly dozzens of them that two things are possibly/probably happening here first I am willing to bet that there is significant file system corruption, which may be able to be fixed with the system file checker. So begin by opening a command prompt then once open type the following:

Code:
sfc /scannow
a little message box will appear allow it to finish, you may need to reboot the VM when it is done.

If this does not find any problems or doesn't seem to help the VM its self may be corrupt and the best option would be to pull everything you need off of it and then recreate it.


Attached Images
 
My System SpecsSystem Spec
03 Apr 2013   #7

Win 7 pro x64
 
 

I have tried to run sfc /scannow on the virtual XP, but have been unable to do so. I did run chkdsk /f/r c: and can look at winlogin entry in the event viewer to see the results. I've run chkdsk multiple times over the past day or so. First time it got 1700+ minor errors, next it got 17 and last it got 2.
Cleaning up minor inconsistencies on the drive.
Cleaning up 2 unused index entries from index $SII of file 0x9.
Cleaning up 2 unused index entries from index $SDH of file 0x9.
Cleaning up 2 unused security descriptors.

When I attempt to run sfc from either my usual 4NT prompt or from the more standard console window, I get told that I have to be running it from a console with administrator privileges. I can do that on this main computer by hitting "run as" administrator. However, on the virtual XP machine even though I right click, say "run as" and check the administrator box (and enter its password), I still get the same error message from sfc. Not sure what I need to do to run sfc on the virtual XP machine. Should the chkdsk be doing the same thing?

I will say that after running chkdsk several times, the crash problem is much better -- but I still just got one when attempting to save a file on the mapped drive from my other computer.
My System SpecsSystem Spec
04 Apr 2013   #8

Microsoft Community Contributor Award Recipient

Windows 7 enterprise 64 bit, Windows 7 Pro 64 bit ,Windows 8 64bit
 
 

please run through this tutorial on the XP Vm I would like to see what the dump files say is going on:

Blue Screen of Death (BSOD) Posting Instructions
My System SpecsSystem Spec
04 Apr 2013   #9

Win 7 pro x64
 
 

Thanks for the interest.

I followed the steps as suggested in the referenced threads. The steps played out a little differently since they were written for Windows 7 and I was doing them in my virtual XP. You did not say what type of dump to choose, so I chose full dump.

Setting up the full dump seemed to cause a difference in the reaction to an operation that caused the error (attempting to navigate in the networked file). Now instead of just restarting the virtual XP window, it freezes and I had to hit the red X to make it restart. When it did restart, it gave me the usual "report error to MS" message. I then ran the application to save the dump files.

I renamed the zip file to dale5351.zip -- I think I saw that instruction someplace, although I cannot find it right now.


Attached Files
File Type: zip dale5351.zip (988.1 KB, 2 views)
My System SpecsSystem Spec
04 Apr 2013   #10

Microsoft Community Contributor Award Recipient

Windows 7 enterprise 64 bit, Windows 7 Pro 64 bit ,Windows 8 64bit
 
 

Well I do think I may have found the source of the problem, looking through the dump files I found this in all of the dumps that didn't throw errors when I tried examining the stack:

Code:
b5cfcaf8  b980f316Unable to load image aswSnx.SYS, Win32 error 0n2
*** WARNING: Unable to verify timestamp for aswSnx.SYS
*** ERROR: Module load completed but symbols could not be loaded for aswSnx.SYS
 aswSnx+0x5c316
Driver Reference Table - aswSnx.SYS

That is the avast! virtualization driver, best course of action would be removing avast! with the Avast! Removal Tool and replacing it with a combination of MSE and Malwarebytes Anti-malware


Tip: when installing Mbam be sure to uncheck the box offering to start a free trial.
My System SpecsSystem Spec
Reply

 virtual xp restarts with errors




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:02 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33