Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Swannsmart external modem is not always detected in XP mode vm

18 Dec 2013   #1

win 7 ultimate x64
 
 
Swannsmart external modem is not always detected in XP mode vm

Hi crew, when I start xp mode my modem is only occasionally detected correctly.
Most of the time, when xp mode queries the serial port during vm boot-up, the modem does not respond correctly. xp mode appears to retry the detection a few times in quick succession.
The modem never fails on [any] real hardware, only on the virtual machine.

IfI click 'scan for hardware changes' in xp modes device manager a few times, it eventually is detected properly and appears in device manager.
On some restarts of the vm, the modem is detected correctly first time, but not often.

It's a 56k voice/fax/data modem made by Swann, with the Ambient [now Intel] chipset.
In fact, if I let XP mode search the net for a driver, it loads a 'Intel v92 external modem' driver.

But of course, the driver is not the problem, it's the initial querying of the serial port to see if anything is connected to it that's the problem.

Here's a short youtube vid of the problem with explanatory text in the vid.

Host OS is a up-to-date win 7 ultimate x64 sp1
MB is a Foxconn P965 LGA 775 with a Q6700 quad processor.

Any suggestions/tricks most welcome


My System SpecsSystem Spec
.

18 Dec 2013   #2

win 7 ultimate x64
 
 

an update:
it's definitely an xp mode issue. vmware always detects the modem correctly.
My System SpecsSystem Spec
21 Dec 2013   #3

win 7 ultimate x64
 
 

This seems an unresolvable issue with xp mode, so I'm sticking with vmware.
It's actually a bit better than xp mode in that I can drag n drop directly from the host file system onto a virtual app running in unity mode on the host desktop....brilliant!!
My System SpecsSystem Spec
.


Reply

 Swannsmart external modem is not always detected in XP mode vm




Thread Tools



Similar help and support threads for2: Swannsmart external modem is not always detected in XP mode vm
Thread Forum
ZTE MF626 modem not detected at dial up setup Network & Sharing
USB External Modem Hardware & Devices
Modem take too much to be detected on start up Drivers
Windows XP Mode - Modem not detected Virtualization
Solved External V92 Modem Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:13 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33