Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't connect to the internet in VMware.

28 Aug 2014   #1
adamisapple

Windows 7 64 Bit Professional
 
 
Can't connect to the internet in VMware.

Hello,
I am virtualizing Windows 8 in VMware. It has 2GB Ram, 30GB Hard Drive, and is 32-bit. My Host OS is Windows 7 Professional, 4GB Ram, 282GB Hard Drive, and is 64-bit. The VMware will NOT connect to the internet. I have tried Bridged, NAT, and LAN, and the others. If anyone can help, It would be awesome. I've searched for a solution for 6 hours and found NOTHING.
Thanks!


My System SpecsSystem Spec
.
28 Aug 2014   #2
Gator

Dual Boot: Windows 8.1 & Server 2012r2 VMs: Kali Linux, Backbox, Matriux, Windows 8.1
 
 

Quote   Quote: Originally Posted by adamisapple View Post
Hello,
I am virtualizing Windows 8 in VMware. It has 2GB Ram, 30GB Hard Drive, and is 32-bit. My Host OS is Windows 7 Professional, 4GB Ram, 282GB Hard Drive, and is 64-bit. The VMware will NOT connect to the internet. I have tried Bridged, NAT, and LAN, and the others. If anyone can help, It would be awesome. I've searched for a solution for 6 hours and found NOTHING.
Thanks!
Hello adamisapple,

Can you provide us with more information? What version of VMware are you using? Have you tried other VM's to check and see if you can connect? Have you made sure all of your drivers are in order on the VM?

Do you have connection outside of the VM, as in your PC?

Here is a pretty comprehensive troubleshooting guide that may help:
VMware KB: Troubleshooting networking and internet connection issues in VMware Fusion
My System SpecsSystem Spec
28 Aug 2014   #3
adamisapple

Windows 7 64 Bit Professional
 
 

My PC has internet, Im on VMware 10, I have not tried any other. Thanks!
My System SpecsSystem Spec
.

31 Aug 2014   #4
jimbo45

Linux CENTOS 7 / various Windows OS'es and servers
 
 

Hi there

Have you run Installed the VMWARE TOOLS on the VM yet. Otherwise I can't think of any problem with networking in VMWARE. - Have you perhaps got firewalls blocking service (either on the VM or the Host or both).

Start testing by removing ALL AV software - and see if that's the culprit too -- things like that HIDEOUS Mcafee software seem to cause a lot of hassles at times for example

I run VMWARE without problems on both LINUX and Windows hosts - no probs with Internet acess at all. Even Windows networking which is usually a dog anyway works ok between VM's and the rest of the LAN.


Cheers
jimbo
My System SpecsSystem Spec
31 Aug 2014   #5
adamisapple

Windows 7 64 Bit Professional
 
 

VM Tools is in the taskbar as a VM icon. I have no antivirus software installed.
My System SpecsSystem Spec
01 Sep 2014   #6
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

Does the Win 7 Host have VMware Network adapters in Device Manager with no errors ?
Does the Win 8 Guest have a Network adapter in Device Manager with no errors ?

Here is what I have for Win 7 Host VMware Network adapters.
Can't connect to the internet in VMware.-vmnsp01.png

Here is what I have for Win 8 Guest Network adapters.
Can't connect to the internet in VMware.-vmnsp02.png


My System SpecsSystem Spec
02 Sep 2014   #7
adamisapple

Windows 7 64 Bit Professional
 
 

I have Bluetooth and Microsoft Adapter in Windows 8 (Guest) but no VM or Intel one. and VM 1&8 in Windows 7 (Host)
My System SpecsSystem Spec
02 Sep 2014   #8
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

Did you work through the troubleshooting guide Gator gave you in post #2 ?
My System SpecsSystem Spec
02 Sep 2014   #9
adamisapple

Windows 7 64 Bit Professional
 
 

How can I check to see if the items are in order?
My System SpecsSystem Spec
02 Sep 2014   #10
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

I don't understand the question.
What items and what order ?
My System SpecsSystem Spec
Reply

 Can't connect to the internet in VMware.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
How to connect a virtual machine to the internet (vmware)?
I have windows 7 64bit as my native OS (as of now). I am trying to run windows xp professional 32bit and again 7 on a vmware virtual machine. Everything is working perfectly, except I cannot figure out how to connect to the internet. I know nothing about internet connections or terms. ...
Virtualization
Can't connect to internet "Windows was unable to connect to this netwo
Hello guys, I have just finished my very first computer build and am rather happy with most things. Unfortunately I am having problems connecting to the internet. I have a temporary dongle in place and because it's my only option for about a month I kinda need it to work. When I first...
Network & Sharing
I can't connect to internet by using the VMWare Player.
My host system is 64-bit Windows 7 RTM. And I installed the vmware player 2.5.2. The virtual system is the 32-bit Windows 7 RTM. But the virtual system can't connect to internet, the connect type is "NAT". I also try to use the other two mode, it also can't connect to internet. Does anybody know...
Virtualization
VMWARE XP Machine can't connect to Internet
I have a dell studio 1537 I'am running 7 as my OS and have VMWorkstation 6.5.2, but for the some reason my XP Machine won't connect to the internet I have installed VMware tools, but still can't connect to the internet. The XP machine sees the network adapter. Has anyone been able to successfully...
Network & Sharing
No internet between VMWare and 7 Host
Now running the RTM 7600 x64 till i get to Michigan's "The New Efficency"on october for 7 Pro retail :3 but. after installing the leaked updates VMWare will make a net connection in NAT and bridged connections and though a guest will say theres Internet.. Nothing will actually work.. like its not...
Network & Sharing
VMWare Workstation cant connect to the Internet
i have windows 7 build 7077 and i have latest vmware version 6.5.2 but i couldnt make it connect internet i installed win xp and it cant connect internet through nat i need to make it really important pls help
Virtualization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App