Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: VMWare Workstation cant connect to the Internet

20 May 2009   #21

win 7

Quote   Quote: Originally Posted by Ralph View Post
Hello everybody,

I was able to connect to the Internet through Bridged Networking and Microsoft Loopback Adapter in a NAT-like fashion.

Hint: From the command prompt, run "hdwwiz.exe". This should launch the "Add Hardware Wizard".

I hope this will be useful to someone.


Rafael Lopez.

can you be more specific

what ip did you give for bridged connection ?

pls explain step by step

My System SpecsSystem Spec
24 May 2009   #22

Windows 7 Build 7229 x64

Quote   Quote: Originally Posted by cefurkan View Post
ofc host can connect internet
bridged doesnt work since i have to use static ip and it tries to take another ip and our dormitory doesnt give dynamic ip atm
dhcp disabled at dormitory network

i can ping the virtual machine so nothing blocks it

i use vmware at windows xp before without any problem

my host is not wireless

win xp sp3 VMWARE version 6.5.2 running on W7 x-32 build 7077 -- i have damn this problem
Can you use an inexpensive router like linksys/dlink to "front-end" your PC running VMWare. Then just assign the single static address provided by your dormitory to the WAN side of the router and do your own static/DHCP addressing on the LAN side. This will then let you set up your VM's with bridged configuration or whatever required.
My System SpecsSystem Spec
01 Jun 2009   #23

W7 RC1

Quote   Quote: Originally Posted by cefurkan View Post
i have windows 7 build 7077
and i have latest vmware version 6.5.2

but i couldnt make it connect internet

i installed win xp and it cant connect internet through nat

i need to make it really important pls help
Hi all,
I managed to get my VM accessing the internet using bridged mode to my laptopís wireless NIC. (Dell D1520 with Dell Wireless 1390 Mini Card). I am running W7-RC1.
Initially I had the same issues as all of you but have now found a workaround which does not require any complicated VMware networking changes and does not require MS ICS.

Simply (re)-install VMware Workstation 6.5.2 with all standard install options then change a couple of settings using the Virtual Network Editor tool.
1. Launch Virtual Network Editor
2. Select Automatic Bridging tab
3. Click ADD and add your WIRED ethernet card to the ĎDo not attempt to automatically bridge to the following adaptersí list.
4. Click Apply.
5. Select Bridge network mode for the VM
6. Edit the VM NIC and configure a permanent IP address, subnet, default gateway and DNS address which matches the subnet/range used by your wireless router. DCHP may also work but I never tested it.
(I think the problem was that VMware automatically bridged to the wired NIC whilst the active internet connection was actually on my laptopís Wireless NIC.)
Hope this helps and hope it works for some of you.
My System SpecsSystem Spec


 VMWare Workstation cant connect to the Internet

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Can't connect to the internet in VMware.
Hello, I am virtualizing Windows 8 in VMware. It has 2GB Ram, 30GB Hard Drive, and is 32-bit. My Host OS is Windows 7 Professional, 4GB Ram, 282GB Hard Drive, and is 64-bit. The VMware will NOT connect to the internet. I have tried Bridged, NAT, and LAN, and the others. If anyone can help, It...
Windows 7 + VMWare Workstation 7 - no internet access
I'm running Windows 7 and VMWare Workstation 7, and I cannot access the internet from any virtual machines using bridged connections. I used to be able to, so I'm not quite sure what happened. I did not modify anything within VMWare.... bridged connections are set as they were by default - to...
Network & Sharing
I can't connect to internet by using the VMWare Player.
My host system is 64-bit Windows 7 RTM. And I installed the vmware player 2.5.2. The virtual system is the 32-bit Windows 7 RTM. But the virtual system can't connect to internet, the connect type is "NAT". I also try to use the other two mode, it also can't connect to internet. Does anybody know...
VMWARE XP Machine can't connect to Internet
I have a dell studio 1537 I'am running 7 as my OS and have VMWorkstation 6.5.2, but for the some reason my XP Machine won't connect to the internet I have installed VMware tools, but still can't connect to the internet. The XP machine sees the network adapter. Has anyone been able to successfully...
Network & Sharing
vmware server vs vbox vs vmware workstation
Hi all W7 x-64 host 4GB RAM dual core 2.3 ghz cpu. Host CPU usage with 1 XP pro SP3 2GB Virtual machine running a file copy of a 2GB file. Host machine not running any other app. Virtual Box 24% Vmware workstation 19% Vmware server 11%. Now this shouldn't be taken as a rigorous...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:41.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App