Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No WiFi hardware found


11 May 2010   #1

windows 7 Ultimate
 
 
No WiFi hardware found

Hello,
I have Toshiba laptop L500 02H with Win 7 Ultimate. I'm trying to use the Easy WiFi Radar that is the XP app but I'm receiving a message " No WiFi hardware found". The XP mode is using the Shared Network adapter while in the Win 7 mode I have Realtek RTL819SE Wireless LAN 802 11n PCI-E NIC and MS Virtual miniport adapter.
Howcould I make WiFi active in the XP mode? Please advise.
Thanks


My System SpecsSystem Spec
.

11 May 2010   #2

Windows7 Ultimate 64bit
 
 

XP mode is in a virtual machine environment, it is not aware of what the host computer have (including wifi hardware). If you want to install a "wifi radar", you need to install in Windows 7 instead.

zzz2496
My System SpecsSystem Spec
11 May 2010   #3

windows 7 Ultimate
 
 

Thanks, zzz2496. That was a reason I installed the XP mode. The Easy Radar doen't work with Win 7.
My System SpecsSystem Spec
.


12 May 2010   #4

windows 7 Ultimate
 
 

So, as I understood there is no way to make WiFi working on the XP Mode.
Please, advise if anybody knows if it's still possible to have WiFi in the XP Mode.

Thanks
My System SpecsSystem Spec
13 May 2010   #5

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro with Media Center
 
 

Open XP Mode settings, click Networking on the left pane, change Adapter 1 to your host machine's WiFi NIC.

Kari


Attached Thumbnails
No WiFi hardware found-xpm_nic1.png  
My System SpecsSystem Spec
14 May 2010   #6

windows 7 Ultimate
 
 

Thank you, Kari.

I did change it to the Realtek RTL819SE Wireless LAN 802 11n PCI-E NIC but when I opened the Network in XP it shwos only the Local Area Connection and it's still the same message "no WiFi software found" from the Easy WiFi Radar.
I tried to change it to Microsoft Virtual Miniport Adapter as well.

Any other thoughts on it?

Thanks
My System SpecsSystem Spec
14 May 2010   #7

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro with Media Center
 
 

If the WiFi NIC works on host, I really don't understand why it doesn't in XP Mode.

I am very sorry, I really don't have any other ideas. I'll do some researching and come back.

Kari
My System SpecsSystem Spec
14 May 2010   #8

W7 X-64 W8.1 X-64 Opensuse 13.1 W2003 Server
 
 

Hi there
as Kari says if the Wifi works on the Host it should work on your VM (even in XP mode)

This might be a basic question but it's a well known fact that in the event of many possibilities often the SIMPLEST solution is the correct one.

Have you actually ENABLED networking for the VM -- I'm not exactly sure how to do it in XP mode as I don't use XP mode - but on a "Typical VM" you set the Networking options in Host machine when you define the virtual machine - such as NAT, Bridged or HOST only.

In the case of VMWARE the "Virtual network adapter" (vnetxx xx is 01 - whatever) used by the Virtual Machine is the one the host is using so if your WiFi works on the host the virtual network adapter will automatically use it as well.

Pic enclosed

Cheers
jimbo


Attached Thumbnails
No WiFi hardware found-vnetwork.png  
My System SpecsSystem Spec
14 May 2010   #9

Windows 7 Professional
 
 

All changing that setting does is point the VM to that networking adapter. VPC still emulates whatever hardware it natively emulates for LAN, just referencing that connection. No devIDs are passed and Windows 7 would have to (and therefore doesn't) relinquish control of the device.

Unfortunately, there is no way around this. I'm not sure what success other VM software might yield.
My System SpecsSystem Spec
14 May 2010   #10

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro with Media Center
 
 

Quote   Quote: Originally Posted by smc333 View Post
All changing that setting does is point the VM to that networking adapter. VPC still emulates whatever hardware it natively emulates for LAN, just referencing that connection. No devIDs are passed and Windows 7 would have to (and therefore doesn't) relinquish control of the device.

Unfortunately, there is no way around this. I'm not sure what success other VM software might yield.
I'm not sure if I understand your point correctly, so I'll just say this:

I have XP Mode installed on two laptops, both having the host's WiFi NIC as Adapter 1 in XP Mode settings. When on the road and only using WiFi (no LAN available), I've never had any problems to connect both my host and installed XP Mode to internet.
My System SpecsSystem Spec
Reply

 No WiFi hardware found




Thread Tools



Similar help and support threads for2: No WiFi hardware found
Thread Forum
URL not found when surfing on hotspot Wifi Network & Sharing
No network hardware found Network & Sharing
Wifi adaptor not found Network & Sharing
IR Hardware was working, now not found. Media Center
IR hardware not found. hauppauge 1250 tv tuner. Media Center
How I found my lost Hardware and Driver! General Discussion
4732z Bluetooth Hardware not found Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:30 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33