Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: XP Mode disconnects host wireless connection

21 Jun 2010   #1
kdpainter

Windows 7 Professional x64
 
 
XP Mode disconnects host wireless connection

I have Windows 7 Pro with XP Mode. When I start the virtual machine, my wireless connection disconnects. Rather, it remains connected except it reports that there is no internet connection. Shutting down the XP Mode virtual machine does not allow me to regain my internet connection. Repair connection, disconnect/reconnect all fail. I have to reboot to reconnect successfully.

I have the network interface in XP Mode set to NAT although I have tried other settings. As soon as I start the virtual machine, my wireless connection dies.

Does anyone have some idea what might be going on here? Thanks,
Kelly


My System SpecsSystem Spec
.
21 Jun 2010   #2
wallyinnc

Windows 7 x64 finally!
 
 

Have you tried to update the Ethernet controller drivers in the XP virtual machine?
My System SpecsSystem Spec
21 Jun 2010   #3
kdpainter

Windows 7 Professional x64
 
 

No, I haven't tried that but I will try that, thanks. Mainly because I lose my internet connection on the host, I figured the problem would be on the host side. I have updated the drivers on the host.
My System SpecsSystem Spec
.

22 Jun 2010   #4
kdpainter

Windows 7 Professional x64
 
 

Interesting. I got it working by disabling the "Microsoft Virtual WiFi Miniport Adaptor" under Windows 7 Pro x64. Then, my WiFi stays connected when I start the XP Mode virtual machine. I am not sure where this driver comes from but it is pretty old. It has a date of 6/21/2006 v6.1.7600.16385.
My System SpecsSystem Spec
Reply

 XP Mode disconnects host wireless connection




Thread Tools




Similar help and support threads
Thread Forum
Wireless LAN disconnects just after successful RDP connection
I've seen a few threads about similar problems, but nothing precisely the same and nothing I've found solves my issue. I've got a laptop (Toshiba Satellite) running Windows 7 Professional (64-bit). I'm trying to connect to the laptop from another machine via RDP, but the connection dies every time....
Network & Sharing
Wireless disconnects when on LAN
I want to keep both my wireless and LAN working and control my routing using advance option of meric. I want to use my LAN for my local devices and use wireless for internet. My problem is that as soon as I enable my LAN connection, my wireless gets disconnected. I would appreciate if you...
Network & Sharing
Wi-Fi connection just randomly disconnects on my netbook
I own a notebook. i have this problem that my wifi connection just disconnects shows a small X on the down right side. just like that randomly. and it wont reconnect, only when i restart my computer it works again. it happens like 10 minutes after i boot my PC. what can i do to prevent it ?...
Network & Sharing
Wireless Disconnects Every Few...Somethings
Hi, I've posted a few times in the past few days because it seems as though my PC is deteriorating before my eyes. I had a problem a while back where the only way I could connect to my router was to manually reset the router (the wireless adapter recognized the network, but would give errors...
Network & Sharing
Wireless Internet Disconnects
Hi I put Windows 7 Pro 64bit on my computer about 2 weeks ago and I'm using a Belkin wireless USB adaptor to connect to the Internet. I am connecting via Windows and NOT a 3rd party utility. Some days the wireless connection is solid, but the majority of the time, the wireless drops and I...
Network & Sharing
how to change the security mode for wireless connection
can some tell me how to do this , swicth to mac address filtering you need to change the security mode under wireless security in the wireless secton from security mode : wep in the drop down box to disable then save setting ... this is what im trying to do but i cant figure how to get there to...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:25.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App