Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: SP1 Not Listed in WU

14 Mar 2011   #51

Windows 7 Home Premium x64 w/ Service Pack 1

@Tech - No problem! Glad it worked (intel update) and I know it will be fine when and if you decide to update to SP1.. I'm running with no problems!

My System SpecsSystem Spec
16 Mar 2011   #52

Windows 7 Home Premium 64bit-HP OEM SP1 Installed

Finally got around to installing SP1 and all seems good.
My System SpecsSystem Spec
09 Apr 2011   #53

Win 7 Home Premium x64

After roughly six weeks of knowing that the Intel Graphics Driver was preventing SP1 from appearing in WU and HOPING HP and/or Intel would do something I followed the instructions and installed the updated driver.

I had to manually check for updates but sure enough there is SP1. As of yet I have not installed it.

If I had listened to Microsoft I would have reinstalled the OS for my computer. HP and Intel blame each other for not having an updated driver available. The whole situation is ridiculous. I imagine there are thousands of computers that will never be offered this update.
My System SpecsSystem Spec

18 Apr 2011   #54

Windows 7 Home Premium 62bit
Great thread - Solved it for me!

I was having the same problem with an Acer Aspire 7741Z not giving me Windows 7 SP1 in the WU check. I also had the Acer HD Graphics Driver Intel installed on a copy of Windows 7 64bit Home Edition on the laptop. I followed Indychic's advice and now have the latest Intel HD driver installed and WIN7 SP1 with no apparent problems noticed to date!

Thank you so much Indychic for taking the time to post this for us.

I also ran into the problem with Intel HD driver to contact Acer for a driver but when I uninstalled it from the remove programs feature from the Windows Control panel it let me install the latest driver. Immediately after a reboot of the driver installation I checked Windows update for SP1 and viola it was there! Installed with no problems.

The two things I find curious is Intel should tell you that you must uninstall the previous driver before trying to update it rather than giving you the cryptic message:
"Product Detected Intel HD Graphics
Current Driver Installed

A customized computer manufacturer driver is installed on your computer. The Intel Driver Update Utility is not able to update the driver. Installing a generic Intel driver instead of the customized computer manufacturer driver may cause technical issues. Contact your computer manufacturer for the latest driver for your computer"

This message goes away if you uninstall the previous driver as mentioned by Indychic first. This must also explain the reason why the latest driver does not show up in the Windows Device Manager when trying to update the driver as it will not uninstall the previous driver. Go figure!

The other weird thing that I have a hard time fathoming is how a video driver prevents SP1 from showing up in Windows Update but it does!

One final note. I installed Intel HD Graphics Driver which was the latest driver listed.

Thanks all for a great thread! If it wasn't for people like you sharing this info I would have pulled all my hair out by now!
My System SpecsSystem Spec
29 Jul 2013   #55

Windows 7 Home Premium 64-bit

Hello is there anyone out there who can help with this problem please of being unable to install SP1 due to Graphics Driver?
I have just hit this problem. Wanted to install IE-10 but cant because havent got SP1; cant install SP1 because of driver problem.
There is some kind of 'fix' for this in the about chain in this forum, but the link to the driver on the Intel website now fails.
Can anyone tell me what the correct link now is, or how to decide which driver from Intel I should choose. HP still do not seem to be offering any newer driver; unbelieveable.
What about going a roundabout route to get SP1 from Microsoft by means other than Windows Update? Would it work? Would I hit the same problem with the driver? Thanks for any help, regards
My System SpecsSystem Spec

 SP1 Not Listed in WU

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Why are my DVD drives not listed as 'D' & 'E'
Maybe I'm a little out of the loop...but I thought systems always listed DVD drives as 'D' & 'E' after the C: drive ? Attached jpg shows a split in drive letter assignments. I have Partition Magic but this only shows up the HDDs/SSD so I can't reset the letters there. Is there a way in Win 7...
Hardware & Devices
How to get the JEDEC value that is listed under SPD?
Here is a question that has been bothering me since yesterday. On SPD, I see a few JEDEC possibilities for my ram. I know how to set the XMP, by using profile1, but I actually went back to a manual timing and set it @ 9-9-9-24 @ 1600mhz. What I want to know is how I can get JEDEC#7 timings on the...
PC Custom Builds and Overclocking
my network it's listed twice
Hello, I've a wireless AP, it gives me through dhcpd IP address and gateway. However, I don't want to use the gateway provided by the AP, so I add on my windows 7 os, in the advanced settings for tcp/ip4 > default gateways , another one with value "1" as metric value. Problem is: When...
Network & Sharing
every track is listed twice?
All my tracks seem to show up twice, also very short clips (like ringtones) seem to have been found and entered too. Two questions - is there a menu that has a 'delete identical tracks' or doublers and is there a way to tell it not to list any tracks less than say 2 minutes? Thanks
Media Center
No speakers listed
So I recently installed Windows 7 on my pc (a little old, i have to admit) and I realized I have no sound. My drivers cd isn't working, because it supports only XP or less. The Windows device installing... thing kinda installed all my drivers, including the sound. But at the Sound window in Control...
Sound & Audio
Folder not listed
When looking in Computer/c:, some user folders are not listed in the c: directory. Folder/files are there but can not be found when browsing, for example, to attach to an email. System directories (e.g., Program Files) are listed. Is there a reason some folders are not listed? Is there a...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:32.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App