Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Windows 7 Service Pack 1 suspected bug with Itunes

25 Feb 2011   #1

Windows 7 Home Premium x64
 
 
Windows 7 Service Pack 1 suspected bug with Itunes

Hi guys.

I am just giving a heads up and seeing if anyone else experienced the same problem.

I downloaded Windows 7 service pack 1. After downloading, I went to itunes and connected my iPhone 4. When I connected my iPhone, itunes would freeze up and not respond. If I unplugged my iPhone, itunes would run as normal. But anytime I plugged in the iphone itunes would freeze and not show my iPhone being connected even after waiting 30 minutes.

After hours of troubleshooting I decided to uninstall Windows 7 service pack 1. Now itunes is running like normal and my iPhone is not causing itunes to freeze up

Just wondering if anybody else is having these issues. I called apple and reported my problem and they put it in their system. I also have the current itunes 10.1.2 and the current iPhone OS.

Steve

My System SpecsSystem Spec
.

25 Feb 2011   #2

Windows 7 x64
 
 

Quote   Quote: Originally Posted by Pennjersey83 View Post
Hi guys.

I am just giving a heads up and seeing if anyone else experienced the same problem.

I downloaded Windows 7 service pack 1. After downloading, I went to itunes and connected my iPhone 4. When I connected my iPhone, itunes would freeze up and not respond. If I unplugged my iPhone, itunes would run as normal. But anytime I plugged in the iphone itunes would freeze and not show my iPhone being connected even after waiting 30 minutes.

After hours of troubleshooting I decided to uninstall Windows 7 service pack 1. Now itunes is running like normal and my iPhone is not causing itunes to freeze up

Just wondering if anybody else is having these issues. I called apple and reported my problem and they put it in their system. I also have the current itunes 10.1.2 and the current iPhone OS.

Steve
That's just iTunes for ya. Does that from time to time on Windows 7 "SP0" also.
My System SpecsSystem Spec
25 Feb 2011   #3

 
 

Hi, welcome to the forums

The best advice I'd offer is to backup your iTunes music/apps then uninstall. Try re-installing to see if the problem is solved.


OS
My System SpecsSystem Spec
.


25 Feb 2011   #4

Windows 7
 
 

I noticed some issues with iTunes as well after updating...new issues. For one thing, it can be very slow to load, it won't ID your device either (it's not there when it is). These are new issues (for me). However, I have noticed an overall performance hit where everything seem to run a bit slower than before (I am anal when it comes to these things) so I do believe there are other issues at play. I did open up a thread here: Windows 7 SP 1: What issues are you now having after the upgrade?
My System SpecsSystem Spec
25 Feb 2011   #5

Window 7 Professional 64
 
 

I am having a horrible time. Downloaded the service pack today. Bought a new song on itunes and went to sync. Half my apps were no longer recognized (maybe probably the ones I downloaded via the iPod) and after the sync, the device no no music library in it at all. Then I tried a restore and I keep getting errors, and the device is clean just like when you first pull it out of the box.

Now I have a blank iPod that won't restore.

Awesome.
My System SpecsSystem Spec
25 Feb 2011   #6

Windows 7
 
 
SP1 Conflicts with iTunes / iPod

After installing SP1 on my Win 7-64 system, iTunes no longer recognized my iPod. iTunes also froze whenever the iPod was connected. System Restore to pre-SP-1 eliminated the problem immediately, as others have noted.

Don't blame iTunes - blame Microsoft for this one. Install SP1 at your own risk if you use iTunes with an iPod or iPhone.
My System SpecsSystem Spec
26 Feb 2011   #7

Window 7 Professional 64
 
 

Well, I uninstalled SP1 and it works again, but I had to go through a complete restore of the iPod, which involved disabling other conflicting software. What a chore.

Now it seems to be where I was 7 hours ago.
My System SpecsSystem Spec
26 Feb 2011   #8

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by Max Power View Post
Well, I uninstalled SP1 and it works again, but I had to go through a complete restore of the iPod, which involved disabling other conflicting software. What a chore.

Now it seems to be where I was 7 hours ago.
Yes it was a chore for me as well. I hope no foul play was involved by Microsoft since they now have Windows Phone 7. I don't know if a large percentage of users are experiencing an itunes / Windows 7 SP1 issue, but some users certainly are. I will eventually try to install SP1 again in a few weeks. As for now I suggest everybody with itunes make backups before installing SP1 again. And give time for Microsoft or Apple to fix the problem.
My System SpecsSystem Spec
26 Feb 2011   #9

Vista Ultimate 32 bit, Win 7 Pro 32 bit, Win 7 Pro 64 bit
 
 

Quote   Quote: Originally Posted by andy7 View Post
Don't blame iTunes - blame Microsoft for this one. Install SP1 at your own risk if you use iTunes with an iPod or iPhone.
Rubbish blame the application Itunes is noted for problems, its them lazy s.ds at iT THAT CAN'T BE BOTHERED.
My System SpecsSystem Spec
26 Feb 2011   #10

Vista Ultimate 32 bit, Win 7 Pro 32 bit, Win 7 Pro 64 bit
 
 

Quote   Quote: Originally Posted by Max Power View Post
Well, I uninstalled SP1 and it works again, but I had to go through a complete restore of the iPod, which involved disabling other conflicting software. What a chore.

Now it seems to be where I was 7 hours ago.
So your iTunes is more important than you computer, you have a strange sense of values.
My System SpecsSystem Spec
Reply

 Windows 7 Service Pack 1 suspected bug with Itunes





Thread Tools



Similar help and support threads for2: Windows 7 Service Pack 1 suspected bug with Itunes
Thread Forum
Windows 7 Service Pack 1 Windows Updates & Activation
Windows 7 Service Pack 1 (SP1) - Uninstall Tutorials
Windows 7 Service Pack 1 for x64 Windows Updates & Activation
Windows 7, Service Pack 1 Windows Updates & Activation
Windows 7 first Service Pack Chillout Room
Is windows 7 a service pack? General Discussion
Windows 7 is no service pack News

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:41 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33