Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Windows 7 SP1 Disables Happauge HVR-950 TV Tuner

25 Feb 2011   #1

Windows 7 x64 Home Premium
 
 
Windows 7 SP1 Disables Happauge HVR-950 TV Tuner

For the first 2 days after I installed Windows 7 SP1 while the Service Pack Upgrade Files were still on my HDD everything was fine, but as soon as I used Disk Cleanup to remove the 920 MB of Service Pack Upgrade Files my Happauge HVR-950Q TV Tuner which HP sells for the computers they make had been working absolutely flawlessly in every respect ever since I got my HP Elite Desktop eight months ago and now SP1 starts telling me that even though the TV Tuner was not currently working it would run much better anyway on a high speed USB interface which it informed me that my HP HPE 270f Intel Core i7 930 computer was completely lacking and that I needed to upgrade my nearly new computer to high speed USB.

So I did a Macrium Reflect Restoration of good old Win 7 on which my HVR-950Q has been rendering a consistently flawless High Definition Video performance for almost an entire year using USB 2.0 without any sign of sluggish performance during TB after TB of recording and playback and all was right again.

As I said everything was working perfectly fine while the 920 MB of Service Pack Update Files were still on the HDD, but after they were removed SP1 immediately put an end to the usefulness of the USB TV Tuner.

~Maxx~
.



Attached Images
 
My System SpecsSystem Spec
.

25 Feb 2011   #2

Windows 7 Ultimate SP1 (64-bit)
 
 

Hello there, Maxxwire.

There's a chance that you might got the USB bug that SP1 users (Via Windows Update) have been presenting.

The Windows 7 SP1 USB Driver Bug (what it is and how to fix it)

Try that and see how it goes it might help you

Post back with your results.
My System SpecsSystem Spec
25 Feb 2011   #3

Windows 7 x64 Home Premium
 
 

Thanks for the link Punkster!

The thread starter talked about running the DISM cleanup command ("DISM /Online /Cleanup-Image /spsuperseded") after installing SP1. The cleanup operation removes all the hotfixes that had been superseded by SP1, so it deletes the KB976972 security catalog and all the "repository" copies of the KB976972 usbehci.sys"

And another poster said it was the Standard extended host PCI to USB adapter not starting automatically after doing sp1 cleanup steps.

After I used the MS Disk Cleanup tool on the 920 MB of Service Pack Update Files this may apply in my case also because the cleanup removed 3.2 GB of files from a post SP1 total of 20.6 GB down to 17.4 GB after the Disc Cleanup removal which very likely contained the files that they were discussing.

Rather than use the batchfile method or delete all of the USB drivers and hope that the newer versions will appear in their place I think wait on installing SP1 again and hope that MS releases a hotfix for this SP1 USB bug since everything is just perfect with Win 7 as it is regardless.

~Maxx~
.


Attached Images
  
My System SpecsSystem Spec
.


02 Mar 2011   #4
Microsoft MVP

 

I think I would slipstream SP1 into my Installation DVD, wipe the HD and clean reinstall to see if that helps.

Otherwise I would contact Hauppage to see if others have experienced problems.
My System SpecsSystem Spec
02 Mar 2011   #5

Windows 7 x64 Home Premium
 
 

greg- Thank you for the reply, but I really don't think that its Happauge's problem because after I did a Macrium Reflect restore of Win 7 prior to SP1 the TV Tuner was once again working perfectly as it always has under Win 7. I will follow your suggestion though and see if other Happauge users are having the same problem after installing SP1.

~Maxx~
My System SpecsSystem Spec
03 Mar 2011   #6

Windows 7 Ultimate x64
 
 
ditto - no audio in tv after windows 7 sp1

I am seeing interesting behavior post SP1 on one of my systems as well. I have the 2250 and after installing the service pack audio is missing when watching and recording tv. Audio works perfectly otherwise. Netflix in media center, pandora via browser etc all work fine.

Only tv in media center either playing live or viewing recorded shows is missing audio.

I did the logical and uninstalled the service pack, unfortunately the issue has remained.
My System SpecsSystem Spec
08 May 2011   #7

Windows 7 x64 Home Premium
 
 

It looks as though Microsoft now has a fix for the 'USB Bug'...

Article ID: 2529073 - Last Review: May 3, 2011 - Revision: 1.0
Binary files in some USB drivers are not updated after you install Windows 7 SP1 or Windows Server 2008 R2 SP1

SYMPTOMS
After you install Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 Service Pack 1 (SP1), binary files in some USB drivers are not updated. For example, the Usbport.sys, Usbehci.sys, and Winusb.sys binary files are not updated.

This update is available from the Microsoft Update website:
http://update.microsoft.com

I tried downloading KB2529073 directly from Microsoft without success so it looks like I will have to wait until it shows up in Windows Updates before I can finally install Win 7 SP1 without the 'USB Bug'.

~Maxx~

.
My System SpecsSystem Spec
09 May 2011   #8

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64
 
 

My System SpecsSystem Spec
09 May 2011   #9

Windows 7 x64 Home Premium
 
 

That is the same page where I got my information from. I did check out the Hotfix link that is listed for KB2529073 and it states that there is no public Hotfix available. Hopefully KB2529073 will be available through Windows Update in the near future.

~Maxx~

.


Attached Thumbnails
Windows 7 SP1 Disables Happauge HVR-950 TV Tuner-kb2529073-hotfix.jpg  
My System SpecsSystem Spec
09 May 2011   #10

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64
 
 

Sorry, I though it was available.

BTW, I used the small utility that is contained in the link Punkster provided when SP1 first came out.
It works fine.
My System SpecsSystem Spec
Reply

 Windows 7 SP1 Disables Happauge HVR-950 TV Tuner





Thread Tools



Similar help and support threads for2: Windows 7 SP1 Disables Happauge HVR-950 TV Tuner
Thread Forum
windows sometimes disables my laptop speakers Sound & Audio
SFC /scannow Disables Windows mail Browsers & Mail
Happauge drivers Drivers
Windows 7 UAC disables itself Read for more. System Security
Happauge USB2 Tv tunner Problems! Drivers
Dual TV Tuner cards or 2 STB boxes and 1 tuner card Media Center
Windows areo automatically disables itself Customization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:46 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33