Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot install SP1 at all


28 Apr 2011   #1

Windows 7 64-bit
 
 
Cannot install SP1 at all

I'm running Windows 7 64-bit Pro with an AMD Phenom II x4 965BE CPU, 8G DDR3 1600 memory on a MSI NF980-G65 mainboard. All drivers are up-to-date.

I originally tried to install sp1 from the automatic updates, but that failed. I ordered the CD from MicroSoft and I'm getting the following error: ERROR_SERVICE_DISABLED(0x80070422) during the system setup. No mention of what service(s) are disabled. I googled the error code and all mentions were to check:
1.Automatic Updates
2.Background Intelligent Transfer Service (BITS)
3.Cryptographic Services
4.Remote Procedure Call (RPC)
5.System Restore Service

All were set to automatic.
Any ideas?

My System SpecsSystem Spec
.

28 Apr 2011   #2

Windows 7 Pro. 64/SP-1
 
 

Do you use Defender or is it turned off. I had it turned off when I downloade SP1 and installed.
My System SpecsSystem Spec
29 Apr 2011   #3

Windows 7 64-bit
 
 

Defender is set to run automatically. I'll try to turn it off and see what happens.

Thanks.
My System SpecsSystem Spec
.


29 Apr 2011   #4

Windows 7 64-bit
 
 

OK...disabled Defender. Didn't make a difference. Still won't load.

You know, as advanced as technology is today, I would think that Microsoft would identify which service(s) wasn't enabled/started in this preparation so people could get on with installing Microsoft's 'fixes' rather than wandering around in forums trying to do this or that to get it to work.

I'm really ticked that I can't install their product!! By the way, I can't upgrade to IE9 either. All other upgrades seem to download and install fine. Why do these give us a hard time??
My System SpecsSystem Spec
29 Apr 2011   #5

Windows 7 64-bit
 
 

Fixed the problem and both SP1 and IE9 installed without a hitch.

Browsed through all the services and, among those that were disabled, I found that the Windows Modules Installer was also disabled. I set this to 'Manual' and tried the SP1 install again. SP1 installed with no errors; tried IE9 and it, too, installed fine. Once these were installed, I got a boatload of other 'critical' updates to install, too.

Thanks for the replies everybody.
My System SpecsSystem Spec
29 Apr 2011   #6

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

rzn6jw

I'll have to remember that. I hadn't run into that being a problem.

Good find and you fixed your own problem and may help others in the process.

Mike
My System SpecsSystem Spec
01 May 2011   #7

Windows 7 Pro. 64/SP-1
 
 

Thanks for the info. I do wonder how it got turned off.
My System SpecsSystem Spec
01 May 2011   #8

Win7 Ultimate x64, Server 2008 R2
 
 

Quote   Quote: Originally Posted by rzn6jw View Post
Fixed the problem and both SP1 and IE9 installed without a hitch.

Browsed through all the services and, among those that were disabled, I found that the Windows Modules Installer was also disabled. I set this to 'Manual' and tried the SP1 install again. SP1 installed with no errors; tried IE9 and it, too, installed fine. Once these were installed, I got a boatload of other 'critical' updates to install, too.

Thanks for the replies everybody.
This exact same thing happened to me too, and I found it was that service being disabled that caused the issue. Let us know what you find out as to why it was disabled. Thanks, and glad you got it fixed!

My System SpecsSystem Spec
Reply

 Cannot install SP1 at all




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:29 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33