Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Win7 SP1 upgrade: ERROR_SXS_ASSEMBLY_MISSING (0x80073701)

16 May 2011   #1

Win7 Enterprise 64bit
 
 
Win7 SP1 upgrade: ERROR_SXS_ASSEMBLY_MISSING (0x80073701)

Hi,

I have a Windows 7 Enterprise edition.
When upgrading to SP1 (online or standalone file) I receive error:

ERROR_SXS_ASSEMBLY_MISSING (0x80073701)

I ran the System Update Readiness Tool but it didn't find any problems.
Also sfc /scannow didn't report any errors.

In the CBS log I find these errors:

2011-05-12 13:23:26, Error CSI 0000000e (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) #8045# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_PinDeployment(Flags = 0, a = Microsoft-Windows-Help-Customization-OEM-Deployment-LanguagePack, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture = [l:10{5}]"it-IT", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, cb = (null), s = (null), rid = [109]"Microsoft-Windows-Help-Customization-Package~31bf3856ad364e35~amd64~it-IT~6.1.7600.16385.OEMHelpCustomization", rah = (null), manpath = (null), catpath = (null), ed = 0, disp = 0)[gle=0x80073701]


I don't know why, but for some reason it wants something from an italian language pack:

Microsoft-Windows-Help-Customization-Package~31bf3856ad364e35~amd64~it-IT~6.1.7600.16385.OEMHelpCustomization


- lkpsetup only shows my default english language, no other languages.
- under \windows\system32\catroot\{F750E6C3-38EE-85E5-00C0F4C295EE}\
I have these files:

Microsoft-Windows-Help-Customization-Package~31bf3856ad364e35~amd64~~6.1.7600.16385.cat
Microsoft-Windows-Help-Customization-Package~31bf3856ad364e35~amd64~~6.1.7601.17514.cat
Microsoft-Windows-Help-Customization-Package~31bf3856ad364e35~amd64~en-US~6.1.7600.16385.cat
Microsoft-Windows-Help-Customization-Package~31bf3856ad364e35~amd64~en-US~6.1.7601.17514.cat
Microsoft-Windows-Help-Customization-Package~31bf3856ad364e35~amd64~it-IT~6.1.7600.16385.cat

This is the same for most of the other packages (no language, en-US and it-IT) in this directory.


How can I uninstall these it-IT packages ?

Thanks,
Kris

My System SpecsSystem Spec
.

17 May 2011   #2

Win7 Enterprise 64bit
 
 

Hi,

Some more info:


CheckSUR.log:
Code:
=================================
Checking System Update Readiness.
Binary Version 6.1.7601.21645
Package Version 11.0
2011-05-17 15:10

Checking Windows Servicing Packages

Checking Package Manifests and Catalogs

Checking Package Watchlist

Checking Component Watchlist

Checking Packages

Checking Component Store

Summary:
Seconds executed: 681
 No errors detected
sfc /scannow

Code:
Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations.
dism /online /get-features | more
Code:
Deployment Image Servicing and Management tool
Version: 6.1.7600.16385

Image Version: 6.1.7600.16385

Features listing for package : Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~6.1.7600.16385

Feature Name : OEMHelpCustomization
State : Enabled

Feature Name : CorporationHelpCustomization
State : Disabled
...
When I try to disable the OEMHelpCustomization package it stops at 17,9%

dism /online /disable-feature /featureName:OEMHelpCustomization

Code:
Deployment Image Servicing and Management tool
Version: 6.1.7600.16385

Image Version: 6.1.7600.16385

Disabling feature(s)
[==========                 17.9%                          ]

Error: 14081

The referenced assembly could not be found.

The DISM log file can be found at C:\windows\Logs\DISM\dism.log

There are alot of it-IT packages in the \Windows\servicing\Packages directory.
I suppose it's not only the Windows-Foundation-Package the SP1 upgrade fails on, just the first package it encounters.

On all the other sites I read about this problem, they suggest to do an in-place repair or uninstall all updates.

Anybody else got some other ideas ?

Best regards,
Kris
My System SpecsSystem Spec
18 May 2011   #3

Win7 Enterprise 64bit
 
 

Hi,

After 2 days of searching I was finally able to install SP1.
First, this was a Windows 7 Professional not Enterprise like I mentionned above.

The solution that worked for me:
- install vistalizator (Vistalizator - change display language in Windows Vista and Windows 7) and add the italian language pack
- I ran the SP1 upgrade, got the same error.
- copy the cbs.log under windows\logs\ to a different location
- scroll down to the bottom of the file and search for errors.
- in my case it gave an error for Package_51_for_KB976098~31bf3856ad364e35~amd64~~6.1.1.1
- uninstall update KB976098 and run SP1 upgrade again

You will have to do the last step several times untill all errors are gone.
In my case I also had to uninstall KB979306.
After the SP1 upgrade you can uninstall the language with vistalizator or lpksetup.

Hope this helps other people that encounter this error.

Greetings,
Kris
My System SpecsSystem Spec
.


18 May 2011   #4

Windows 7 Ultimate SP1 64-Bit
 
 

Hello Kris, welcome to Windows Seven Forums.

Sorry we didn't help you, but pleased to hear you were able to resolve the problem.

Thanks for posting to let us know, it may be of help to someone in the future.
My System SpecsSystem Spec
Reply

 Win7 SP1 upgrade: ERROR_SXS_ASSEMBLY_MISSING (0x80073701)





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:56 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33