Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win7 64bit SP1 not installing


21 Jun 2011   #1

Windows 7 64bit
 
 
Win7 64bit SP1 not installing

i'm getting the error while trying to update to service pack1:
ERROR_MOD_NOT_FOUND(0x8007007e)

tried to download the SP1 and then install it, the same error.
as suggested by MS tried with my Kaspersky off with no luck, too.
Disconnected all cameras and printers - the same error...

could you please advice of any other solution to this problem.

My System SpecsSystem Spec
.

21 Jun 2011   #2

Windows 7 Ultimate x86; Windows XP Pro SP3 x86; Windows Vista Ultimate x86
 
 

To be clear here, did you manually download the standalone, full Service Pack 1 and save it or was SP1 downloaded via Windows Update ?

Have you tried to run the System File Checker ? - How to Repair Windows 7 System Files with System File Checker

Have you run the System Update Readiness Tool (CheckSUR) for Windows 7 x64 yet ?
If yes, then please zip up and attach one of the logs that it created when it ran.
They are located at and named

Windows\Logs\CBS\CheckSUR.log
Windows\Logs\CBS\CheckSUR.persist.log

If not, then please click the above link, download, and save it.
When the download completes close all open programs and web browsers.

With the system connected to the internet ( so that cab files can be downloaded ) run CheckSUR, and restart if prompted to.

CheckSUR may not be able to resolve this specific return code, 0x8007007E. The issue is most likely related to either Kaspersky or a missing/corrupted system file.

Let's see what one of the logs looks like first before someone recommends a Repair or Clean installation of Win 7.
My System SpecsSystem Spec
21 Jun 2011   #3

Windows 7 64bit
 
 

automatic update failed, so i downloaded manualy SP1 and it failed again...
please find enlosed all logs as requested per above.

System file checker was unable to fix something that it found to be wrong ;o(((
i do hope i wont need a new install...

thank you
My System SpecsSystem Spec
.


21 Jun 2011   #4

Windows 7 Ultimate x86; Windows XP Pro SP3 x86; Windows Vista Ultimate x86
 
 

There are files missing that were originally installed with Windows 7 and a couple that are from a recent update, KB2533552. Unfortunately, my system is Windows 7 32 bit and I don't have them on hand as your system is 64 bit.

Do you have a Windows 7 installation DVD so you can attempt a Repair Install ? - How to Do a Repair Install to Fix Windows 7
My System SpecsSystem Spec
21 Jun 2011   #5

windows 7 ultimate
 
 

Quote   Quote: Originally Posted by MowGreen View Post
....... Unfortunately, my system is Windows 7 32 bit and I don't have them on hand as your system is 64 bit........
Which files are they Mow?
My System SpecsSystem Spec
22 Jun 2011   #6

Windows 7 64bit
 
 

i do have the disc...
but if i do the repair, what happens to all my software that i already have installed?
also could you list the files missing, maybe i could get them from the internet or someone?

thank you very much, Tom
My System SpecsSystem Spec
23 Jun 2011   #7

Windows 7 Ultimate x86; Windows XP Pro SP3 x86; Windows Vista Ultimate x86
 
 

Here's a list of the missing/corrupted files and their locations

wbemdisp.dll amd64_microsoft-windows-wmi-scripting_31bf3856ad364e35_6.1.7600.16385_none_bd062a3e0c6e3ed4

wbemdisp.tlb amd64_microsoft-windows-wmi-scripting_31bf3856ad364e35_6.1.7600.16385_none_bd062a3e0c6e3ed4

wbemprox.dll amd64_microsoft-windows-wmi-core_31bf3856ad364e35_6.1.7600.16385_none_1548f4bc3949a69a

WBEMCons.mof amd64_microsoft-windows-wmi-mof_31bf3856ad364e35_6.1.7600.16385_none_fe6bb73bc9e20a39

wbemcntl.dll amd64_microsoft-windows-wmi-management-snapins_31bf3856ad364e35_6.1.7600.16385_none_f7dacf5fd4a3c2a7

wbemcore.dll amd64_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7600.16385_none_655452efe0fb810b

wbemcore.dll amd64_microsoft-windows-wmi-core-wbemcore-dll_31bf3856ad364e35_6.1.7600.16385_none_3db4a48af082b51c

wbemprox.dll amd64_microsoft-windows-wmi-core_31bf3856ad364e35_6.1.7601.17514_none_177a088436382a34

t2embed.dll x86_microsoft-windows-font-embedding_31bf3856ad364e35_6.1.7600.20788_none_b6231cc5996240b8


wbemprox.dll 6.1.7600.16385 originally was installed with Windows 7 and is also included in KB2533552
t2embed.dll 6.1.7600.20788 is from KB982132

Your personal data would be preserved when doing a Repair Installation.
It's always best to backup your personal data regularly and before installing Service Packs or doing a Repair Installation.

All updates would need to be reinstalled however, if you install the full standalone of SP1 first after doing the Repair Install that will take care of most of the updates for Windows 7.

If you can wait a little perhaps we can obtain the missing/corrupted files from a Trusted Source, such as fimble, rather than downloading them from the internet.
My System SpecsSystem Spec
25 Jun 2011   #8

Windows 7 64bit
 
 

thats great, ofcourse i can wait, no rush...
just let me know when you get them...

BIG BIG BIG thank you for your hard work and your help....
My System SpecsSystem Spec
30 Jun 2011   #9

Windows 7 64bit
 
 

any news about those missing files, MowGreen?
My System SpecsSystem Spec
01 Jul 2011   #10

Windows 7 Ultimate x86; Windows XP Pro SP3 x86; Windows Vista Ultimate x86
 
 

No one has provided them as yet and I'm not sure that someone will, Tomas.

BTW, I just did a Repair Install of a client's system that had a similar issue installing SP1. It was much easier than replacing a large number of missing files, their data was preserved, and SP1 installed flawlessly. Then I installed all of the updates by groups ( Security updates first, then Performance and Stability updates, then .NET Framework updates, and finally, upgraded Internet Explorer to IE9 )

Before doing the Repair Install I uninstalled the antivirus . This noticeably improved the time it took to install SP1 and all of the updates.

So, I highly recommend the Repair Installation route.

Actually, a clean installation is my preferred method.
Then install the manually downloaded, standalone full package of SP1 with no AV installed, then do all of the updates as I listed them.
That goes really fast and allows one to watch TV at the same time.
My System SpecsSystem Spec
Reply

 Win7 64bit SP1 not installing




Thread Tools



Similar help and support threads for2: Win7 64bit SP1 not installing
Thread Forum
Solved Win7 64bit: Installing in other drives/partitions General Discussion
difficulty installing win7 64bit via USB key Installation & Setup
Installing Java and Flash in Win7 64bit Installation & Setup
Installing drivers on new win7 64bit ultimate os General Discussion
Error's (0x8007045D and 0x80070002) while installing Win7 Ult 64bit Installation & Setup
Installing Win7 32bit On A 64bit Machine Hardware & Devices
Installing programs on 64bit win7 Software

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:51 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33