Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Service PK1 Install not Successfull, registry error


04 Jul 2011   #1

Windows 7 Home Premium x64, Windows XP Professional, Ubuntu 10.04 Lucid Linx
 
 
Service PK1 Install not Successfull, registry error

I have been trying to install Windows 7 SP1 for days, and keep getting the same error code... "Invalid Value for Registry. Error: REGDB_E_INVALIDVALUE (0x80040153)"

I did the online help, with now luck, I did the 'Troubleshooting problems installing a service pack for Windows 7', (the sytem readiness tool wont install either, the troubleshooter said it resolved a problem, but didn't, and I have Avast AV, and it won't let me shut it down even using task manager), unable to run Windows Update in Safemode and tried to download and install manually while in Safemode, but same error.

Here is what is in Event Viewer...

Installation Failure: Windows failed to install the following update with error 0x80070643: Windows 7 Service Pack 1 for x64-based Systems (KB976932).

There are also a lot of these in Event Viewer, before and after the Install Failure...

"Event 18213 DistributedCOM.
The launch and activation security descriptor for the COM Server application with APPID
{8BC3F05E-D86B-11D0-A075-00C04FB68820}
is invalid. It contains Access Control Entries with permissions that are invalid. The requested action was therefore not performed. This security permission can be corrected using the Component Services administrative tool."

Not sure if that has anything to do with it, but it looks like a problem as well.

Any idea how I can fix the registry error, short of re-installing Windows 7?

Thanks ahead!

My System SpecsSystem Spec
.

04 Jul 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

can you verify something for me?
Do you have a load of decom errors in your event log?
my computer (rightclick) manage - expand logs.
My System SpecsSystem Spec
04 Jul 2011   #3

Windows 7 Home Premium x64, Windows XP Professional, Ubuntu 10.04 Lucid Linx
 
 

If you are talking about in Event Viewer, I think that is at the bottom of my post, the second Event. it shows to be Event 18213, DistributedCOM, and roughly about 40,000 of them.
My System SpecsSystem Spec
.


04 Jul 2011   #4

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

First thing I would try is reinstalling all your .net framework stuff.
When dcom freaks out that's usually the reason.
Download .NET Framework

reinstalling or repair installing it should fix any registry entries that may have gone bad or been removed.
My System SpecsSystem Spec
04 Jul 2011   #5

Windows 7 Home Premium x64, Windows XP Professional, Ubuntu 10.04 Lucid Linx
 
 

Yuck! I've had to reinstall .net framework stuff in the past. Back then you had to have a special uninstall tool to uninstall all the .net versions first and then re-install 1 by 1, in the correct order!
My System SpecsSystem Spec
04 Jul 2011   #6

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

just try loading the full v4 stuff for now.
My System SpecsSystem Spec
04 Jul 2011   #7

Windows 7 Home Premium x64, Windows XP Professional, Ubuntu 10.04 Lucid Linx
 
 

Quote:
just try loading the full v4 stuff for now.
I did that just now, maybe it will help with the DCOM errors, but still need a fix for the registry error.

I've got eveyrthing backed up, so if I have to re-install or repair install, so be it. I think I may just do a complete install, so I can format and clear my old XP partition since I don't use it anymore.
My System SpecsSystem Spec
04 Jul 2011   #8

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

so after installing the v4 you still get the same registry error...
yeah repair install or restore point.
It's possible it existed in previous points though since this is the kind of thing that only pops up when you do something specific.
My System SpecsSystem Spec
04 Jul 2011   #9

Windows 7 Home Premium x64, Windows XP Professional, Ubuntu 10.04 Lucid Linx
 
 

Nah, it didn't fix anything. I'll reboot and try again later just in case, but doubt anything will change. Restore point was one of the first things I tried as well...

thanks for the help.
My System SpecsSystem Spec
04 Jul 2011   #10

Microsoft Windows 8.1 Pro 64-bit
 
 

not to through a stone in the grinder here, but if it helps any:

have you installed all other important updates before trying to install the service pack (including previously hidden important updates)? That has often been a problem. And if you haven't restarted the computer in a while, sometimes, strange as it is, it can have a positive effect.

updated drivers (if it is needed) may be a good thing here if nothing else seems to work
My System SpecsSystem Spec
Reply

 Service PK1 Install not Successfull, registry error




Thread Tools



Similar help and support threads for2: Service PK1 Install not Successfull, registry error
Thread Forum
Solved Error 800B0100 when trying to install Windows 7 Service Pack 1 Windows Updates & Activation
Error 0x80070643 Service pack 1 install failure Windows Updates & Activation
Windows 7 Service Pack 1 fails to install error code 8024200D Windows Updates & Activation
Solved cannot install service pack 1. error trust_e_nosignature Windows Updates & Activation
Service Pack 1 error code on install Windows Updates & Activation
Trying to install Windows 7 Service Pack 1 SP1 error 80070002 Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:36 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33