Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win 7 SP1 error 800B0100

09 Jul 2011   #1
ferrytrip1

Windows 7
 
 
Win 7 SP1 error 800B0100

Hi, I seem to have the same errors installing the SP1 as other, as yet I have not been successful.

I ran the system update readiness tool, it told me KB947821 was not installed.

I downloaded the .iso and tried to install from CD. Not successful, it told me the error was trust_e_nosignature.

So far I have not found a way to do this update.

PC was just built few days ago and was running fine till this update.

Can anybody advise where I go from here?

Thanks

Simon


My System SpecsSystem Spec
.
09 Jul 2011   #2
seavixen32

Windows 7 Ultimate SP1 64-Bit
 
 

Rather than installing from a CD, I downloaded and saved SP1 to my hard drive, and installed it from there.

That said, have you tried installing SP1 via Windows Updates?

Useful information in this link: Support for Microsoft Update technical problems - troubleshooting
My System SpecsSystem Spec
09 Jul 2011   #3
niemiro

Vista Home Premium x86 SP2
 
 

Quote   Quote: Originally Posted by ferrytrip1 View Post
Hi, I seem to have the same errors installing the SP1 as other, as yet I have not been successful.

I ran the system update readiness tool, it told me KB947821 was not installed.

I downloaded the .iso and tried to install from CD. Not successful, it told me the error was trust_e_nosignature.

So far I have not found a way to do this update.

PC was just built few days ago and was running fine till this update.

Can anybody advise where I go from here?

Thanks

Simon
Hello Simon!

Well done on trying to run the System Update Readiness Tool (SURT). Since the System Update Readiness Tool is our method of fixing 0x800B0100 (TRUST_E_NOSIGNATURE), I will need to take some log files, and do some manual fixing, enough to run the System Update Readiness Tool successfully, and then we can go from there.

Please copy the C:\Windows\Logs\CBS folder to your Desktop, right click on it > Send to > Compressed (zipped) folder, and upload the new file which is created on your Desktop here.

Thanks a lot!

Richard
My System SpecsSystem Spec
.

09 Jul 2011   #4
ferrytrip1

Windows 7
 
 

Quote   Quote: Originally Posted by seavixen32 View Post
Rather than installing from a CD, I downloaded and saved SP1 to my hard drive, and installed it from there.

That said, have you tried installing SP1 via Windows Updates?

Useful information in this link: Support for Microsoft Update technical problems - troubleshooting
The problem first came about as windows update kept failing. I followed all the repair solutions from MS. It is still the same now.

All other updates are ok from Windows update.

I tried the CD in safe mode - still no luck

Thanks for the reply

Simon
My System SpecsSystem Spec
09 Jul 2011   #5
ferrytrip1

Windows 7
 
 

Quote   Quote: Originally Posted by niemiro View Post
Quote   Quote: Originally Posted by ferrytrip1 View Post
Hi, I seem to have the same errors installing the SP1 as other, as yet I have not been successful.

I ran the system update readiness tool, it told me KB947821 was not installed.

I downloaded the .iso and tried to install from CD. Not successful, it told me the error was trust_e_nosignature.

So far I have not found a way to do this update.

PC was just built few days ago and was running fine till this update.

Can anybody advise where I go from here?

Thanks

Simon
Hello Simon!

Well done on trying to run the System Update Readiness Tool (SURT). Since the System Update Readiness Tool is our method of fixing 0x800B0100 (TRUST_E_NOSIGNATURE), I will need to take some log files, and do some manual fixing, enough to run the System Update Readiness Tool successfully, and then we can go from there.

Please copy the C:\Windows\Logs\CBS folder to your Desktop, right click on it > Send to > Compressed (zipped) folder, and upload the new file which is created on your Desktop here.

Thanks a lot!

Richard
File attached, thanks

Simon
My System SpecsSystem Spec
09 Jul 2011   #6
niemiro

Vista Home Premium x86 SP2
 
 

Quote   Quote: Originally Posted by ferrytrip1 View Post
Quote   Quote: Originally Posted by niemiro View Post
Quote   Quote: Originally Posted by ferrytrip1 View Post
Hi, I seem to have the same errors installing the SP1 as other, as yet I have not been successful.

I ran the system update readiness tool, it told me KB947821 was not installed.

I downloaded the .iso and tried to install from CD. Not successful, it told me the error was trust_e_nosignature.

So far I have not found a way to do this update.

PC was just built few days ago and was running fine till this update.

Can anybody advise where I go from here?

Thanks

Simon
Hello Simon!

Well done on trying to run the System Update Readiness Tool (SURT). Since the System Update Readiness Tool is our method of fixing 0x800B0100 (TRUST_E_NOSIGNATURE), I will need to take some log files, and do some manual fixing, enough to run the System Update Readiness Tool successfully, and then we can go from there.

Please copy the C:\Windows\Logs\CBS folder to your Desktop, right click on it > Send to > Compressed (zipped) folder, and upload the new file which is created on your Desktop here.

Thanks a lot!

Richard
File attached, thanks

Simon
Well done! Let's get started with the fixing! Interestingly, I am seeing a successful run of SURT from 2011-07-08 22:28. Anyway, let's fix some of what is causing this, and then reassess the situation.

WARNING! This fix was created specifically for this user! If you are not this user, do not follow these instructions!
@ferrytrip1: Ignore the above

Download the attached .zip file. Inside it, will be two folders, Packages and Manifests.

Create these folders if they do not already exist: C:\Windows\Temp\CheckSur\Servicing\Packages\ and C:\Windows\Temp\CheckSur\winsxs\Manifests

Extract Packs.zip onto your Desktop. Please place the contents of my Desktop\Packages in C:\Windows\Temp\CheckSur\Servicing\Packages\ and my Desktop\Manifests in C:\Windows\Temp\CheckSur\winsxs\Manifests.

DO NOT place the .zip file in that folder, or the folders themselves. Make sure that a lot of files are in each of those Checksur folder.

Re-run the System Update Readiness Tool, and get me another copy of C:\Windows\Logs\CBS\CheckSUR.log.

Also, please retest Windows Updates (with fingers slightly crossed, no matter how much we both know that that won't help! lol.)

Thanks a lot!

Richard


Attached Files
File Type: zip Packs.zip (32.2 KB, 212 views)
My System SpecsSystem Spec
09 Jul 2011   #7
ferrytrip1

Windows 7
 
 

Thank you Richard. The Packages and Manifest folders were there but empty. I ran the SURT and got an installation complete message this time.

Copy of CBS folder attached.

Have rerun Windows Update and got a successful message

Thank you very much for your prompt help

Only 3 more laptops and an HTPC to update now.....

Thanks

Simon
My System SpecsSystem Spec
09 Jul 2011   #8
niemiro

Vista Home Premium x86 SP2
 
 

Hello again, Simon!

No problem! Your logs look good now! If there are no more problems, I am willing to call this one solved. Would you agree? Are you happy with that?
  • If your problem is solved please use the Mark this thread as solved link at the top of your thread.
I am sure that they won't, but if any of your other computers have problems, I am willing to help with those too, either one at a time in this thread, or at the same time, each in their own thread, to avoid confusion.

It has been a pleasure to work with you!

Richard
My System SpecsSystem Spec
09 Jul 2011   #9
ferrytrip1

Windows 7
 
 

Thanks again for your help, I will mark this as closed.

Simon
My System SpecsSystem Spec
Reply

 Win 7 SP1 error 800B0100




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 Update error when installing SP1 error 800b0100
Hi there guys! I've noticed you have helped people before having the same issue I am. When trying to running windows updates (service pack 1) I am getting the 800B0100 error. I have tried all the "Microsoft" fixes (FixIt, SUR tool etc), but no luck. I have run the sfc /scannow and have the CBS...
Windows Updates & Activation
Windows 7 Update error when installing SP1 error 800b0100
Hello, new to this forum, my apologies if I've missed any of the conventions for posting. I have been dealing with a persistent error 800b0100 error when trying to update to service pack 1 for Windows 7 Professional. I've tried running Mircosoft FixIt in aggressive mode and have ran the SUR tool...
Windows Updates & Activation
SP1 Error 800B0100
Hi Guys i just Formatted my pc and all updates have been installed only for SP1 i've tried The windows standalone Installer nothing is working ???
Windows Updates & Activation
Error Installing Service Pack 1 Error 800B0100
Please help me I am new to this forum and have a problem in installing SP1 for windows 7, i get the error 8000100 , I have already tried the system readiness tool 2 times and all it does is install a hotfix , pls help!!! :cry::cry:
Windows Updates & Activation
800B0100 error
All of my security updates are failing with the 800B0100 error code and I just noticed that this has been occuring since 11/15 when my computer downloaded SP1 (successfully). Other downloads are working (eg, Hotfix for Windows KB947821 downloaded successfully on 12/5). It appears that only the...
Windows Updates & Activation
Win 7 SP1 Error 800B0100
Hi, I'm facing the same problem others are facing with regards to installing Windows 7 SP1. I've tried using WU and Manual Update to install KB947821 but to no avail. I keep getting the message that installation was not successful, with the error code Error: TRUST_E_NOSIGNATURE(0x800b0100). I've...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:35.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App