Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: #elementModuleHeaderText# message in Windows Update Module


04 Feb 2012   #1
Philip Donald

Windows 7 Starter 32 bit
 
 
#elementModuleHeaderText# message in Windows Update Module

Hi

I struggled initially to install Service Pack 1 on Windows 7 as the 'sqmapi.dll' was missing. This was fixed by a registry fixing programme. Since that install, I get the message #elementModuleHeaderText# in the Windows Update Module, and I can't see if it is working in any way.

I have tried the following:

Running: MicrosoftFixit.wu.Run and it made no difference
Running: WindowsUpdateAgent30-x86 and this too made no difference
Following the steps set out in "http://support.microsoft.com/kb/971058/en-gb#LetMeFixItMyselfAlways" to try reset Windows Update and I received the following error messages:

FIRST TIME AROUND

Loaded but entry point not found:

regsvr32.exe mshtml.dll
regsvr32.exe shdocvw.dll
regsvr32.exe browseui.dll
regsvr32.exe qmgr.dll

Failed to load:

regsvr32.exe msxml.dll
regsvr32.exe gpkcsp.dll
regsvr32.exe sccbase.dll
regsvr32.exe slbcsp.dll
regsvr32.exe initpki.dll
regsvr32.exe wuaueng1.dll
regsvr32.exe wucltui.dll
regsvr32.exe wuweb.dll
regsvr32.exe muweb.dll


The following command was not found:

reset winsock



SECOND TIME AROUND

The filename, directory name, or volume label syntax is incorrect

Ren %systemroot%\SoftwareDistribution\DataStore *.bak
Ren %systemroot%\SoftwareDistribution\Download *.bak

Access is denied:

Ren %systemroot%\system32\catroot2 *.bak

Loaded but entry-point DllRegisterServer was not found

regsvr32.exe mshtml.dll
regsvr32.exe shdocvw.dll
regsvr32.exe browseui.dll
regsvr32.exe qmgr.dll

The module failed to load:

regsvr32.exe msxml.dll
regsvr32.exe gpkcsp.dll
regsvr32.exe sccbase.dll
regsvr32.exe slbcsp.dll
regsvr32.exe initpki.dll
regsvr32.exe wuaueng1.dll
regsvr32.exe wucltui.dll
regsvr32.exe wuweb.dll
regsvr32.exe muweb.dll

The following command was not found:

reset winsock


I am now posting my own question because I think I deserve a medal or an answer.

I cannot run sfc /scannow in Command Prompt as it says Access is denied. I am running Command Prompt as an administrator, so I don't know what I am doing wrong. I would prefer to run sfc /scannow before restoring to the pre SP1 restore point as I struggled so much getting SP1 installed. Please help me run sfc /scannow.

Grace and peace
Philip


My System SpecsSystem Spec
04 Feb 2012   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

I suspect that your 'registry fixing program' has stuffed up more than it solved, and brokena few things along the way.
Which program was it?


WRT the SoftwareDistribution folder - you have to stop the WU service before you can rename it
NET STOP WUAUSERV
from an Elevated Command Prompt

Re the winsock reset - the proper command - again in an elevated Command prompt is
NETSH WINSOCK RESET
My System SpecsSystem Spec
04 Feb 2012   #3
Philip Donald

Windows 7 Starter 32 bit
 
 

Hi Noel

The programme was dffsetup_sqmapi.exe. That was the download file at least, I've uninstalled it.

Yeah, where I recorded the errors I was following a long list of instructions and most of them went through fine. The first two instructions are:

Stop the BITS service and the Windows Update service. To do this, type the following commands at a command prompt. Press ENTER after you type each command.
  • net stop bits
  • net stop wuauserv
and they went through fine.


I recorded the errors because to record every step would have taken hours. I did stop the services etc before trying to rename folders etc. I found a .bat file with the same instructions and they went through fine. So if I manually go into Command Prompt I get difficulties.

I've uploaded a screen shot so you can see the error.

I can see that the automatic updater is working because since the Service Pack install, more Updates have been updated under 'View Installed Updates'. So the problem is more to do with the controls of Windows Update than with the functionality.

Any ideas what to do with the sfc /scannow problem?


Attached Thumbnails
-windows-update-page.jpg  
My System SpecsSystem Spec
04 Feb 2012   #4
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

You can always copythe entire command prompt to Notepad (click on the C: icon top left, and select Edit>Select All and hit the Enter key - paste as normal) then either upload the file as an attachment, or if it's small paste it into your responses.

Please check the Environment Variables -
in a command prompt window, enter the following command

Code:
REG QUERY "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment"
copy/paste the results to your response.

I can't find the registry thingy you refer to - Google comes up empty on the filename.

I suspect that you could be in clean install territory here - tehre's a good chnce that sonething is well stuffed.

Please find the copy of SQMAPI.DLL that is currently installed - what version is it, and what is the EXACT filesize quoted in Properties?
Do a Search for it in the Windows folder - how may copies of it are there on your system (there should be lots! - I have 38 <g>)
Are any dated more recently than the one in the System32 folder OR the SysWOW64 folder?
My System SpecsSystem Spec
04 Feb 2012   #5
Philip Donald

Windows 7 Starter 32 bit
 
 

Hi Noel

Okay, I'm attaching two file. The one is the Command Prompt Environment and the other is the search results for sqmapi.dll. I have 13 files in the Windows Folder and 4 different File versions. The one file version (the oldest one) comes in two different sizes but let me explain it systematically:

The bottom five instances (I'm working upwards here) of the file are all version 6.1.7600.16385 and come in at 185 KB. The next instance is version 6.0.6000.16386 and comes in at 142 KB. Then we have five instances of version 6.1.7601.17514 coming in at 186 KB. This includes the version in the System32 folder. The next one up is the newest version 6.1.760117608, also at 186 KB. Finally we have version 6.0.6000.16386 again, but this time the file is 138 KB. I don't have any in the folder SysWOW64. Those are all the versions in the Windows folder. I have two more in the Programme Files folder, one version 16386 at 138KB and one 17514 at 186 KB.

I'd prefer to restore than to go back to reinstall. I have a Repair Disk made after the SP 1 update. I received the OS on the computer with no disks. But there is a restore point from before the SP 1 install. Anyway, if you can see anyway to fix this up from where we are, that would be first prize.

Grace and peace
Philip


Attached Thumbnails
-sqmapi.jpg  
Attached Files
File Type: txt Environment.txt (1.3 KB, 28 views)
My System SpecsSystem Spec
04 Feb 2012   #6
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

They look OK to me - my listing was from an x64 install so it's different to yours, but my VM (which is an un-updated SP1 install) looks almost the same.
One point of concern may be the one in the Backup folder, it seems to have been changed today, and the filesize is odd.

Are tehre any comments in the Event Viewer about the problem with SFC?

Please attach a copy of the CBS.log file (or the SFCDETAILS.TXT file according to the instructions here - How to use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7 ) to your response - it may show some details at least.
My System SpecsSystem Spec
04 Feb 2012   #7
Philip Donald

Windows 7 Starter 32 bit
 
 

Hi Noel

Thanks for coming back to me. I'm afraid the SFC /scannow does not generate any events and the said text file is empty as well. I just get that blank Access is denied when I type it in. I even activated the hidden administrator to see if that would do the trick, but still no luck. (I'm running sfc /scannow on another of my computers and it works fine, so I am typing in the correct commands).

As you said earlier, this may need a reinstall. I had this problem with sfc /scannow even before I installed the SP1, so this goes back to a while back. Even before I did the repair of sqmapi.dll.

If you come up with any ideas in the next few hours (when I imagine you will be sleeping), please let me know and I'll try repair it. Otherwise I will do a reinstall or something. I may have to download a Windows Version as I never received a disk with this computer. Bought it in South Korea, and didn't bother to check the disk contents. I only got a driver disk.

Grace and peace
Philip
My System SpecsSystem Spec
04 Feb 2012   #8
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Bought in South Korea? What was the original language?
Please - just in case - post an MGADiag report, as it may give a clue as to what else is wrong.
To properly analyse and solve problems with Activation and Validation, we need to see a full copy of the report produced by the MGADiag tool (download and save to desktop - http://go.microsoft.com/fwlink/?linkid=52012 )
Once saved, run the tool.
Click on the Continue button, which will produce the report.
To copy the report to your response, click on the Copy button in the tool (ignore any error messages at this point), and then paste (using either r-click/Paste, or Ctrl+V ) into your response.

Please also state the Version and Edition of Windows quoted on your COA sticker (if you have one) on the case of your machine, but do NOT quote the Key on the sticker!
How to Tell - Home
My System SpecsSystem Spec
05 Feb 2012   #9
Philip Donald

Windows 7 Starter 32 bit
 
 

Okay, it follows below. There is no COA sticker, the dealer however installed the OS. I did change location from Korea to South Africa, but he installed it with English US and English UK. Perhaps he used Korean to start the process off (with the built-in administrator account) and then created a user with the English language versions. However, when I activated the Built-in (hidden) administrator, it was in English. I am operating out of the user account name that he created, but I have changed the name to 'Marion' as this is my wife's Netbook. Please let me know if there is anything else I can follow up on. Originally, in the version specs it said activated, now it says 28 days to activate.

Grace and peace
Philip

Diagnostic Report (1.9.0027.0):
-----------------------------------------
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: N/A, hr = 0xc004f012
Windows Product Key: *****-*****-CMMYT-WHMY2-89M6G
Windows Product Key Hash: Hb01nJn1bGwj7lOU9wXoRUMnZn4=
Windows Product ID: 00342-946-6744545-85807
Windows Product ID Type: 5
Windows License Type: Retail
Windows OS version: 6.1.7601.2.00010300.1.0.011
ID: {23B03E46-C68D-4641-9FB3-3EE9B852B636}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Starter
Architecture: 0x00000000
Build lab: 7601.win7sp1_gdr.111025-1505
TTS Error:
Validation Diagnostic:
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->
File Mismatch: C:\Windows\system32\wat\watadminsvc.exe[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\npwatweb.dll[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\watux.exe[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\watweb.dll[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\en-US\sppc.dll.mui[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\en-US\sppcext.dll.mui[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\en-US\slc.dll.mui[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\en-US\slcext.dll.mui[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\en-US\sppuinotify.dll.mui[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\en-US\slui.exe.mui[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\en-US\sppcomapi.dll.mui[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\en-US\sppcommdlg.dll.mui[6.1.7600.16385], Hr = 0x800b0100
File Mismatch: C:\Windows\system32\en-US\sppsvc.exe.mui[6.1.7600.16385], Hr = 0x800b0100

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{23B03E46-C68D-4641-9FB3-3EE9B852B636}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.011</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-89M6G</PKey><PID>00342-946-6744545-85807</PID><PIDType>5</PIDType><SID>S-1-5-21-3196210055-2473974765-1846434818</SID><SYSTEM><Manufacturer>Acer</Manufacturer><Model>AO722</Model></SYSTEM><BIOS><Manufacturer>Acer</Manufacturer><Version>V1.07</Version><SMBIOSVersion major="2" minor="7"/><Date>20110919000000.000000+000</Date></BIOS><HWID>98853A07018400F2</HWID><UserLCID>1C09</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>South Africa Standard Time(GMT+02:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>ACRSYS</OEMID><OEMTableID>ACRPRDCT</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, Starter edition
Description: Windows Operating System - Windows(R) 7, RETAIL channel
Activation ID: 71c7c851-1863-4232-8ac2-cdd7f5e45dae
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00342-00170-946-674454-00-2057-7600.0000-3592011
Installation ID: 019442484496268552141795795600167091041072500144995843
Processor Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88338
Machine Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88339
Use License URL: http://go.microsoft.com/fwlink/?LinkID=88341
Product Key Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88340
Partial Product Key: 89M6G
License Status: Licensed
Remaining Windows rearm count: 4
Trusted time: 2012/02/05 08:55:42 AM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: N/A
HealthStatus: 0x0000000000000000
Event Time Stamp: N/A
ActiveX: Not Registered - 0x80040154
Admin Service: Not Registered - 0x80040154
HealthStatus Bitmask Output:


HWID Data-->
HWID Hash Current: MgAAAAEAAgABAAEAAAACAAAAAwABAAEAJJRcgM1QVPnC5EoA8AtiPfZ98DegIom5UF4=

OEM Activation 1.0 Data-->
N/A

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: no, invalid SLIC table
Windows marker version: N/A
OEMID and OEMTableID Consistent: N/A
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
APIC ACRSYS ACRPRDCT
FACP ACRSYS ACRPRDCT
HPET ACRSYS ACRPRDCT
BOOT ACRSYS ACRPRDCT
MCFG ACRSYS ACRPRDCT
SLIC ACRSYS ACRPRDCT
SSDT AMD POWERNOW
SSDT AMD POWERNOW
My System SpecsSystem Spec
05 Feb 2012   #10
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

You have some major problems.
Vistalizator is installed to circumvent the licensing restrictions - There is no way that Starter Edition is supposed to be able to handle two languages.
Starter is also an OEM-only license - your your report shows it as being a Retail license - because it's the Default Key which CANNOT be activated legally, and therefore there must be a hacker's Activation Exploit installed.
Since there is no COA sticker, and the SLIC table is invalid, the machine is not Licensed to run Windows at all.
You will have to purxhase a new License for Windows,
If you still require both English and Spanish as installed languages (MUI), you will have to purchase Ultimate Edition - it's the only one htat supports multiple languages for other than basics.
This installation has been so hacked that there is no way that you can even be sure that you are the one actually in control of it - I recommend a fiull reformat and reinstall with legal media as soon as possible.


Sorry to be the bearer of such bad news - but hopefully, you'll get a better machine out of it at the end of the day!
My System SpecsSystem Spec
Reply

 #elementModuleHeaderText# message in Windows Update Module




Thread Tools



Similar help and support threads for2: #elementModuleHeaderText# message in Windows Update Module
Thread Forum
Solved windows 7 update error message Windows Updates & Activation
Windows Update = #elementmoduleheadertext# Windows Updates & Activation
Error message for windows update Windows Updates & Activation
Eliminate Action Center message about Windows Update? Windows Updates & Activation
Windows 7 Update-Missing Files Message Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:41 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App