Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Service Pack 1 Error: Trust_E_NOSIGNATURE(0x800b0100)

25 Feb 2012   #1
ruben353535

Windows 7 Ultimate 32bit
 
 
Service Pack 1 Error: Trust_E_NOSIGNATURE(0x800b0100)

i downloaded the service pack from the microsoft website and its still not working i tried fixing the registry with a registery fixer and nothing anyone else have any ideas?


My System SpecsSystem Spec
26 Feb 2012   #2
Joan Archer

Windows 7 Ultimate SP1 32 bit/Windows 8.1 64bit
 
 

Welcome to the forum.

It would be a good idea if you told the experts just what the name of this registry fixer is, it's never a good idea to use one Windows 7 is very capable of looking after the register itself.

It's possible the download was corrupted, please post back with as much information as possible about the problem like what happens after the download and why do you say it's not working, remember we can't see your machine so have no idea of what you have running or what it is you see.
My System SpecsSystem Spec
26 Feb 2012   #3
ruben353535

Windows 7 Ultimate 32bit
 
 

I downloaded the sp from the microsoft website and i openedit and it said it was initializing then it says it failed because of this error.
I used system care 5 and its not corrupted because it works fine on my other computer i installed it on. I also tried fix it from the microsoft website and another microsoft regestry fixer that i found on the website. I forgot the nameof that one though. And i tried doing the trouble shooting steps micrsoft recomended and it said it was fixed but the same thing happens. I keep trying to install the sp and it keeps giving me the same error and recomending me to the microsoft website.
My System SpecsSystem Spec
26 Feb 2012   #4
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Advanced System Care is a major source of problems for Win7 - it doesn't seem to have a clue.

I suspect that it has disabled one of your services - if not entirely uninstalled it.

Please open a command prompt, and type the following commands

SC QC CRYPTSVC
SC QUERYEX CRYPTSVC

copy the output to your reply.
My System SpecsSystem Spec
26 Feb 2012   #5
ruben353535

Windows 7 Ultimate 32bit
 
 

C:\Windows\system32>SC QC CRYPTSVC
[SC] QueryServiceConfig SUCCESS
SERVICE_NAME: CRYPTSVC
TYPE : 20 WIN32_SHARE_PROCESS
START_TYPE : 2 AUTO_START
ERROR_CONTROL : 1 NORMAL
BINARY_PATH_NAME : C:\Windows\system32\svchost.exe -k NetworkService
LOAD_ORDER_GROUP :
TAG : 0
DISPLAY_NAME : Cryptographic Services
DEPENDENCIES : RpcSs
SERVICE_START_NAME : NT Authority\NetworkService
C:\Windows\system32>SC QUERYEX CRYPTSVC
SERVICE_NAME: CRYPTSVC
TYPE : 20 WIN32_SHARE_PROCESS
STATE : 4 RUNNING
(STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0
PID : 1528
FLAGS :
My System SpecsSystem Spec
26 Feb 2012   #6
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Good - at least that service is still functional!
First run CHKDSK and SFC....
Click on the Start button
type in the Search box
CMD.EXE
right-click on the only file that is found
Select Run as Administrator
- the Elevated Command Prompt window should pop up
At the Command prompt, type
CHKDSK C: /R
and hit the Enter key
You will be told that the drive is locked, and the CHKDSK will run at he next boot - hit the Y key, and then reboot. The chkdsk will take a few hours depending on the size of the drive, so be patient!

After the CHKDSK has run, Windows should boot normally (possibly after a second auto-reboot) - then run the SFC

SFC -System File Checker - Instructions
Click on the Start button
type in the Search box
CMD.EXE
right-click on the only file that is found
Select Run as Administrator
- the Elevated Command Prompt window should pop up
At the Command prompt, type

SFC /SCANNOW

and hit the Enter key
Wait for the scan to finish - make a note of any error messages - and then reboot.

If the SFC scan reports that it couldn’t fix problems, please upload the CBS.log file
Then run the CheckSUR Tool - Description of the System Update Readiness Tool for Windows Vista, for Windows Server 2008, for Windows 7, and for Windows Server 2008 R2 - and post the CheckSUR.log file

(it may be a good idea to zip both files before posting - that can get quite large )
My System SpecsSystem Spec
26 Feb 2012   #7
ruben353535

Windows 7 Ultimate 32bit
 
 

i already did doth the disk check and the system file checker yesterday and both came up with no errors. the sur said it was installing a hot fix then i restarted my computer and the sp still isnt installin. i have no idea where the check sur file is.
My System SpecsSystem Spec
26 Feb 2012   #8
ruben353535

Windows 7 Ultimate 32bit
 
 

i found it


Attached Files
File Type: log CheckSUR.log (10.2 KB, 123 views)
My System SpecsSystem Spec
27 Feb 2012   #9
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

You have a number of problems there - mostly to do with .NET, I think...
Unfortunately, I don't have the experience I'd like with this type of problem - and our resident expert is unwell (Richard - get well soon, we need you!)
I would recommend that you request support from MS - it should be free for SP installation assistance.
https://support.microsoft.com/oas/de...direct=1&sd=gn
(with any luck that link will work - I'll try it myself in a tick )

[edit - seems to work for me, at least]
My System SpecsSystem Spec
27 Feb 2012   #10
ruben353535

Windows 7 Ultimate 32bit
 
 

I was trying to get helpwith this problem without microsoft support but il give it a try. Thanks for your help
My System SpecsSystem Spec
Reply

 Service Pack 1 Error: Trust_E_NOSIGNATURE(0x800b0100)




Thread Tools



Similar help and support threads for2: Service Pack 1 Error: Trust_E_NOSIGNATURE(0x800b0100)
Thread Forum
Service Pack 1 Error: Trust_E_NOSIGNATURE(0x800b0100) Windows Updates & Activation
Solved Service Pack 1 & IE9 Error Trust_E_NOSIGNATURE(0x800b0100) Windows Updates & Activation
Windows 7 - Service Pack 1 Error: Trust_E_NOSIGNATURE(0x800b0100) Windows Updates & Activation
Solved cannot install service pack 1. error trust_e_nosignature Windows Updates & Activation
Windows 7 - Service Pack 1 Error: Trust_E_NOSIGNATURE(0x800b0100) Windows Updates & Activation
Service Pack 1 error Trust_E_NOSIGNATURE Windows Updates & Activation
Service Pack 1 error Trust_E_NOSIGNATURE Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:24 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App