Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Updates keep failing including SP1

11 Mar 2012   #11
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

Is Vss (Volume Shadow Copy Service ) in services set to "automatic"?

Also see this Event ID 513


My System SpecsSystem Spec
.
12 Mar 2012   #12
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

I see tehre's a couple of problems also involving the Crypto Services.

Please run the following commands from an Elevated Command Prompt
SC QUERYEX CRYPTSVC
SC QC VSS

copy the results to your response - it may give us a clue.
My System SpecsSystem Spec
12 Mar 2012   #13
obidon

Windows 7 Professional x64
 
 

Ok I set the Volume Shadow Copy Service to Automatic, so maybe that will make a difference now.

Here are the command prompt results from querying the VSS and CryptSvc services:

Code:
SERVICE_NAME: cryptsvc
        TYPE               : 20  WIN32_SHARE_PROCESS
        STATE              : 4  RUNNING
                                (STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0
        PID                : 1484
        FLAGS              :



[SC] QueryServiceConfig SUCCESS

SERVICE_NAME: vss
        TYPE               : 10  WIN32_OWN_PROCESS
        START_TYPE         : 3   DEMAND_START
        ERROR_CONTROL      : 1   NORMAL
        BINARY_PATH_NAME   : C:\Windows\system32\vssvc.exe
        LOAD_ORDER_GROUP   :
        TAG                : 0
        DISPLAY_NAME       : Volume Shadow Copy
        DEPENDENCIES       : RPCSS
        SERVICE_START_NAME : LocalSystem
My System SpecsSystem Spec
.

12 Mar 2012   #14
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

According to the output, the VSS is set to Manual (which is normal) - did you change it after running the report?
My System SpecsSystem Spec
12 Mar 2012   #15
obidon

Windows 7 Professional x64
 
 

Yes I changed it after as I thought that automatic is what Jacee said I should change it to. What should I leave it as, set to Manual or Automatic? And also why?

I like learning as much as possible about my system.
My System SpecsSystem Spec
12 Mar 2012   #16
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

My preference would be to leave it as Manual - that's the default. I have heard that for some situations, Automatic is better, but I have a suspicion that this could cause minor problems at boot, as the service will try to open early in the boot process, and may encounter problems. I have no evidence, either way.
My System SpecsSystem Spec
12 Mar 2012   #17
obidon

Windows 7 Professional x64
 
 

Ok thanks for the advice. I guess I'll just leave it as the default for now.

Are there any other suggestions on how I can get SP1 installed?

I really just want to update to this service pack because I feel like my system is very unstable without out. I tried downloading an HDD diagnostic software just now but it said I needed .NET framework 4.0 in order to install it (which I thought I already had but I guess not.) So I went to download .NET 4.0 but THIS said I should get Service Pack 1 before installing .NET 4.0. Just another reason why I need SP1 so badly.

I must've tried installing SP1 from the updates over 100 times by now just to have it fail every time. Any other things you think I can try for now?

Thanks for all the help guys. Just really want to get this working.
My System SpecsSystem Spec
12 Mar 2012   #18
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

For testing your HD, go to the manufacturer's website, and download the HD test utility from there - burn it to CD, and then boot from it.
The errors showing in your VEW back up yor feeling that your system isn't stable - but I for one can't tell from the report what the actual problem is.
I don't see any results from teh SFC scan or the CheckSUR Tool - if you've run those, please upload the log files so that we can see what's in them.
My System SpecsSystem Spec
12 Mar 2012   #19
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

Let's see if flushing the DNS cache and restoring MS's Hosts file helps.

Copy and paste these lines in Note pad.

@Echo on
pushd\windows\system32\drivers\etc
attrib -h -s -r hosts
echo 127.0.0.1 localhost>HOSTS
attrib +r +h +s hosts
popd
ipconfig /release
ipconfig /renew
ipconfig /flushdns
netsh winsock reset all
netsh int ip reset all
shutdown -r -t 1
del %0


Save as flush.bat to your desktop.
Double click on the flush.bat file to run it.Vista and Windows 7... right click the .bat file and choose to run as Administrator. Your computer will reboot itself.
My System SpecsSystem Spec
13 Mar 2012   #20
total confusion

Windows 7 Pro
 
 

I had the same problems trying to get my system to automatically download the service pack. I ran through every trick thrown at me. I finally downloaded the stand alone version and it fixed all of the problems. Make sure you download the right service pack for your system.
Download: Windows 7 and Windows Server 2008 R2 Service Pack 1 (KB976932) - Microsoft Download Center - Download Details
Good luck
My System SpecsSystem Spec
Reply

 Windows 7 Updates keep failing including SP1




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 x64 Updates Keep Failing
I just finished a virus removal for a co-worker and am now getting errors trying to install the updates that are available. The main one which I would like to get is IE11. I keep getting the error codes: 0x8007371B and 9C57. I have tried every tool and fix-it solution from Microsoft that I could...
Windows Updates & Activation
No windows updates anywhere, including system32, sevices, etc.
so the problem im having is that windows update is no where to be found. its not in system32 as wuapp or in the services, its my aunt computer and she has windows 7 ultimate, some one else installed win7 for her and disabled/removed windows update and the search programs and files bar. so the...
Windows Updates & Activation
Windows Updates Are Failing to Install? ( Over 112 Updates)
I get a message everytime I try to updates Windows, there is over 112 updates which could not install, I have attached a picture of my error code (In the picture i have only tried one to see if it would work.) Thanks :huh:
Windows Updates & Activation
Can't download ~50 updates, including SP1 - Windows 7 Ultimate x64
Hello, I don't know how to fix the errors in my CheckSUR log, and it would be very much appreciated if someone could supply the files and instructions. Here is the error code that I got when trying to manually install SP1, if it's any help: trust_e_nosignature 0x800b0100
Windows Updates & Activation
Same 6 windows updates keep failing.
It's been doing the updates or whatever when the computer shuts down. Then when I go to boot up the computer it does the second part of the update, it gets to 15% then says failure to configure windows updates reverting changes, reboots and then I can log in to the computer. Every time I shuts down...
Windows Updates & Activation
Windows Updates failing
I have 5 windows updates that fail every time I try to install them. They are: KB977863, KB972270, KB978251, KB976264, KB979306. It says error code: 800B0100. I've run the system update readiness tool but it still doesn't work. Any suggestions? Thanks
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:42.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App