Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BITS Error 2: The System cannot find the file specified

04 Oct 2013   #41
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by Jochen View Post
Why post screenshots? Did you import bits.reg? What problems do you have?


My System SpecsSystem Spec
.
04 Oct 2013   #42
Jochen

 
 

Quote   Quote: Originally Posted by Kaktussoft View Post
Quote   Quote: Originally Posted by Jochen View Post
This is including the ones I imported from you;
I asked you to post subkeys as well!
I thought that is what you meant by that.
My System SpecsSystem Spec
04 Oct 2013   #43
MrSleeps

Windows 7 64bit
 
 

Thanks Kaktussoft.. Your reg file fixed my problem

Mucho appreciated !
My System SpecsSystem Spec
.

10 Oct 2013   #44
abidcastaneda

Windows 7
 
 
Thank you so, so, so much

Quote   Quote: Originally Posted by Kaktussoft View Post
Quote   Quote: Originally Posted by 3DPiper View Post
Have you had malware problems recently?

I check for malware frequently, using both Malwarebytes and superantispyware.. I haven't specifically noticed any problem until now.

How long-standing is your problem?

I'm not really sure, I just recently realized I wasn't updating and that led me to find out this problem..
I think the last successful update was a month ago

What other symptoms apart from not being able to update are you seeing?

Again, I am only noticing things now that I am looking for them.. One problem is I can't open a cmd prompt
as administrator (everything in the compatibility tab is greyed out)..

In elevated command prompt

Code:
cd /d "C:\Users\All Users\Application Data\microsoft\Network"attrib *.*
post output

I cannot start an elevated command prompt, my whole compatibility tab is greyed out..


go through the list of services and make sure all of the following are set to Automatic or Manual:
Remote Procedure Call (RPC), System Event Notification, Windows Management Instrumentation Driver Extensions, COM+ Event System, DCOM Server Process Launcher

Try to start these services (of not started yet). All start fine?

RPC is started and is currently set to Automatic
System Even Notification is currently started and set to Automatic
Windows Management Instrumentation is currrently started and set to Automatic
COM+ Event System is currently started and set to Automatic
DCOM Server Process Launcher is currently started and set to Automatic


Start REGEDIT and browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BITS\Parameters
What do you see on the right side of screen?

My BITS registry doesn't look like yours (see pic)..
Import mine... see attachment
Thank you very much, using your registry solved my problem for the BITS service, trying out windows update to see if its fully resolved now, again, thank you.
My System SpecsSystem Spec
15 Oct 2013   #45
Lazorenz

At First it was Windows Vista Premium 64 or 32 -bit I guess but now it Windows 7 Professional 32-bit
 
 

Quote   Quote: Originally Posted by kaktussoft View Post
Quote   Quote: Originally Posted by 3dpiper View Post
have you had malware problems recently?

i check for malware frequently, using both malwarebytes and superantispyware.. I haven't specifically noticed any problem until now.

how long-standing is your problem?

i'm not really sure, i just recently realized i wasn't updating and that led me to find out this problem..
I think the last successful update was a month ago

what other symptoms apart from not being able to update are you seeing?

again, i am only noticing things now that i am looking for them.. One problem is i can't open a cmd prompt
as administrator (everything in the compatibility tab is greyed out)..

in elevated command prompt

code:
Cd /d "c:\users\all users\application data\microsoft\network"attrib *.*
post output

i cannot start an elevated command prompt, my whole compatibility tab is greyed out..


go through the list of services and make sure all of the following are set to automatic or manual:
remote procedure call (rpc), system event notification, windows management instrumentation driver extensions, com+ event system, dcom server process launcher

try to start these services (of not started yet). All start fine?

rpc is started and is currently set to automatic
system even notification is currently started and set to automatic
windows management instrumentation is currrently started and set to automatic
com+ event system is currently started and set to automatic
dcom server process launcher is currently started and set to automatic


start regedit and browse to hkey_local_machine\system\currentcontrolset\services\bits\parameters
what do you see on the right side of screen?

my bits registry doesn't look like yours (see pic)..
import mine... See attachment


thank you so much sir it really worked on me :d :d
My System SpecsSystem Spec
27 Oct 2013   #46
DaiB

Windows 7 Pro
 
 
The Registry fix worked!

The fix worked; thanks so much. I wonder what caused the deletion of the Regsistry BITS Paramters? Did any of the Microsoft Fixits delete things they shouldn't have as I was dealing with a brand new XP install from a legit MS disc. There is something badly broken currently with the MS Windows XP update site for new OS installs. I thought support was ending in April 2014 not Autumn/Fall 2013.
My System SpecsSystem Spec
28 Oct 2013   #47
EnzymeNL

Windows 7 Ultimate x64
 
 

Thanks alot for this post, had the same problem and this solved it
My System SpecsSystem Spec
21 Nov 2013   #48
dbkate

Vista Home Prem.32bit and Windows 7 Pro 64bit
 
 

I have to say a HUGE thank you for all of the posts in this thread! By using the suggestions here and modifying them for Windows Vista Home Prem 32 bit, i was able to restore this machine after the dreaded Cryptolocker virus! without having to restore the pc to factory condition and re-install all updates, software and services! THANK YOU!!!
My System SpecsSystem Spec
04 Dec 2013   #49
Boltbreaker

Windows 7 Ultimate 64 bit
 
 
Worked!

Quote   Quote: Originally Posted by Kaktussoft View Post
Quote   Quote: Originally Posted by 3DPiper View Post
Have you had malware problems recently?

I check for malware frequently, using both Malwarebytes and superantispyware.. I haven't specifically noticed any problem until now.

How long-standing is your problem?

I'm not really sure, I just recently realized I wasn't updating and that led me to find out this problem..
I think the last successful update was a month ago

What other symptoms apart from not being able to update are you seeing?

Again, I am only noticing things now that I am looking for them.. One problem is I can't open a cmd prompt
as administrator (everything in the compatibility tab is greyed out)..

In elevated command prompt

Code:
cd /d "C:\Users\All Users\Application Data\microsoft\Network"attrib *.*
post output

I cannot start an elevated command prompt, my whole compatibility tab is greyed out..


go through the list of services and make sure all of the following are set to Automatic or Manual:
Remote Procedure Call (RPC), System Event Notification, Windows Management Instrumentation Driver Extensions, COM+ Event System, DCOM Server Process Launcher

Try to start these services (of not started yet). All start fine?

RPC is started and is currently set to Automatic
System Even Notification is currently started and set to Automatic
Windows Management Instrumentation is currrently started and set to Automatic
COM+ Event System is currently started and set to Automatic
DCOM Server Process Launcher is currently started and set to Automatic


Start REGEDIT and browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BITS\Parameters
What do you see on the right side of screen?

My BITS registry doesn't look like yours (see pic)..
Import mine... see attachment

First time posting, hope this is right format. Wanted to say the above fixed my problem, hat's off to you sir!
My System SpecsSystem Spec
15 Jan 2014   #50
oziisan

windows 7 32 and 64 bit
 
 
I have the same problem here

Quote   Quote: Originally Posted by Kaktussoft View Post
In elevated command prompt
Code:
 
cd /d   "C:\Users\All Users\Application Data\microsoft\Network"
attrib  *.*
post output

go through the list of services and make sure all of the following are set to Automatic or Manual:
Remote Procedure Call (RPC), System Event Notification, Windows Management Instrumentation Driver Extensions, COM+ Event System, DCOM Server Process Launcher

Try to start these services (of not started yet). All start fine?

Start REGEDIT and browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BITS\Parameters
What do you see on the right side of screen?

I have the same problem here. BY REGDEDIT, I have come top this: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BITS\Parameter. And on the right side i see these: 1: Default REG_SZ (value not set)
2: ServiceDll RED_EXPAND_SZ %SystemRoot%\System32\qmgr.dll

How do I fix my BITS from here? Please help.
My System SpecsSystem Spec
Reply

 BITS Error 2: The System cannot find the file specified




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Cannot Open File...The system cannot find the path specified
Hello, could somebody please help me? So background story here: I have a SSD for boot and applications, and a HDD for storage. I recently changed my "Location" for Pictures, Movies, Documents, and also Downloads. I changed the "Locations" to my 1TB HDD. I did not make a junction, I just created...
General Discussion
Error from Service Control Manager - system cannot find the file
Hello! Not sure this is the correct forum, new here. I constantly (roughly every 10ms) receive an error in Event Viewer Screenshot: http://i.imgur.com/rF8Voi1.png "The WinPcap Packet Driver (NPF) service failed to start due to the following error: The system cannot find the file specified."...
Software
16-bits program error message in 64-bits W7...
This is a rather unsual error message from Windows 7, that cannot even run 16-bits programs, quote: "Too many other files are currently in use by 16-bit programs. Exit one or more 16-bit programs, or increase the value of files in your Config.sys file." The only time that this issue shows...
Performance & Maintenance
the system cannot find the file specified
Hi.....an error "the system cannot find the file specified" occured when i was trying to run a setup.exe to setup the microsoft expression4,a microsoft package .......what can i do to solve this problem?...i 've searched some forums but i haven't resolved it yet.......thankyou
Software
Which File? (The system cannot find the file specified)
I have a Windows 7 driver installation question that has been nagging me for awhile. I now turn to the forums for help. If I try to install a driver and not all of the driver files are present, I will get the error message "The system cannot find the file specified." But the problem is that it...
Drivers
Cannot find system image file
I have copied my system image files to my external HDD and now need to restore. However, Win 7 cannot see these files since I moved them onto my external HDD and then copied them back into the folder: windowsimagebackup. Note: I had a problem with my data drive where the windows images were...
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App