Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Update error : 643

04 Sep 2012   #1

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Update error : 643

Security Update for Microsoft XML Core Services 4.0 Service Pack 2 for x64-based Systems (KB954430)

Installation date: ‎9/‎4/‎2012 7:51 PM

Installation status: Failed

Error details: Code 643

Update type: Important

A security issue has been identified in Microsoft XML Core Services (MSXML) that could allow an attacker to compromise your Windows-based system and gain control over it. You can help protect your computer by installing this update from Microsoft. After you install this item, you may have to restart your computer. Once you have installed this item, it cannot be removed.

**Already reset Windows update history, and tried Microsoft fix it. I am running SFC/Scannow currently. Will admit, lots of tweaks and various incorrect setups and the such on here. Have been running with this for a very long time, so i don't think this is the problem.**


Edit: SFC is no help:/ Also just to mention one windows update is not that important to me, just rather annoys me.

My System SpecsSystem Spec
.

18 Sep 2012   #2

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Ok figured out my fix, after clean installing and multiple other attempts to fix it, i found the problem still existed. Downloaded one of my games again, to be exact "Lord of the Rings Online". Said i needed framework v.1.14 so i went and got 4.5 the latest and it still insisted v1.1.14 so i got it which gave me error codes. I fixed this error code by re adding my "public" registry key. Next the framework 1.1.14 worked. I had given up on the problem update, and then after installing ms office prof 2010 i checked for updates naturally, because i knew there would be some. The update this time installed. So i believe these could be possible fixes.
1. If you have deleted your public folders, Google the fix to bring them back by using regedit.
2. Install the latest framework 4.5 (i think this was the real fix)
3. These did not work for me, but try Microsoft fix it, resetting update history and components as well as using the system readiness tool.
My System SpecsSystem Spec
19 Sep 2012   #3

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

I wasn't aware that .NET 4.5 was out of Beta yet! - it certainly has nothing to do with your WU installation problem unless it happened to fix a broken registry entry, which would likely be more by luck than judgement
My System SpecsSystem Spec
.


19 Sep 2012   #4

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by NoelDP View Post
I wasn't aware that .NET 4.5 was out of Beta yet! - it certainly has nothing to do with your WU installation problem unless it happened to fix a broken registry entry, which would likely be more by luck than judgement
Oh, what do you think the fix to it was? i was really frustrated after i cleaned install and it still didn't work. I did delete the public folder in which i re added using reg edit, then installed framework v.1.14 and then after that i decided to just go ahead and get 4.5
My System SpecsSystem Spec
19 Sep 2012   #5

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

The 643 error is a swine - I had a long corresepondence with MS on my problems with it in XP, and ended up just hiding the updates concerned

I have no honest idea - but it certainly wasn't (except by coincidence ) installing 4.5
My System SpecsSystem Spec
19 Sep 2012   #6

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by NoelDP View Post
The 643 error is a swine - I had a long corresepondence with MS on my problems with it in XP, and ended up just hiding the updates concerned

I have no honest idea - but it certainly wasn't (except by coincidence ) installing 4.5
Aha got it, thanks. Just glad its gone, not a big deal just annoying.
My System SpecsSystem Spec
Reply

 Update error : 643




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:43 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33