Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Error: TRUST_E_NOSIGNATURE(0x800b0100)

27 Oct 2012   #1

Windows 7 Home Premium 64bit.
 
 
Error: TRUST_E_NOSIGNATURE(0x800b0100)

I have the error when i try to install service pack 1, I already tried with System Update Readiness Tools and doesn't work. I unchecked antivirus and firewall too.
I have attached the checksur.log



Attached Files
File Type: log CheckSUR.log (3.1 KB, 32 views)
My System SpecsSystem Spec
.

29 Oct 2012   #2

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Hello spsaarathi and welcome to the forums

What language are you using for IE9? I've got all of your replacement files apart from two which depend on your language pack

Tom
My System SpecsSystem Spec
30 Oct 2012   #3

Windows 7 Home Premium 64bit.
 
 
Ie - enu

Hello Tom,
Thanks for responding to my post. I do not use any language pack for my IE. It is a standard version ENU.

Thanks in advance

Spsaarathi
My System SpecsSystem Spec
.


30 Oct 2012   #4

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Hi Spsaarathi,

Thanks for letting me know

Windows Update Package Replacement

Warning: this fix is specific to the user in this thread. No one else should follow these instructions as it may cause more harm than good. If you are after assistance, please start a thread of your own.

  1. Please download the attached file, Packs.zip and save this to your Desktop.
  2. Right-click on the file and select Extract All...
  3. Tick the box labelled Show extracted files when complete then click Extract
  4. A window will open showing two folders, Manifests and Packages
  5. Open the Manifests folder and copy the files into the following folder (if there are any files)

    C:\Windows\Temp\CheckSur\Winsxs\Manifests

  6. Open the Packages folder and copy the files into the following folder (if there are any files)

    C:\Windows\Temp\CheckSur\Servicing\Packages

  7. Run the System Update Readiness Tool (SURT) again
  8. When the SURT finishes installing, copy (Ctrl + C) and paste (Ctrl + V) the contents of the SURT log into your next post please:

    C:\Windows\Logs\CBS\CheckSUR.persist.log


You will probably be shown the error code 0x8024200D after performing this fix, if so, please download and install the update from this link. It must be downloaded using Internet Explorer.

Download Internet Explorer 9 - Microsoft Windows

Tom


Attached Files
File Type: zip Packs.zip (416.0 KB, 96 views)
My System SpecsSystem Spec
31 Oct 2012   #5

Windows 7 Home Premium 64bit.
 
 

Hi Tom, Thanks for your help.
I was not shown error code 0x8024200D after performing this fix. Please find the requested file attached. My IE9 instalation also failed.

Best regards
Spsaarathi


Attached Files
File Type: log CheckSUR.persist.log (86.9 KB, 9 views)
My System SpecsSystem Spec
31 Oct 2012   #6

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Hi Spsaarathi,

It looks like the SURT has performed the replacements without any issues, so there's no problems at that end. What error code were you shown when IE9 failed to install?

Tom
My System SpecsSystem Spec
06 Nov 2012   #7

Windows 7 Home Premium 64bit.
 
 
IE9 failed

Hi Tom,
Sorry for late reply. Thanks for your response.

Windows 7 sp1 installed successfully but IE9 failed to install. Currently IE8 is installed in my PC.

Thanks in Advance

Best regards
Partha
My System SpecsSystem Spec
06 Nov 2012   #8

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Hi Partha,

I'm glad to hear that, I was half expecting IE9 to fail after that fix. Fortunately, this fix is a lot easier, just download and install it from the web:

Download Internet Explorer 9 - Microsoft Windows

Tom
My System SpecsSystem Spec
30 Apr 2013   #9

Ontario
 
 

Hi Tom! Could you please help me out as well? Attached is my checksur.log file.

Thanks a lot.

Primeweb


Attached Files
File Type: log CheckSUR.log (4.0 KB, 2 views)
My System SpecsSystem Spec
30 Apr 2013   #10

Ontario
 
 
OS

Forgot to mention it is a Windows 7 Home 64 bit
My System SpecsSystem Spec
Reply

 Error: TRUST_E_NOSIGNATURE(0x800b0100)




Thread Tools



Similar help and support threads for2: Error: TRUST_E_NOSIGNATURE(0x800b0100)
Thread Forum
Solved Error: TRUST_E_NOSIGNATURE(0x800b0100) Windows Updates & Activation
Solved Service Pack 1 & IE9 Error Trust_E_NOSIGNATURE(0x800b0100) Windows Updates & Activation
Windows 7 - SP 1 Install Error: Trust_E_NOSIGNATURE(0x800b0100) Windows Updates & Activation
Win 7 x64bit - SP1 Error: TRUST_E_NOSIGNATURE(0x800b0100) Windows Updates & Activation
Error trust_e_nosignature 0x800b0100 when installing W7 SP1 Windows Updates & Activation
Service Pack 1 Error: Trust_E_NOSIGNATURE(0x800b0100) Windows Updates & Activation
TRUST_E_NOSIGNATURE(0x800b0100) error installing SP1 for Win 7 Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:44 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33