Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Not updating after system image restore or re-install


01 Nov 2012   #1

Windows 7
 
 
Not updating after system image restore or re-install

When I use either of my two system images (one which I have already used successfully for my existing install) and from two different HDD's, I now cannot update and get "unknown error code 8024402F" which googling seems to suggest may clear itself at some point. The MS Updates repair did not fix it.

Decided, after googling, to just re-install which I have done many times without problem. This time the second set of 124 updates had three fails (KB2544521, KB2703157 & KB2598845) even though I update on shutdown and have never had fails before.
Then , after one more successful update, I started getting the Unknown error update failure I had after the system image restores.

My questions are:
  1. Are the original Windows 7 install disks problematic due to the large number of updates and would the use of a SP1 install disk be better? (Have done 96 updates previously (on shutdown) without a single fail)
  2. Has anyone had this update error (after an image restore) and it sort itself out eventually?
  3. Anyone know of any tips or tricks to minimize/avoid update problems after install with non-SP1 install disk?
  4. Or, know of any tips or tricks to avoid the update error problem after restoring a system image?
Win 7 has been problem free for me, since 2009. My router is unchanged and since an image restore (I gave up on the re-install after updates stopped working) has updated to the latest version of MSE (4.1.522.0, KB2754296) and latest antivirus definitions automatically.


I cannot understand this current problem as, apart from the usual firefox updates etc., I have not changed anything for months.



Many thanks for any replies. Got to take someone to distant Hospital soon so I apologize if I am late responding to any comments myself.

My System SpecsSystem Spec
.

02 Nov 2012   #2

Windows 7
 
 

Solved by uninstalling .NET Framework 4 Client Profile. Updates then work.

Tried to repair the above first, but only uninstalling works.

It gets re-installed by updates (seeming after the Malicious Software Removal Tool has run!?) and Updates stops working again.

Not sure what's going on but at least I can get the latest updates. It's just crazy that I have to keep uninstalling the .NET Framework each time to update.
My System SpecsSystem Spec
02 Nov 2012   #3

Windows 7
 
 

Decided to install .NET Framework 4.5 which permanently replaces .NET Framework 4 Client Profile when it is installed.

Now MS Updates work fine.
My System SpecsSystem Spec
.


Reply

 Not updating after system image restore or re-install




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:36 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33