Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: [solved] Problem to install SP1 - bcdedit problem

04 Jan 2013   #1

Windows 7 Pro x64
 
 
[solved] Problem to install SP1 - bcdedit problem

Dear all,

My problem is solved, but it took me so long to get it solved that I decided to post my experience in case it could help someone else.
Sorry if I'm not very precise in the manipulation I did, I don't remember everything precisely.

My 1st problem: SP1 failed to install when running the Windows Update manager. When failling, it was suggesting a help page from Microsoft but all the propositions on that page also failled.

My 2nd problem: Apparently, the problem was linked to another one on my computer: at the startup, during the boot process, a black screen was offering 2 identical "Windows 7" options (waiting 30s when not pressing enter) while only one Windows 7 was actually installed. I don't know why this screen was shown (when I installed Windows, a Linux distrib was installed on another disk with the boot flag, this is my best guess).

Anyway the two problems seemed linked because one of the proposition to solve the SP1 installation problem was to type the command "bcdedit" (elevated) which was failling, and which is precisely intended to manage the black boot screen also annoying me.

Solution of the 1st problem: after Googling, I tryed several methods, the one that worked was to press F8 during the boot sequence to enter the System Recovery Option menu. When entering this mode, it told me that something was wrong, asked me if I wanted it to repair automatically and reboot, I agreed and on the next start up, I could install SP1 in the regular way.

But, this didn't solved the 2nd problem, nor rebuilding the BCD from stratch via command prompt in the System Recovery, nor editing the BCD base using the bcdedit command line...

Solution of the 2nd problem: I used a shareware named EasyBCD (free version was enough), in the "BCD Backup/Repair" tab, I reseted the BCD configuration, then added a new Entry in the "Add new entry" menu for Windows 7 only.

I guess it could be done with the bcdedit command line, but I didn't succeded. The entry {bootmgr} was wrong, but I didn't know what the proper configuration it should have...
Of course, I had to reinstall Grub2 in order to boot my Linux distrib.

My System SpecsSystem Spec
.

04 Jan 2013   #2

Windows 7 Pro x64
 
 

It turned out that the problem was indeed because of the installation of Linux (and because I had a partition on another disk marked as active during the installation).
See this thread for completeness.
My System SpecsSystem Spec
Reply

 [solved] Problem to install SP1 - bcdedit problem




Thread Tools



Similar help and support threads for2: [solved] Problem to install SP1 - bcdedit problem
Thread Forum
Solved At least one IE9RC problem solved Browsers & Mail
Solved Windows SP 1 problem solved Windows Updates & Activation
bcdedit problem Installation & Setup
Boot Hang Solved; separately Sleep Problem Solved Performance & Maintenance
Audio Problem solved Sound & Audio
Solved my problem Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:30 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33