Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows update not running - windows 7 home premium 64 bit

10 Jan 2013   #11
DEVFISCAL

Windows 7 32 bit
 
 

C:\windows\system32>NET START TRUSTEDINSTALLER
The Windows Modules Installer service is starting.
The Windows Modules Installer service was started successfully.

C:\windows\system32>SC QUERYEX TRUSTEDINSTALLER
SERVICE_NAME: TRUSTEDINSTALLER
TYPE : 10 WIN32_OWN_PROCESS
STATE : 4 RUNNING
(STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0
PID : 2396
FLAGS :
C:\windows\system32>SC QUERYEX EVENTLOG
SERVICE_NAME: EVENTLOG
TYPE : 20 WIN32_SHARE_PROCESS
STATE : 4 RUNNING
(STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0
PID : 772
FLAGS :
C:\windows\system32>SC QUERYEX EVENTSYSTEM
SERVICE_NAME: EVENTSYSTEM
TYPE : 20 WIN32_SHARE_PROCESS
STATE : 1 STOPPED
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0
PID : 0
FLAGS :
C:\windows\system32>
C:\windows\system32>


My System SpecsSystem Spec
.
10 Jan 2013   #12
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

@DEVFISCAL -
Plese start your OWN NEW thread - and give details of your own problem there.
My System SpecsSystem Spec
11 Jan 2013   #13
Aidan364

Windows 7 Home Premium 64bit
 
 

I just tried to run the CheckSUR tool now and and I was prompted with an error 0xc80000222
My System SpecsSystem Spec
.

11 Jan 2013   #14
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Please open an Elevated Command Prompt and run the following commands

SC QUERYEX MSISERVER
SC QC MSISERVER
NET START MSISERVER
REG QUERY HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\msiserver /S

post the results...

Here are some instructions to make life easier
1) To open an Elevated Command Prompt Window (the ECP window), click on Start, All Programs, Accessories – then right-click on Command Prompt, and select Run as Administrator. Accept the UAC prompt.
2) To run the commands easier, highlight the block of commands, and right-click on the highlight – select Copy. In the CP Window, click on the black/white icon at top left – select Paste. The commands will run but may not complete the last command, so hit the Enter Key once.
3) To copy the results... click on the Black/White icon in the top left, and select Edit... 'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to paste it into your response.
My System SpecsSystem Spec
11 Jan 2013   #15
Aidan364

Windows 7 Home Premium 64bit
 
 

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>
C:\Windows\system32>SC QUERYEX MSISERVER

SERVICE_NAME: MSISERVER
TYPE : 10 WIN32_OWN_PROCESS
STATE : 1 STOPPED
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0
PID : 0
FLAGS :

C:\Windows\system32>SC QC MSISERVERVER
[SC] OpenService FAILED 1060:

The specified service does not exist as an installed service.


C:\Windows\system32>NET START MSIERVER
The service name is invalid.

More help is available by typing NET HELPMSG 2185.


C:\Windows\system32>REG QUERY HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic
es\msiserver /S

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\msiserver
DisplayName REG_SZ @%SystemRoot%\system32\msimsg.dll,-27
ImagePath REG_EXPAND_SZ %systemroot%\system32\msiexec.exe /V
Description REG_SZ @%SystemRoot%\system32\msimsg.dll,-32
ObjectName REG_SZ LocalSystem
ErrorControl REG_DWORD 0x1
Start REG_DWORD 0x3
Type REG_DWORD 0x10
DependOnService REG_MULTI_SZ rpcss
ServiceSidType REG_DWORD 0x1
RequiredPrivileges REG_MULTI_SZ SeTcbPrivilege\0SeCreatePagefilePrivil
ege\0SeLockMemoryPrivilege\0SeIncreaseBasePriorityPrivilege\0SeCreatePermanentPr
ivilege\0SeAuditPrivilege\0SeSecurityPrivilege\0SeChangeNotifyPrivilege\0SeProfi
leSingleProcessPrivilege\0SeImpersonatePrivilege\0SeCreateGlobalPrivilege\0SeAss
ignPrimaryTokenPrivilege\0SeRestorePrivilege\0SeIncreaseQuotaPrivilege\0SeShutdo
wnPrivilege\0SeTakeOwnershipPrivilege\0SeLoadDriverPrivilege
FailureActions REG_BINARY 84030000000000000000000003000000140000000100
0000C0D4010001000000E09304000000000000000000


C:\Windows\system32>
My System SpecsSystem Spec
11 Jan 2013   #16
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

The errors are mostly my fault At least I got the last one right!

The settings look right - we'd best run the two failed commands properly...

SC QUERYEX MSISERVER
NET START MSISERVER

post the results - sorry about that!
My System SpecsSystem Spec
11 Jan 2013   #17
Aidan364

Windows 7 Home Premium 64bit
 
 

No problem, cheers again for the help

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>SC QUERYEX MSISERVER

SERVICE_NAME: MSISERVER
TYPE : 10 WIN32_OWN_PROCESS
STATE : 1 STOPPED
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0
PID : 0
FLAGS :

C:\Windows\system32>NET START MSISERVER
The Windows Installer service is starting.
The Windows Installer service was started successfully.


C:\Windows\system32>
C:\Windows\system32>
My System SpecsSystem Spec
11 Jan 2013   #18
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Hmmm - that's odd - the 80000022 error indicates the msiserver service couldn't be accessed.
This could be due to corruption in the SoftwareDistribution folder - the problem with that the conventional cure can lead to problems later on, if not handled properly, and you will lose your Update history (but the updates will still be installed, and viewable in the Installed Updates listing).

Open an Elevated Command Prompt
Run the following commands

NET STOP WUAUSERV
REN C:\WINDOWS\SoftwareDistribution SDOLD
NET START WUAUSERV

wait 15 minutes, and reboot
then wait 10 minutes, and open Windows Updates, and run a Check for Updates.

Install only the oldest update found - and reboot once installed
then go back to Windows updates and install the others.
My System SpecsSystem Spec
11 Jan 2013   #19
Aidan364

Windows 7 Home Premium 64bit
 
 

Thanks a lot for the help, It works perfectly now. Much apprichiated

Aidan
My System SpecsSystem Spec
11 Jan 2013   #20
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Glad to hear it!

Good luck.
My System SpecsSystem Spec
Reply

 Windows update not running - windows 7 home premium 64 bit




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 Home Premium Suddenly Running Very Slowly
I have had this new laptop for about a month. It's a gaming laptop and I've had no problems until today. Startup which usually takes about 20 seconds from power on to all startup programs functional, now takes 3 minutes with desktop items taking a long time to display. Upon completion of...
Performance & Maintenance
Windows 7 64bit Home Premium starts tasks I do not want running
Every time I start Windows 7, a bunch of tasks I don't want start themselves. Some are in the tray, some are running in the TASK MANAGER. I then go to CCleaner that has a STARTUP tool that allows me to DISABLE or DELETE but I delete which I do to all except my Anti-virus and Firewall. When I...
General Discussion
Intel RST Service not running in Windows 7 Home Premium 64 Bit
I have refreshed my Hard disk in Acer Aspire Laptop and restored the windows using the recovery disk. After the restore, Inter RST displays a yellow triangle and says the "RST services is not Running". When I try opening the RST, I get a message 'IAStorUI has stopped working'. Also the performance...
Drivers
Windows update not running - windows 7 home premium 64 bit
i had just changed a hard rive from a 500gb seagate to a 1tb hgst and when i try to do windows update and when i click on it i am prompted with a message that says windows update cannot currently check for up dates because the service is not running you may need to restart your computer which i...
Windows Updates & Activation
Running windows 7 but thinking of using xp home premium, look inside.
running windows 7 but as stated in another thread having problems with the product key and getting fed up with the windows popping up about activating my windows 7. anyway ive got a old pc with windows xp home premium on which im thinking of taking apart to use the case for my xbox 360 and keep...
Installation & Setup
chkdsk quit running in Windows 7 Home Premium 64 bit
I am running a Windows 7 Home Premium 64 bit computer. I used to be able to run chkdsk with no problem. For some reason when I now run chkdsk, I get the countdown from 9 to 0 and the system then boots Windows 7 Home Premium. It will not run chkdsk. Any help will be appreciated.
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:20.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App