Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: .net framework any version will give error 667 on install

18 Feb 2013   #1

Windows 7 Home Premium x64
.net framework any version will give error 667 on install

Ive been having issues with this ever since Avast deleted files inadvertantly on a boot-time scan. Now no installation of .net framework any version will install: error code 667

Really dont want to do a clean OS install if possible.

My System SpecsSystem Spec
19 Feb 2013   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Please follow the Windows Update Posting Instructions and post the requested data
My System SpecsSystem Spec

 .net framework any version will give error 667 on install

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
dot net framework 3.5 setup error on windows 7? how to install?
dear sevenforums community, i am using win 7 home premium 64 bit. yesterday, i bought a new 3.5 external hard drive, inside it there is a dot net framework 3.5 installation package. Not knowing that win 7 SP 1 comes from net framework 3.5 installed already, i double clicked the exe file from...
.NET Framework 4.0 Will not Install on Win 7 64(error code 643)
Hi, everyone. I'm new here but really hoping that someone can help me because I'm at my wit's end with this. My problem is that I cannot get the .NET framework 4 to install for anything. On Friday night I began installing Sharepoint Server 2010. Below are the following related products I had...
Windows Updates & Activation
"Microsoft .NET Framework Version 2.0 is required to continue." Error
Hi, I hope I'm not asking this for the millionth time here, as I tried a search but am afraid it all just confused me more. I believe my problem is related to the Dell all-in-one printer I want to work with my Dell laptop. Recently, Windows updated and I now get this message again upon start up:...
General Discussion
Win7 Ships what version .Net Framework ?
One of the new software i wana install requires .Net Framework 4.0 and hence i was wondering what version of .Net Framework does win7 ultimate ships with? Also, how can i check which version i am having by default ?
Installation & Setup
.NET Framework 1.1 Install error
Hi all I tried out the RC beta of win7 Ult x64, and the appz i use daily worked on it. So I got myself a real copy of win7 sense I dont need all in Ult I thought save some and get Pro x64. But This gave me a lot of problems with .NET framework 1.1 which I must use for the app "Magic File...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:35.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App