Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: I have a viable reason to remove Windows 7 SP1 (not an error code)...

13 Mar 2013   #1
soulcoma

Windows Seven
 
 
I have a viable reason to remove Windows 7 SP1 (not an error code)...

Here is my issue. I installed Windows 7 SP1 when it came out. Not the Beta or RC, but the final KB976932.
It installed fine. Under Control Panel > System it showed Windows 7 SP1.
A week later (thereabout) I had an issue or BSOD, I can't remember what it was; it was many months ago.
I didn't have any Restore Points so I did a LKGC reboot.
Everything came back fine, but it showed I had Windows 7 and not SP1 under System.
But, in the Programs and Features SP1 is still listed as installed and Windows Update says it is installed.
I have had no issues with this until today.
During a monthly update, IE 10 was listed as an update today.
It failed saying it requires Windows 7 SP1 (which I have but my PC thinks I don't, I guess?).
I tried to uninstall it with the Uninstaller and through CMD. That hung and failed.
I then realized I had deleted the backup files by running Disk Cleaner (actually another program, but the result is the same.)

It says in a post I found that I would need to completely reinstall Windows 7 and I use Chrome so I don't really care that much about IE 10, so that's not gonna happen. I lost my 7 disk anyway.

My question is...is there any way to remove SP1 without the backup files? Can I reinstall a manual download of the file on top of the original? (I did that but it still says I only have Windows 7, yet KB976932 is still listed as installed and Windows is Up To Date). Can I trick the system into 'knowing' that SP1 is really installed?

Sorry if this post is a bit confusing, I'm not a novice, but certainly not an expert. Reinstalling 7 from scratch is not an option for me and not worth the effort. I'll deal with this if I have to. Just thought an expert might know a workaround. Thanks for your time.


My System SpecsSystem Spec
.
13 Mar 2013   #2
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

My System SpecsSystem Spec
13 Mar 2013   #3
soulcoma

Windows Seven
 
 

Thank you. I've run an SFC scan (no issues), I have no error codes in Windows Update and my logs read no errors. I saw the readiness tool earlier today but didn't know if it applied to my situation. I will install that and see what happens. I apologize if I posted incorrectly in this forum.
My System SpecsSystem Spec
.

13 Mar 2013   #4
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

No problem - please post the CBS.log files anyhow (together with the CheckSUR log) as there is a lot of data outside just the bare SFC output in them.
My System SpecsSystem Spec
13 Mar 2013   #5
soulcoma

Windows Seven
 
 

Thanks. Uploaded. 221 MB Text File? Wow. I tried reinstalling manually again and it did the whole configure setup on reboot but it still shows Windows 7 in System and not SP1, yet the KB is showing installed still. I reinstalled to a LKGC that was right before the day I installed SP1 and it tricked the PC into thinking it is not installed. I assume. File is attached.
My System SpecsSystem Spec
13 Mar 2013   #6
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Yeah - these files get to be a lot of fun
back after I've had a chance to thread a way through it.
My System SpecsSystem Spec
13 Mar 2013   #7
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Some of the more critical errors....

Code:
2013-03-13 12:19:27, Info                  CBS    User canceled the install. [HRESULT = 0x800f0820 - CBS_E_CANCEL]
2013-03-13 12:19:27, Info                  CBS    Progress handler returned failure while executing updates, aborting. [HRESULT = 0x800f0820 - CBS_E_CANCEL]
2013-03-13 12:19:27, Info                  CBS    Failed to advance progress. [HRESULT = 0x800f0820 - CBS_E_CANCEL]
2013-03-13 12:19:27, Info                  CBS    Failed to prepare execution. [HRESULT = 0x800f0820 - CBS_E_CANCEL]
2013-03-13 12:19:27, Info                  CBS    Failed to process component watch list. [HRESULT = 0x800f0820 - CBS_E_CANCEL]
Code:
2013-03-13 12:44:35, Info                  CBS    Appl: SelfUpdate detect, component: x86_microsoft-windows-consolehost_31bf3856ad364e35_6.1.7600.20978_none_74c994877c801cc5, elevation: 2, applicable: 0
2013-03-13 12:44:35, Info                  CBS    Appl: Evaluating applicability block(non detectUpdate part), disposition is: Staged, applicability: NotApplicable, result applicability state: Staged
2013-03-13 12:44:35, Info                  CBS    Appl: Package: Package_6_for_KB2507938~31bf3856ad364e35~x86~~6.1.1.4, Update: Trigger_1, Applicable: NotApplicable, Disposition: Staged
2013-03-13 12:44:35, Info                  CBS    Restored system sleep block state: 0x80000000
2013-03-13 12:44:36, Error                 CBS    Failed to ask UI handler to terminate. [HRESULT = 0x800706ba - RPC_S_SERVER_UNAVAILABLE]
2013-03-13 12:44:37, Error                 CBS    Failed to ask UI handler to terminate. [HRESULT = 0x800706ba - RPC_S_SERVER_UNAVAILABLE]
2013-03-13 12:44:38, Info                  CBS    Exec: Processing complete.  Session: 30285831_3509511967, Package: Package_for_KB976932~31bf3856ad364e35~x86~~6.1.1.17514 [HRESULT = 0x00000000 - S_OK]
2013-03-13 12:44:38, Info                  CBS    Session: 30285831_3509511967 finalized. Reboot required: yes [HRESULT = 0x00000000 - S_OK]
2013-03-13 12:48:22, Info                  CBS    SPI: Starting SPInstall version 6.1.7601.17514
Code:
2013-03-13 12:48:39, Info                  CBS    SPI: SQM is not opted in
2013-03-13 12:48:39, Error                 CBS    SPI: (SPIRegQueryDWORDValue:413)Failed to query registry value: UploadDisableFlag er=0x2
2013-03-13 12:48:43, Info                  CBS    SPI: Starting SP Compatibility\Applicability scan
2013-03-13 12:48:43, Error                 CBS    SPI: (SPIRegQueryDWORDValue:400)Failed to open the registry root: n/a, key: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ServicePack\SP1. er=0x2
2013-03-13 12:48:43, Error                 CBS    SPI: (SPIRegQueryDWORDValue:400)Failed to open the registry root: n/a, key: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ServicePack\SP1. er=0x2
2013-03-13 12:48:43, Error                 CBS    SPI: (SPIRegQueryDWORDValue:400)Failed to open the registry root: n/a, key: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ServicePack\SP1. er=0x2
2013-03-13 12:48:43, Error                 CBS    SPI: (SPIRegQueryDWORDValue:400)Failed to open the registry root: n/a, key: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ServicePack\SP1. er=0x2
2013-03-13 12:48:43, Info                  CBS    Session: 30285834_2671949147 initialized by client SP Coordinater Engine.
2013-03-13 12:48:43, Error                 CBS    Failed to resolve package 'Microsoft-Media-Foundation-Package~31bf3856ad364e35~x86~en-US~6.1.7601.17514' [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
...and there's a whole ruck of this type of error....

Code:
 Line 892928: 2013-03-13 12:48:44, Error                 CBS    Failed to resolve package 'Microsoft-Windows-Xps-Foundation-Client-Package~31bf3856ad364e35~x86~en-US~6.1.7601.17514' [HRESULT = 0x80070490 - ERROR_NOT_FOUND]

If we're lucky, the CheckSUR should resolve a lot of the 0x80070490 errors.


Not sure what this one is...
Code:
2013-03-13 12:56:59, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
2013-03-13 12:56:59, Info                  CBS    Failure in poqexec.exe while processing updates. [HRESULT = 0x80071a90 - ERROR_TRANSACTIONAL_CONFLICT]
2013-03-13 12:56:59, Error                 CBS    Shtd: Failed while processing non-critical primitive operations queue. Non-critical primitives will be retried from SMSS. [HRESULT = 0x80071a90 - ERROR_TRANSACTIONAL_CONFLICT]
2013-03-13 12:56:59, Info                  CBS    Setting ExecuteState key to: CbsExecuteStateUnstageDrivers
2013-03-13 12:56:59, Info                  CBS    SQM: Waiting up to 60000 ticks for pending uploads to complete.

There's a whole load of this type of error at the end.....
Code:
2013-03-13 13:49:55, Info                  CSI    00000231 Couldn't mark for pending delete: [ml:78{39},l:76{38}]"\SystemRoot\WinSxS\Temp\PendingDeletes"\[l:88{44}]"377a98e21220ce0191000000c805c80f.wbemsvc.dll".  Reason: [13]"Cannot Delete"

....and all 200MB+ of it generated in less than two hours
My System SpecsSystem Spec
13 Mar 2013   #8
soulcoma

Windows Seven
 
 

thx
My System SpecsSystem Spec
13 Mar 2013   #9
soulcoma

Windows Seven
 
 

it was probably me trying to reinstall the Service Pack (and uninstall it).
My System SpecsSystem Spec
13 Mar 2013   #10
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

That would certainly do something like that

Please run the CheckSUR tool and post the CheckSUR.log file
My System SpecsSystem Spec
Reply

 I have a viable reason to remove Windows 7 SP1 (not an error code)...




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
windows update error (code 9c48 and code 9c57)
i having problem with this windows update here is zip for CBS thanks!!!
Windows Updates & Activation
Unable to Update/Repair/Remove .Net Framework 4.5 Error Code 66A
hi, i am having an issue with updating the .Net Framework 4.5 from Windows Update. It gets an error code "Code 66A". So i decided to use the Setup file to repair or remove it from my computer and then reinstall again but then there are errors too. "fatel error during installation". ive installed...
Windows Updates & Activation
Error code 0xC8000247. Recently cloned my HDD, it might be the reason.
Diagnostic Report (1.9.0027.0): ----------------------------------------- Windows Validation Data--> Validation Code: 0x8004FE21 Cached Online Validation Code: 0x0 Windows Product Key: *****-*****-6377X-2YQPX-HHWQM Windows Product Key Hash: TQExrpoWs54DRUYMBwyUGuvVatA= Windows Product ID:...
Windows Updates & Activation
BSOD Error Code 0x07e, Unknown reason
Hi all, I was browsing the web earlier today and got a random BSOD. The first one I got was a Memory Management one, but a Crash Dump for this one does not appear in the Minidump folder. After restarting my computer, I got a second BSOD about 3 minutes after logging in, This time it was a...
BSOD Help and Support
Windows won't load if I remove optical drive (error code 0x490)
Here's my situation, I want to remove my optical drive (ASUS dvd/rw) as I never use it, however after I disconnected it Windows wont load. It begins to load and then flashes a blue screen and restarts. If I plug my optical drive back in everything is boots up fine. Does anyone know how I can remove...
BSOD Help and Support
Windows 7 BSOD on start-up, STOP code but no reason
Hello! My laptop has been crashing rather frequently, and is starting to be a pain. Microsoft Windows 7 Home Premium 64-bit, original installed OS on system, OEM. Bought in 2009. I have not re-installed the OS. The BlueScreen that comes up has no line of data at the top on bold print! It...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:18.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App