Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Cannot install IE10 on Win 7 x64

24 Mar 2013   #11

Win 7 Pro x64
 
 

Tnaks a lot. IE9 starts to show its age and I really want to be able to upgrade to IE10. I am using Firefox as well but I want to keep IE as a browser.

My System SpecsSystem Spec
.

24 Mar 2013   #12

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

No problem, we'll have you up and running in no time. You'll be glad to hear that, with the help of your data, I think I've finally found the cause of this problem! Now I need to confirm this with a few tests on my virtual machine before getting a fix posted for you.

Tom
My System SpecsSystem Spec
25 Mar 2013   #13

Win 7 Pro x64
 
 

Any progress? I am very curious to see what you found out. I usually resolve issues like this myself but this is well beyond my level of expertise.
My System SpecsSystem Spec
.


27 Mar 2013   #14

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Hi XYZ1234,

I've spent hours on end looking through your registry exports and comparing to what I think they should be. There are a few inconsistencies which I was very hopeful for when I post a few days ago but when I test these on my system, none of them have generated the error you face. I am currently in the process of setting up my virtual machine to be as similar to your system as possible - basically, I took your registry exports and incorporated them into my registry. The SURT now takes up to 6 hours to run as it corrects all of the problems! The last run showed this:

Code:
Found 21652 errors
Fixed 14130 errors
I haven't forgotten about you, it's just that this is a very slow process

Tom
My System SpecsSystem Spec
27 Mar 2013   #15

Win 7 Pro x64
 
 

Thanks.

It is strange that SURT takes so long on your machine - on my two year old computer, it takes much less and finds not so many errors, I think (it is all in the log files but I forgot).
My System SpecsSystem Spec
27 Mar 2013   #16

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Silly question, Tom - what about the Catroot2 folder? possible cause?
My System SpecsSystem Spec
27 Mar 2013   #17

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Quote   Quote: Originally Posted by XYZ1234 View Post
Thanks.

It is strange that SURT takes so long on your machine - on my two year old computer, it takes much less and finds not so many errors, I think (it is all in the log files but I forgot).
My machine isn't the problem, 4.5GHz and 8GB of RAM is plenty to run a VM, the scale of what I'm trying to do is the problem here. Say each error takes one second to fix, then 22000 errors is 6 hours and 6 minutes to complete. By forcing your registry into mine, the SURT is now essentially aligning the various files and registry keys in the best way possible as I will have plenty of registry keys for non existent files and vice versa Each run is getting faster, and improving though. I'm now down to ~7000 errors and it's flatlining at that number:

Code:
Summary:
Seconds executed: 5967
 Found 7522 errors
  CSI Create Hard Link Failed Total count: 36
  CSI Manifest Missing Total count: 3115
  CSI Manifest and S256H Do Not Match Total count: 6
  CSI Payload File Missing Total count: 4353
  CSI Missing Winning Component Key Total count: 12
Fortunately, I now have some missing Winning Component Keys to work with!

Quote   Quote: Originally Posted by NoelDP View Post
Silly question, Tom - what about the Catroot2 folder? possible cause?
Far from a silly question I'm 99% sure this is a registry problem but it's definitely worth trying something with the catroot2 folder.
My System SpecsSystem Spec
02 Apr 2013   #18

Win 7 Pro x64
 
 

Any progress?
My System SpecsSystem Spec
30 Apr 2013   #19

Win 7 Pro x64
 
 

Nothing new, I guess?
My System SpecsSystem Spec
30 Apr 2013   #20

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Hi XYZ1234,

I'm so sorry for the delay, I've been really busy over the past few weeks and completely forgot about this.

Would you mind re-uploading the two registry files please: Cannot install IE10 on Win 7 x64

I have about 4 components hives on my Desktop at the moment and I have no idea which one is yours!

Tom
My System SpecsSystem Spec
Reply

 Cannot install IE10 on Win 7 x64





Thread Tools



Similar help and support threads for2: Cannot install IE10 on Win 7 x64
Thread Forum
Solved Cannot install IE10 Update! Windows Updates & Activation
Cannot Install IE10 From Windows Update Windows Updates & Activation
IE10 won't install and now IE9 won't either Browsers & Mail
IE10 will not install on Win7 Windows Updates & Activation
Stuck somehow between IE9 and IE10. Cant run/install either. Browsers & Mail
Solved IE10 install error 9C44 Windows Updates & Activation
Test install of IE10? Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:16 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33