Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot install IE10 on Win 7 x64

30 Apr 2013   #21
XYZ1234

Win 7 Pro x64
 
 

I sent you a PM with a link.


My System SpecsSystem Spec
.

01 May 2013   #22
tom982

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Hi XYZ1234,

Thanks for the files, I've got them saved where I won't lose them this time!

Can you post your CheckSUR log please, it appears that you've removed all of your attachments so I don't know which registry keys to look at:

C:\Windows\Logs\CBS\CheckSUR.persist.log

Tom
My System SpecsSystem Spec
01 May 2013   #23
XYZ1234

Win 7 Pro x64
 
 

CheckSUR is attached.
My System SpecsSystem Spec
.


04 May 2013   #24
tom982

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Hi XYZ1234,

I hope it was worth the wait, but I've fully repaired the COMPONENTS hive

Download this file please: https://dl.dropboxusercontent.com/u/...components.zip

Extract the contents to your Desktop, there should be one file named components.

Then navigate to C:\Windows\system32\config

And rename the file components to components.bak.

Then copy and paste the components file on your Desktop to this folder. Reboot and run the SURT again please, then post the log: C:\Windows\Logs\CBS\CheckSUR.persist.log

If, at any point, you are displayed an error saying the file is in use, or access denied, reboot and try again.

Tom
My System SpecsSystem Spec
04 May 2013   #25
XYZ1234

Win 7 Pro x64
 
 

Thanks. I am traveling now, and will try this when I get back in a few weeks.
My System SpecsSystem Spec
04 May 2013   #26
tom982

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

No problem, thanks for letting me know. Hope you have a nice time travelling!

Tom
My System SpecsSystem Spec
18 May 2013   #27
XYZ1234

Win 7 Pro x64
 
 

I am back. Attached is the log.

Thanks for your efforts.
My System SpecsSystem Spec
18 May 2013   #28
tom982

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Hi XYZ1234,

Welcome back, hope your travelling went well!

After spending so many hours researching, I've finally worked out how to fix a missing winning component key error! Every one of those errors have gone in your log, but you do have some new ones which doesn't really surprise me - the error was caused by a missing C mark in your registry which is essentially one link in a very long chain; now that the link is there again, the SURT can continue to scan along the chain and has found errors further down it. So now we're down to these errors:

Code:
(f)    CSI Missing Deployment Key    0x00000000    usbport.inf_31bf3856ad364e35_6.1.7601.17586_1b9eb6021a6421dc    HKLM\Components\CanonicalData\Deployments    
(f)    CSI Missing Deployment Key    0x00000000    nvraid.inf_31bf3856ad364e35_6.1.7601.17577_97c2e9ecd5cc2253    HKLM\Components\CanonicalData\Deployments    
(f)    CSI Missing Deployment Key    0x00000000    iastorv.inf_31bf3856ad364e35_6.1.7601.17577_0cf9793d9e95787b    HKLM\Components\CanonicalData\Deployments    
(f)    CSI Missing Deployment Key    0x00000000    usb.inf_31bf3856ad364e35_6.1.7601.17586_28d4bd852548d3f5    HKLM\Components\CanonicalData\Deployments    
(f)    CSI Missing Deployment Key    0x00000000    amdsata.inf_31bf3856ad364e35_6.1.7601.17577_aa54fe0598b884c4    HKLM\Components\CanonicalData\Deployments    
(f)    CSI Missing Deployment Key    0x00000000    usbstor.inf_31bf3856ad364e35_6.1.7601.17577_a66e757baea0992f    HKLM\Components\CanonicalData\Deployments    
(f)    CSI C Mark Deployment Missing    0x00000000    c!9c076e57253..e8b316bfeb7_31bf3856ad364e35_8.0.7601.17634_880aab4c1e04de45    x86_microsoft-windows-activexcompat_31bf3856ad364e35_8.0.7601.17634_none_12f5b1ddd8e2d185    
(f)    CSI C Mark Deployment Missing    0x00000000    c!cd27d714c57..b8bd18b2b9f_31bf3856ad364e35_6.1.7601.17582_b4c08393cd537b8c    amd64_microsoft-windows-capi2-certs_31bf3856ad364e35_6.1.7601.17582_none_2067109eaaffb4bb    
(f)    CSI C Mark Deployment Missing    0x00000000    c!2e18f52dc38..07c4527b44e_31bf3856ad364e35_8.0.7601.17579_20db61f5937e4a1a    x86_microsoft-windows-activexcompat_31bf3856ad364e35_8.0.7601.17579_none_12cf71b9d8fec2d5    
(f)    CSI C Mark Deployment Missing    0x00000000    c!0e291225e97..8087e5375ca_31bf3856ad364e35_6.1.7600.16808_fdcbf8d21b80caf9    amd64_microsoft-windows-g..ebuild-search-index_31bf3856ad364e35_6.1.7600.16808_none_1b3c97835a989f39    
(f)    CSI C Mark Deployment Missing    0x00000000    c!2e18f52dc38..07c4527b44e_31bf3856ad364e35_8.0.7601.17579_20db61f5937e4a1a    amd64_microsoft-windows-activexcompat_31bf3856ad364e35_8.0.7601.17579_none_6eee0d3d915c340b    
(f)    CSI C Mark Deployment Missing    0x00000000    c!41132c91358..de658ad1324_31bf3856ad364e35_6.1.7601.17592_66b394c89e0fceda    amd64_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_672ce6c3de2cb17f    
(f)    CSI C Mark Deployment Missing    0x00000000    c!03f860582fe..68a6bcef193_31bf3856ad364e35_6.1.7600.16820_ba55f2f35bead747    amd64_microsoft-windows-g..validatefntcache-02_31bf3856ad364e35_6.1.7600.16820_none_a509c27b34094bea    
(f)    CSI C Mark Deployment Missing    0x00000000    c!bbb6c955cca..ae9c6e05c3b_31bf3856ad364e35_6.1.7601.17528_70b647f112c794cc    x86_microsoft-windows-directshow-mpeg2_31bf3856ad364e35_6.1.7601.17528_none_b80fc5c5008bc45c    
(f)    CSI C Mark Deployment Missing    0x00000000    c!9c076e57253..e8b316bfeb7_31bf3856ad364e35_8.0.7601.17634_880aab4c1e04de45    amd64_microsoft-windows-activexcompat_31bf3856ad364e35_8.0.7601.17634_none_6f144d61914042bb    
(f)    CSI C Mark Deployment Missing    0x00000000    c!9c076e57253..e8b316bfeb7_31bf3856ad364e35_8.0.7601.17634_880aab4c1e04de45    amd64_microsoft-windows-directshow-mpeg2_31bf3856ad364e35_6.1.7601.17528_none_142e6148b8e93592    
(f)    CSI C Mark Deployment Missing    0x00000000    c!cd27d714c57..b8bd18b2b9f_31bf3856ad364e35_6.1.7601.17582_b4c08393cd537b8c    x86_microsoft-windows-capi2-certs_31bf3856ad364e35_6.1.7601.17582_none_c448751af2a24385    
(f)    CSI C Mark Deployment Missing    0x00000000    c!fc1bde87f5b..7acaa841765_31bf3856ad364e35_6.1.7601.17592_4d581c651c62820b    x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_0b0e4b4025cf4049    
(f)    CSI Payload File Missing    0x00000000    sysmain.sdb    wow64_microsoft-windows-a..ence-mitigations-c1_31bf3856ad364e35_6.1.7600.16414_none_72b68533402654a8
It's getting late here so I'll post a fix for you tomorrow

Tom
My System SpecsSystem Spec
19 May 2013   #29
tom982

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Hi XYZ1234,

Can you download the attached file, tom982.zip, and extract the contents to C:\tom982 - there should now be many .reg files in this folder.


Then download the attached file, Fix.bat, right click on this then select Run as administrator. This should import all of the missing registry keys into your registry.


Re-run the SURT and post the log please


C:\Windows\Logs\CBS\CheckSUR.persist.log

Tom
My System SpecsSystem Spec
19 May 2013   #30
XYZ1234

Win 7 Pro x64
 
 

Here is the log. I am not sure that I updated the registry successfully - there were too many security warnings.
My System SpecsSystem Spec
Reply

 Cannot install IE10 on Win 7 x64




Thread Tools





Similar help and support threads
Thread Forum
Stuck somehow between IE9 and IE10. Cant run/install either.
I allowed the IE10 update to install. The installation appeared fine, however IE10 froze every time I tried to enter an address away from my homepage (about:blank). I uninstalled using the removal of update expecting IE9 to come back. The icons are there, but when clicked on i get a brief flash of...
Browsers & Mail
Cannot run ie10, cannot install ie9/11 (ie10 installed)
ok, I believe this is due to some bad windows update, but there isn't a list that i can locate to uninstall. I've already tried force uninstall all remnants, using: --- FORFILES /P %WINDIR%\servicing\Packages /M Microsoft-Windows-InternetExplorer-*11.*.mum /c "cmd /c echo Uninstalling...
Windows Updates & Activation
Cannot Install ie10 (9c59)
Hi all, This is my first time so I hope I get it right. Can't install ie10 on my Win 7 64 bit system. Thought I would just wait until ie11 but can't get that to install either - only from standalone installer but error seems pretty much the same. anyway, here is my error screenshot from ie10 on...
Windows Updates & Activation
Install IE10 failed
Hello, i have Problem installing IE10. Install with update or manuell failed: Error log: Der Status des Pakets KB2718695 konnte nicht in "Installiert" gešndert werden. Status: 0x80070002. install of CheckSUR has no erros. SFC /SCANNOW : no error
Windows Updates & Activation
Windows update fails to install IE10 after repair install
I did a repair install of W7 Ult. x64 SP1. Applied all updates, but if fails to install IE10 update : (as you see it is a dutch version). If have run sure & sfc /scannow. Both report no problems. CBS files are attached. Please help ?
Windows Updates & Activation
IE10 won't install and now IE9 won't either
We have a Windows 7 x86 box that won't install IE10, first via automatic updates, then through manual install. I took over the problem and removed IE10 in Windows Features, only to discover I was left with no IE at all. I attempted to reinstall 9, but got a message that a later version was...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 20:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App