Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Home Premium X64 (windows update issue)

21 Apr 2013   #11
tom982

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Hi Bacilul,

Well there goes the easy option! Time for plan b:

Command Prompt

Warning: this fix is specific to the user in this thread. No one else should follow these instructions as it may cause more harm than good. If you are after assistance, please start a thread of your own.

  1. Click on the Start button and in the search box, type Command Prompt
  2. When you see Command Prompt on the list, right-click on it and select Run as administrator
  3. When command prompt opens, copy and paste the following commands into it, press enter after each

    sc query wuauserv

    reg query HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\wuauserv

  4. Right-click on the Command Prompt window and click Select All, this will invert all of the colours by selecting the text, now press enter. All of this text is now copied.
  5. Paste (Ctrl+V) it into your next post please.


Tom


My System SpecsSystem Spec
.

21 Apr 2013   #12
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Typo alert!
shouldn't it be

SC QUERY WUAUSERV

??
My System SpecsSystem Spec
21 Apr 2013   #13
tom982

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Quote   Quote: Originally Posted by NoelDP View Post
Typo alert!
shouldn't it be

SC QUERY WUAUSERV

??
Nice catch! Thanks Fixed.
My System SpecsSystem Spec
.


22 Apr 2013   #14
Bacilul

Windows 7 Home Premium x64 SP1
 
 

Hello
Code:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>sc query wuauserv

SERVICE_NAME: wuauserv
        TYPE               : 20  WIN32_SHARE_PROCESS
        STATE              : 4  RUNNING
                                (STOPPABLE, NOT_PAUSABLE, ACCEPTS_PRESHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0

C:\Windows\system32>reg query HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\servic
es\wuauserv

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\wuauserv
    PreshutdownTimeout    REG_DWORD    0x36ee800
    DisplayName    REG_SZ    @%systemroot%\system32\wuaueng.dll,-105
    ImagePath    REG_EXPAND_SZ    %systemroot%\system32\svchost.exe -k netsvcs
    Description    REG_SZ    @%systemroot%\system32\wuaueng.dll,-106
    ObjectName    REG_SZ    LocalSystem
    ErrorControl    REG_DWORD    0x1
    Start    REG_DWORD    0x2
    DelayedAutoStart    REG_DWORD    0x1
    Type    REG_DWORD    0x20
    DependOnService    REG_MULTI_SZ    rpcss
    ServiceSidType    REG_DWORD    0x1
    RequiredPrivileges    REG_MULTI_SZ    SeAuditPrivilege\0SeCreateGlobalPrivil
ege\0SeCreatePageFilePrivilege\0SeTcbPrivilege\0SeAssignPrimaryTokenPrivilege\0S
eImpersonatePrivilege\0SeIncreaseQuotaPrivilege
    FailureActions    REG_BINARY    80510100000000000000000003000000140000000100
000060EA000000000000000000000000000000000000

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\wuauserv\Parameters
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\wuauserv\Security

C:\Windows\system32>
My System SpecsSystem Spec
22 Apr 2013   #15
tom982

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Hi Andrew,

That all looks in order. Can you try resetting your Windows Update components using the FixIt please:

How do I reset Windows Update components?

Tom
My System SpecsSystem Spec
22 Apr 2013   #16
Bacilul

Windows 7 Home Premium x64 SP1
 
 

Nope, didn't worked. Anyway, the reason I mentioned about changing the operating system's language using Vistalizator in my first post was that I had doubts that's the main cause. Changed the language back to Italian, and everything is ok ...installing the important updates right now. I avoided reverting my language back to the original one because when I added English it took some time. Anyway, now the real question is, I'm planning to change the language back to EN, I'm guessing windows update will no longer work correctly after that, is there anything we can do so I could keep both the language and windows updates ? Any ideas?
My System SpecsSystem Spec
22 Apr 2013   #17
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Please post an MGADisg report - vistalizator lraves charscteridtic trsces there if still in effect
My System SpecsSystem Spec
22 Apr 2013   #18
tom982

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro x64
 
 

Quote   Quote: Originally Posted by NoelDP View Post
Please post an MGADisg report - vistalizator lraves charscteridtic trsces there if still in effect
Hitting the whiskeys early?
My System SpecsSystem Spec
22 Apr 2013   #19
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Nah - posting from my phone while having a ciggy


@Bacilul
Please follow this tutorial and post an MGADiag report - then we can see what the problem is.

http://www.sevenforums.com/windows-updates-activation/234159-windows-genuine-activation-issue-posting-instructions.html

Ignore errors produced when clicking on the Copy button - they simply mean that the tool could not create the backup files for some reason. The data is still copied to the clipboard for pasting to your response.
My System SpecsSystem Spec
22 Apr 2013   #20
Bacilul

Windows 7 Home Premium x64 SP1
 
 

Thanks NoelDP, I would but the problem is that the problem is gone.
After setting IT and downloaded/installed updates I changed it back to EN and voila, it works now.
It seems I am lucky after all.
Thank you very much Tom for your help , I really appreciate it, I'm sorry we had to follow all these steps but everything is ok now.
We will meet again ! hehe
My System SpecsSystem Spec
Reply

 Windows 7 Home Premium X64 (windows update issue)




Thread Tools





Similar help and support threads
Thread Forum
windows 7 home premium 64bit activation issue
Diagnostic Report (1.9.0027.0): ----------------------------------------- Windows Validation Data--> Validation Code: 0 Cached Online Validation Code: 0x0 Windows Product Key: *****-*****-MVJJY-9MFRT-22RMM Windows Product Key Hash: 2McoXZHlu/1PX2JgKSjLLfremeI= Windows Product ID:...
Windows Updates & Activation
Can't update Windows 7 Home Premium 64 bit
Hi. Whenever I try to update my laptop, it always gets stuck on "Installing 1 of 22". It's happened for about 2-3 years now and I hope now since I've finally registered an account and telling people on sevenforums.com about this, I can update my Windows. Computer Information: Manufacturer:...
Windows Updates & Activation
Windows 7 Home Premium Update Failure
Hi, I am running Windows 7 Home Premium x64 and I have been having problems updating my Windows. Every time I shut down, Windows would spend 15 minutes or so trying to update only to have it fail. I have followed the instructions on the posting guideline and have attached the relevant data...
Windows Updates & Activation
Windows 7 Home Premium Imaging Issue
Hello! I was trying to make an image of my pc using windows 7 image backup tool, and using DVDs. The problem is that i keep getting the message asking me to format the DVD (+R). When i do that it then asks me to lable a dvd and insert it...and then... i am asked to format again..and label (...
Backup and Restore
Windows 7 Home Premium 64-bit UPGRADE issue
i am in the works on my new rig and my dumba-- bought windows upgrade without knowing it and tried to install it on my new hard drive so i was wondering since it needs vista to upgrade from is it possible to place my old hard drive from my vista computer and place it on my new motherboard and...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App