Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Error installing Service Pack 1 (error 80073701)

23 Jun 2013   #1

Windows 7 Home Premium 64bit
 
 
Unable to install Service Pack 1 on Win7, error 80073701

So I've been spending the last two days trying to figure out how to fix this. I recently restored my laptop back to factory defaults, but now whenever I try to using Windows Update to install Service Pack 1 I keep getting error 80073701 (ERROR_SXS_ASSEMBLY_MISSING).

So I've been searching various tech forums and as far as I can see it's an issue with missing/corrupt language packs. I've tried using Microsoft's Fix It tool and the System Update Readiness Tool as well as running sfc /scannow from the command prompt with no luck.

I've tried running lpksetup.exe in order to remove the language packs (which as far as I can tell aren't installed at all), but I'm just getting told that they cannot be removed after a short amount of time with no error codes or usable information to follow up on that.

I've also read someplaces that I should remove certain earlier updates, but can't seem to find out which. Some say to remove all Windows Updates and Security Updates, but that's close to 150 updates and then I'd rather restore the OS once more.


Some places suggest trying to install all the missing language packs, and I'm hoping to avoid this as it is somewhat time consuming. First time I checked the CBS.log file it said I was missing the Finnish language pack. I installed that one, and now I'm missing the Bulgarian pack.

I'd gladly provide a zipped cbs.log, but that one is a good 400mb and I'm not quite sure how to reduce that in size.


My System SpecsSystem Spec
.

24 Jun 2013   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Please reboot to Safe Mode and see if you can rename the existing CBS.log file - it should have archived itself by now unless there are severe problems with the system
Sometimes simply booting to Safe Mode will force the archiving - sometimes the file is corrupt, and cannot be archived.
Of that does the trick, delete the renamed file, then run another SFC /SCANNOW, and post the new CBS folder zipped.
My System SpecsSystem Spec
24 Jun 2013   #3

Windows 7 Home Premium 64bit
 
 

I've done as you said, and I've attached the CBS.log - it doesn't really say much about the error as far as I can see though.
Whenever I attempt to update/install Service Pack 1 the CBS.log grows, and the most recent one was around 1gb. It took me a while, but I managed to dig out the parts that mentioned the specific error code, which looked like this:
Code:
2013-06-25 01:19:31, Error                 CSI    00000012 (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) #3088280# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_PinDeployment(Flags = 0, a = 1e042f6e20d987b1e88bb63e9496b001, Version = 6.1.7600.20561, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, cb = (null), s = (null), rid = [77]"Package_37_for_KB976098~31bf3856ad364e35~amd64~~6.1.1.1.976098-73_neutral_LDR", rah = [1]"2", manpath = (null), catpath = (null), ed = 0, disp = 0)[gle=0x80073701]
2013-06-25 01:19:31, Info                  CBS    Failed to pin deployment while resolving Update: 976098-73_neutral_LDR from file: (null) [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2013-06-25 01:19:31, Info                  CBS    Failed to resolve item[0] in Package: Package_37_for_KB976098~31bf3856ad364e35~amd64~~6.1.1.1, Update: 976098-73_neutral_LDR [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2013-06-25 01:19:31, Info                  CBS    Failed to resolve execution update. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2013-06-25 01:19:31, Error                 CBS    Failed to resolve execution package: Package_37_for_KB976098~31bf3856ad364e35~amd64~~6.1.1.1 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2013-06-25 01:19:31, Info                  CSI    00000013@2013/6/24:23:19:31.828 CSI Transaction @0x1f1e80 destroyed
2013-06-25 01:19:31, Info                  CBS    Perf: Resolve chain complete.
2013-06-25 01:19:31, Info                  CBS    Failed to resolve execution chain. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2013-06-25 01:19:31, Error                 CBS    Failed to process single phase execution. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING
2013-06-25 01:20:29, Info                  CBS    Reboot mark refs: 0
2013-06-25 01:20:30, Info                  CBS    SQM: Reporting package change for package: Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514, current: Partially Installed, pending: Default, start: Partially Installed, applicable: Installed, target: Installed, limit: Installed, hotpatch status: StillGoing, status: 0x0, failure source: Resolve, reboot required: False, client id: WindowsUpdateAgent, initiated offline: False, execution sequence: 813, first merged sequence: 813
2013-06-25 01:20:32, Info                  CBS    SQM: Upload requested for report: PackageChangeBegin_Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514, session id: 101457923, sample type: Standard
2013-06-25 01:20:32, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
2013-06-25 01:20:32, Info                  CBS    SQM: Reporting package change completion for package: Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514, current: Partially Installed, original: Partially Installed, target: Installed, status: 0x80073701, failure source: Resolve, failure details: "(null)", client id: WindowsUpdateAgent, initiated offline: False, execution sequence: 813, first merged sequence: 813
2013-06-25 01:20:32, Info                  CBS    SQM: resolve time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2013-06-25 01:20:32, Info                  CBS    SQM: stage time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2013-06-25 01:20:32, Info                  CBS    SQM: execute time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2013-06-25 01:20:32, Info                  CBS    SQM: Upload requested for report: PackageChangeEnd_Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514, session id: 101457924, sample type: Standard
2013-06-25 01:20:32, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
2013-06-25 01:20:32, Info                  CBS    Enabling LKG boot option
2013-06-25 01:20:32, Info                  CBS    Exec: End: nested restore point - complete.
2013-06-25 01:20:32, Info                  CBS    Restored system sleep block state: 0x80000000
2013-06-25 01:20:32, Info                  CBS    Exec: Processing complete.  Session: 30306606_1399909444, Package: Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING
Please note that this is from my last update attempt, and this bit is before the last sfc /scannow, although I've done the scan a couple of times and it doesn't seem to do much.
My System SpecsSystem Spec
.


25 Jun 2013   #4

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Hmm - I don't recall ever seeing a system with 450 POQ points in the SFC before (the norm is around 260 for x64)
The log is clear, though.
I don't have time to llok in depth at it now, so please upload your windowsupdate.log file so I can look at that as well when I get time.
My System SpecsSystem Spec
25 Jun 2013   #5

Windows 7 Home Premium 64bit
 
 

Here's the windowsupdate.log. Is the POQ points anything I should be aware of? First time I've ever heard about it?
Also, thanks for wanting to help


Attached Files
File Type: zip WindowsUpdate.zip (202.6 KB, 1 views)
My System SpecsSystem Spec
08 Sep 2013   #6

Windows 7 Home Premium 64bit
 
 

I gave up trying to fix this, so I restored my laptop back to system default once again. This time I gradually installed 10 updates at a time, restarting, and installing the next 10 updates all via Windows Update. This time SP1 would appear by itself and install without any problems whatsoever.
My System SpecsSystem Spec
08 Sep 2013   #7

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Great!
Sorry about my lack of response - you should have shouted at me!
My System SpecsSystem Spec
08 Sep 2013   #8

Windows 7 Home Premium 64bit
 
 

It's no problem, I went away on holiday and didn't need my laptop that much. I forgot about this post when I got back home, and just figured I'd try to start over before my classes started again. Compared to how long I spent trying to fix this, restoring to default seemed like a much easier solution
My System SpecsSystem Spec
Reply

 Error installing Service Pack 1 (error 80073701)




Thread Tools



Similar help and support threads for2: Error installing Service Pack 1 (error 80073701)
Thread Forum
8007000D error Cannot update service pack 1 Windows Updates & Activation
Error Installing Service Pack 1 Error 800B0100 Windows Updates & Activation
Installing Windows 7 64bit Service Pack 1, Error "D_S_S_SUCCESS(0x0)" Windows Updates & Activation
Service Pack 1 Error 800B0100 Windows Updates & Activation
Service Pack 1 error Trust_E_NOSIGNATURE Windows Updates & Activation
Service Pack 1 error Trust_E_NOSIGNATURE Windows Updates & Activation
error service pack 1...help Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:14 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33