Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: missing components for sp1 update error code 800f0a13


06 Jul 2013   #1

windows 7 home preium 64bit
 
 
missing components for sp1 update error code 800f0a13

hello, i recently had to remove a virus from this laptop with the help of the nice people at spywarehammer. all their scans showed no reason why the sp1 update should fail. i have searched several online articles and forums and have completed countless trouble shooting suggestions with no luck. i have already done a windows repair using the reinstallation disk several times. hopefully you can help. i've read and completed the posting instructions, if you need more info just ask. by the way, i'm running windows 7 home prerium 64bit on a hp g62-223cl notebook. -brandy




Attached Files
File Type: zip CBS.zip (7.45 MB, 4 views)
My System SpecsSystem Spec
.

07 Jul 2013   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

You had massive corruption (899 affected files so far), according to the SFC scan.

It appears to have corrected most of it, but I would recommend running SFC /SCANNOW again, and posting (just) the new CBS.log file so we can start seeing the wood for the trees.
My System SpecsSystem Spec
07 Jul 2013   #3

windows 7 home preium 64bit
 
 

hello, here is the newest cbs log. -brandy


Attached Files
File Type: zip CBS 7-7 log.zip (67.3 KB, 2 views)
My System SpecsSystem Spec
.


07 Jul 2013   #4

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Great! - SFC found nothing more to repair this time

Please now run another CheckSUR - post the new CheckSUR.log file so we can make sure that the other repairs haven't uncovered any new errors.
Then test the system to see if it's showing any more signs of problems.
My System SpecsSystem Spec
08 Jul 2013   #5

windows 7 home preium 64bit
 
 

hello, still no luck, it says i have missing compenents. i tried installing through windows update and downloading sp1 from microsoft. i hope this is the log you are looking for, let me know if its the wrong log. -brandy


=================================
Checking System Update Readiness.
Binary Version 6.1.7601.21645
Package Version 19.0
2013-07-07 23:42
Checking Windows Servicing Packages
Checking Package Manifests and Catalogs
(f) CBS MUM Corrupt 0x00000000 servicing\Packages\Microsoft-Windows-IE-Hyphenation-Parent-Package-English~31bf3856ad364e35~~~10.2.9200.16437.mum Expected file name Microsoft-Windows-IE-Hyphenation-Parent-Package-English~31bf3856ad364e35~neutral~~10.2.9200.16437.mum does not match the actual file name
(f) CBS MUM Corrupt 0x00000000 servicing\Packages\Microsoft-Windows-IE-Spelling-Parent-Package-English~31bf3856ad364e35~~~10.2.9200.16437.mum Expected file name Microsoft-Windows-IE-Spelling-Parent-Package-English~31bf3856ad364e35~neutral~~10.2.9200.16437.mum does not match the actual file name
Checking Package Watchlist
Checking Component Watchlist
Checking Packages
Checking Component Store
Summary:
Seconds executed: 1445
Found 2 errors
CBS MUM Corrupt Total count: 2
Unavailable repair files:
servicing\packages\Microsoft-Windows-IE-Hyphenation-Parent-Package-English~31bf3856ad364e35~~~10.2.9200.16437.mum
servicing\packages\Microsoft-Windows-IE-Spelling-Parent-Package-English~31bf3856ad364e35~~~10.2.9200.16437.mum
servicing\packages\Microsoft-Windows-IE-Hyphenation-Parent-Package-English~31bf3856ad364e35~~~10.2.9200.16437.cat
servicing\packages\Microsoft-Windows-IE-Spelling-Parent-Package-English~31bf3856ad364e35~~~10.2.9200.16437.cat
My System SpecsSystem Spec
09 Jul 2013   #6

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

The errors in the latest CheckSUR log are normal for a system with IE10 installed - and can be ignored.

The new SFC log is still clean.

BUT....
The background CBS log shows the following errors
Code:
 Line 36133: 2013-07-08 21:53:29, Error                 CSI    0000031d@2013/7/9:03:53:29.221 (F) d:\win7sp1_gdr\base\wcp\componentstore\csd_locking.cpp(324): Error STATUS_SXS_ASSEMBLY_MISSING originated in function CCSDirectTransaction::LockComponent expression: (null)
 Line 36135: 2013-07-08 21:53:30, Error                 CSI    0000031e (F) STATUS_SXS_ASSEMBLY_MISSING #7014233# from CCSDirectTransaction::OperateEnding at index 0 of 1 operations, disposition 2[gle=0xd015000c]
 Line 36136: 2013-07-08 21:53:30, Error                 CSI    0000031f (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) #7014118# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_PinDeployment(Flags = 0, a = bc939918a63a5f7425f2aa3a382052ed, Version = 8.0.7601.21634, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, cb = (null), s = (null), rid = [77]"Package_3_for_KB2475792~31bf3856ad364e35~amd64~~6.1.1.3.2475792-7_neutral_LDR", rah = [1]"3", manpath = (null), catpath = (null), ed = 0, disp = 0)[gle=0x80073701]
 Line 36140: 2013-07-08 21:53:30, Error                 CBS    Failed to resolve execution package: Package_3_for_KB2475792~31bf3856ad364e35~amd64~~6.1.1.3 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
I'm not sure how to go about fixing this - I would have hoped that CheckSUR would have caught it

I need to do some research - If you haven't heard by this time tomorrow, SHOUT!.
My System SpecsSystem Spec
31 Jul 2013   #7

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Most of the fixes I've found involve a repair install of Windows

One which appears to have worked stated that their problem was caused by insufficient disk space - how much room do you have on the C: drive? (it needs to be at least 10GB - preferably a lot more)
My System SpecsSystem Spec
Reply

 missing components for sp1 update error code 800f0a13




Thread Tools



Similar help and support threads for2: missing components for sp1 update error code 800f0a13
Thread Forum
Error code 28 on Ethernet controller (Missing Drivers) Drivers
Solved Update for Windows Update Error Code 800700B7 Windows Updates & Activation
Windows Update fails in Update Check. Error code C80003FA. Windows Updates & Activation
Help!!!! ERROR CODE 0x80070015 and Bootmgr is missing. Installation & Setup
Bootmgr is missing and Error Code: 0x80070017 (No OS is installed) Installation & Setup
SP1 error's 800F081F & 800F0A13 Windows Updates & Activation
"MISSING COMPONENTS" error message Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:48 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33