Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem Installing SP1 - Windows 7 Home Premium 64 bit

21 Aug 2013   #51
IcecoldUK

Windows 7 64 bit Home Premium
 
 

Any ideas anyone?

I still have several updates that refuse to install.

Jon


My System SpecsSystem Spec
.
21 Aug 2013   #52
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Ah - Sorry!
Did the CHKDSK find anything?

Please run new SFC /SCANNOW and CheckSUR and post the logs.
My System SpecsSystem Spec
22 Aug 2013   #53
IcecoldUK

Windows 7 64 bit Home Premium
 
 

No problem mate. I understand you are busy, i didn't want to hassle you.

Latest CBS log attached. CHKDSK was clear.

Jon
My System SpecsSystem Spec
.

22 Aug 2013   #54
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

You appear to have a number of malformed Manifest files - or perhaps the registry entries related are malformed.
I'll work up some form of test scenario so we can check which it is, and go about fixing them.

I'm surprised that neither SFC nor CheckSUR picked up on them
My System SpecsSystem Spec
22 Aug 2013   #55
IcecoldUK

Windows 7 64 bit Home Premium
 
 

Thank you for you help, it's much appreciated.

My guess would be that its the registry...

Jon
My System SpecsSystem Spec
23 Aug 2013   #56
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

PLease open an Elevated Command Prompt, and run the following commands

Code:
 
COPY C:\Windows\servicing\packages\Package_for_KB2789645~31bf3856ad364e35~amd64~~6.1.1.0.mum %userprofile%\desktop\pack.log
REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\ApplicabilityEvaluationCache\Package_for_KB2789645~31bf3856ad364e35~amd64" >>%userprofile\desktop\pack2.log
REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect\Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~0.0.0.0" >>%userprofile\desktop\pack2.log
REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Packages\Package_for_KB2789645~31bf3856ad364e35~amd64~~6.1.1.0" >>%userprofile\desktop\pack2.log
 
REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageIndex\Package_for_KB2789645~31bf3856ad364e35~amd64~~0.0.0.0" >>%userprofile\desktop\pack2.log
REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Packages\Package_for_KB2789645_SP1~31bf3856ad364e35~amd64~~6.1.1.0" >>%userprofile\desktop\pack2.log
 
.
Post the results by attaching the two files created on your desktop (pack.log and pack2.log) to your reply.

With any luck that'll give me enough to work on.
My System SpecsSystem Spec
23 Aug 2013   #57
IcecoldUK

Windows 7 64 bit Home Premium
 
 

Hi Noel,

I ran the commands you required, but it only produced 1 pack log which i've attached for you.

Here's what the command prompt produced back:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>COPY C:\Windows\servicing\packages\Package_for_KB2789645~31b
f3856ad364e35~amd64~~6.1.1.0.mum %userprofile%\desktop\pack.log
1 file(s) copied.

C:\Windows\system32>REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Co
mponent Based Servicing\ApplicabilityEvaluationCache\Package_for_KB2789645~31bf3
856ad364e35~amd64" >>%userprofile\desktop\pack2.log
The system cannot find the path specified.

C:\Windows\system32>REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Co
mponent Based Servicing\PackageDetect\Microsoft-Windows-Foundation-Package~31bf3
856ad364e35~amd64~~0.0.0.0" >>%userprofile\desktop\pack2.log
The system cannot find the path specified.

C:\Windows\system32>REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Co
mponent Based Servicing\Packages\Package_for_KB2789645~31bf3856ad364e35~amd64~~6
.1.1.0" >>%userprofile\desktop\pack2.log
The system cannot find the path specified.

C:\Windows\system32>
C:\Windows\system32>REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Co
mponent Based Servicing\PackageIndex\Package_for_KB2789645~31bf3856ad364e35~amd6
4~~0.0.0.0" >>%userprofile\desktop\pack2.log
The system cannot find the path specified.

C:\Windows\system32>REG QUERY "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Co
mponent Based Servicing\Packages\Package_for_KB2789645_SP1~31bf3856ad364e35~amd6
4~~6.1.1.0" >>%userprofile\desktop\pack2.log

Jon
My System SpecsSystem Spec
26 Aug 2013   #58
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

That's a bit of a shocker - it seems that there's a fair amount of data missing from the registry, or has at least got misplaced, somehow.

I'm not sure how best to check and resolve this - it would almost certainly be quickest to do a repair install, but if you're willing to have a go at a manual fix let me know and we'll give it a try.

Here's the instructions for a Repair install - Repair Install
My System SpecsSystem Spec
26 Aug 2013   #59
IcecoldUK

Windows 7 64 bit Home Premium
 
 

Hi Noel,

Can we try the manual fix please if it's ok with you as I've already tried running the repair install previously to no avail, and I've completed several fresh installs but the problem still persists.

Jon
My System SpecsSystem Spec
27 Aug 2013   #60
IcecoldUK

Windows 7 64 bit Home Premium
 
 

I'm not sure if this will help at all, but ive attached a screen shot of the update history to indicate the updates which will not install.

Jon
My System SpecsSystem Spec
Reply

 Problem Installing SP1 - Windows 7 Home Premium 64 bit




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Getting Error code: 0x80070570 while installing Windows 7 Home Premium
While i am installing Windows 7 Home Basic 64 Bit on my SONY VAIO VGN-NW350F laptop i am getting the following error . Windows Cannot Install Required files. The file may be corrupt or missing. Make sure all files required for installation are available, and restart the installation. Error code:...
Installation & Setup
Installing Windows 7 Home Premium
Hey guys, Can someone help me? Do I need to backup my files before installing Windows 7 Home Premium when I'm already using Windows 7 Home Basic?
Installation & Setup
Internet not working after re-installing windows 7 home premium
Hi Guys, I had a virus and so had to re-install windows 7 home premium in my laptop. Now, internet is not working. I went to device manager. There, I see a node called 'Other devices' under which 3 items appear. This is what I see. Other devices -Network controller -PCI simple...
Drivers
Asking for username/password while installing Windows 7 Home Premium
Hi. I've got some driver problems so I decided to reinstall the same windows . While installing, The system restarted and showed up the Win 7 wallpaper asking for username and password. From what ? Also i didn't configured username/password before this. Tried the old username/pass but it says "This...
Installation & Setup
Installing Windows 7 over Vista home Premium
Hey everyone, I am have a question and would appreciate your help. I now have Windows Vista Home Premium and I want to upgrade to Windows 7 Ultimate 32 bits. Now I know that I have to do a clean install and thus I would like to make a backup file. My computer has 2 drives one called C and the...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App