Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem Installing SP1 - Windows 7 Home Premium 64 bit

27 Aug 2013   #61
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Looks like the only current failure is KB2834140 - released in March - as everything else seems to have gone in now.

Let's see what we can find in the SOFTWARE registry hive.


Close all windows (it would be a good idea to print these instructions!)
Now reboot to the Repair Environment - as soon as the machine restarts, start tapping F8 - this should bring up the Advanced Boot Menu, at the top of which should be the option 'Repair my Computer'
Pick that
You'll have to log in with your username and password.

Pick the option to use a Command Prompt
At the prompt type
DIR C:\Windows
hit the enter key - if you get a 'Not Found' error try
DIR D:\Windows

or
DIR E:\Windows



use the drive letter which works in the following command (instead of <drive>)

COPY <drive>:\Windows\System32\config\SOFTWARE <drive>:\SOFTHIVE


run the command (it should take almost no time)and when the prompt returns, type
EXIT
and hit the Enter key to exit Command Prompt - reboot to Normal Mode Windows.


Now zip the C:\SOFTHIVE file (it'll probably be about 100MB!) and post the resulting Zip file to your favourite fileshare site (best are probably Dropbox or SkyDrive), and post a link.
I'll let you know when I have it so you can remove it (there is some sensitive info in it which you don't want getting out too broadly, but should be OK for the limited time here)

I'll have a play and see if I can work out what's wrong and get back to you.


My System SpecsSystem Spec
.
27 Aug 2013   #62
IcecoldUK

Windows 7 64 bit Home Premium
 
 

Done!

I've sent you a PM with the dropbox link.

Jon
My System SpecsSystem Spec
27 Aug 2013   #63
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Got it - and got it

back later.
My System SpecsSystem Spec
.

29 Aug 2013   #64
IcecoldUK

Windows 7 64 bit Home Premium
 
 

Hi Noel,

You said to shout if i hadn't heard anything from you.

Jon
My System SpecsSystem Spec
29 Aug 2013   #65
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Thanks for the nudge - I keep forgetting how little time I have nowadays!

You're at the top of the list
My System SpecsSystem Spec
29 Aug 2013   #66
IcecoldUK

Windows 7 64 bit Home Premium
 
 

No rush mate, except for the windows updates and a few odd little glitches everything appears to be working correctly. I nudged because you asked, and because i didn't want you to think i'd lost interest

Jon
My System SpecsSystem Spec
01 Sep 2013   #67
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Looking through the registry, I can't see any of the errors I was expecting - which means (I hope!) that the errors must be in the files.

Please run the following commands, and then zip the created folder up, and upload it

MD %userprofile%\desktop\npfolder
copy c:\windows\servicing\Packages\Package_for_KB2813347~31bf3856ad364e35~amd64~~6.1.1.0.mum %userprofile%\desktop\npfolder
copy c:\windows\servicing\Packages\Package_for_KB2667402~31bf3856ad364e35~amd64~~6.1.2.0.mum %userprofile%\desktop\npfolder
copy c:\windows\servicing\Packages\Package_for_KB2564958~31bf3856ad364e35~amd64~~6.1.1.1.mum %userprofile%\desktop\npfolder
copy c:\windows\servicing\Packages\Package_for_KB2789645~31bf3856ad364e35~amd64~~6.1.1.0.mum %userprofile%\desktop\npfolder
My System SpecsSystem Spec
02 Sep 2013   #68
IcecoldUK

Windows 7 64 bit Home Premium
 
 

Hi Noel,

I ran the commands as requested, please see attached.

The package for KB2789645 would not copy. I ran the command twice and waited up to 20 minutes, but both times it stalled on KB2789645.

Jon
My System SpecsSystem Spec
02 Sep 2013   #69
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

That doesn't surprise me too much

Please run a full CHKDSK and then see if the file will copy...



Click on Start > All Programs > Accessories
Right-click on the Command Prompt entry
Select Run as Administrator and accept the UAC prompt - the Elevated Command Prompt window should pop up.

At the Command prompt, type

CHKDSK C: /R

and hit the Enter key.
You will be told that the drive is locked,
and the CHKDSK will run at he next boot - hit the Y key, press Enter, and then reboot.

The CHKDSK will take a few hours depending on the size of the drive, so be patient!

After the CHKDSK has run, Windows should boot normally (possibly after a second auto-reboot) -

The run another SFC /SCANNOW reboot and post the new CBS.log file.
My System SpecsSystem Spec
02 Sep 2013   #70
IcecoldUK

Windows 7 64 bit Home Premium
 
 

As requested...

Jon
My System SpecsSystem Spec
Reply

 Problem Installing SP1 - Windows 7 Home Premium 64 bit




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Getting Error code: 0x80070570 while installing Windows 7 Home Premium
While i am installing Windows 7 Home Basic 64 Bit on my SONY VAIO VGN-NW350F laptop i am getting the following error . Windows Cannot Install Required files. The file may be corrupt or missing. Make sure all files required for installation are available, and restart the installation. Error code:...
Installation & Setup
Installing Windows 7 Home Premium
Hey guys, Can someone help me? Do I need to backup my files before installing Windows 7 Home Premium when I'm already using Windows 7 Home Basic?
Installation & Setup
Internet not working after re-installing windows 7 home premium
Hi Guys, I had a virus and so had to re-install windows 7 home premium in my laptop. Now, internet is not working. I went to device manager. There, I see a node called 'Other devices' under which 3 items appear. This is what I see. Other devices -Network controller -PCI simple...
Drivers
Asking for username/password while installing Windows 7 Home Premium
Hi. I've got some driver problems so I decided to reinstall the same windows . While installing, The system restarted and showed up the Win 7 wallpaper asking for username and password. From what ? Also i didn't configured username/password before this. Tried the old username/pass but it says "This...
Installation & Setup
Installing Windows 7 over Vista home Premium
Hey everyone, I am have a question and would appreciate your help. I now have Windows Vista Home Premium and I want to upgrade to Windows 7 Ultimate 32 bits. Now I know that I have to do a clean install and thus I would like to make a backup file. My computer has 2 drives one called C and the...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App