Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: *Only* IE10 install fails in Windows Update

06 Aug 2013   #1

XP Home, Pro, 98SE, 7 home premium, and Debian Linux
 
 
*Only* IE10 install fails in Windows Update

First of all, I'm new here, so try to be patient as I stumble through the rules.
Normally I'm pretty good at fixing software issues, but this one has me stumped.

I have a machine running Windows 7 h/p which seems to have installed any other updates fine, but always chokes on IE10, throwing "Code 9C59 Windows Update encountered and unknown error."
(As a side note, I've *never* seen it encounter a *known* error.)

What I have done with no success:
Renamed the SoftwareDistribution folder.
Turned off Norton's 360.
Uninstalled IE9 and reinstalled (it said I had a newer version of IE9 installed *after* I had removed it and rebooted!)
Tried downloading and running the redistributable installer for IE10.

All failed. I have since downloaded and run SURT, run an sfc scan, and checked the Windows error log while I waited. There are loads of instances of this in the event viewer:

"Installation Failure: Windows failed to install the following update with error 0x80070643: Internet Explorer 10 for Windows 7 for x64-based Systems."

I compressed a copy of the CBS folder and attached it.
Thanks in advance for any help.
Greg





Attached Files
File Type: zip CBS.zip (4.69 MB, 3 views)
My System SpecsSystem Spec
.

07 Aug 2013   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

The errors from the CheckSUR log are these....
Code:
Unavailable repair files:
 servicing\packages\Package_1_for_KB2817183~31bf3856ad364e35~amd64~~9.4.1.0.mum
 servicing\packages\Package_2_for_KB2817183~31bf3856ad364e35~amd64~~9.4.1.0.mum
 servicing\packages\Package_for_KB2817183_RTM~31bf3856ad364e35~amd64~~9.4.1.0.mum
 servicing\packages\Package_for_KB2817183~31bf3856ad364e35~amd64~~9.4.1.0.mum
 servicing\packages\Package_1_for_KB2817183~31bf3856ad364e35~amd64~~9.4.1.0.cat
 servicing\packages\Package_2_for_KB2817183~31bf3856ad364e35~amd64~~9.4.1.0.cat
 servicing\packages\Package_for_KB2817183_RTM~31bf3856ad364e35~amd64~~9.4.1.0.cat
 servicing\packages\Package_for_KB2817183~31bf3856ad364e35~amd64~~9.4.1.0.cat
The CBS.log appears to be incomplete - it ends a lot earlier than it should do - but still shows the following error....
Code:
2013-08-06 14:30:23, Info                  CSI    0000009d [SR] Beginning Verify and Repair transaction
2013-08-06 14:30:24, Info                  CSI    0000009e [SR] Cannot repair member file [l:20{10}]"csrsrv.dll" of Microsoft-Windows-Csrsrv, Version = 6.1.7601.18113, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file is missing
Please reboot and post the new CBS folder - meanwhile I'll try and produce a fix protocol for the CheckSUR errors.
My System SpecsSystem Spec
07 Aug 2013   #3

XP Home, Pro, 98SE, 7 home premium, and Debian Linux
 
 

Thanks, NoelDP. The Windows\Logs\CBS folder is just over 5MB in size. When zipped, it's 4.69MB. Nothing seemed to go wrong during the copy/packing process. Weird. Anyway, here's another copy fresh out of the oven.

Again, thanks for the reply. It is truly appreciated.

Greg


Attached Files
File Type: zip CBS(2).zip (4.69 MB, 1 views)
My System SpecsSystem Spec
.


08 Aug 2013   #4

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Sorry for the delay - I will get to it, I promise!
My System SpecsSystem Spec
08 Aug 2013   #5

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

I've uploaded a file - glraa.zip - to my SkyDrive at Noel's SkyDrive
Please download and save it.
Right-click on the downloaded file, and select Extract all…
Extract to the default location - which will create a new folder glraa in the same place.
Open this folder - there should be one folder inside it ( Packages)

Copy the content of the Packages folder to the folder
C:\Windows\Temp\CheckSur\Servicing\Packages

Now run the CheckSUR tool again (it may take a while)

Post the new CheckSUR.log file, and the CheckSUR.persist.log file.
My System SpecsSystem Spec
09 Aug 2013   #6

XP Home, Pro, 98SE, 7 home premium, and Debian Linux
 
 

Thanks, NoelDP, and I apologize for the time delay. I had to set this machine aside for a while and return to my "organic life" for a while.
Just as a point of interest, I had to create the CheckSur, Servicing, and Packages folders.

Attached are the latest log files.

I appreciate your time.

Greg


Attached Files
File Type: zip CBS(3).zip (4.71 MB, 2 views)
My System SpecsSystem Spec
12 Aug 2013   #7

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Hmm - looks like I misplaced a file somehow -

Code:
Checking Component Store
(f) CSI Payload File Missing 0x00000000 win32k.sys amd64_microsoft-windows-win32k_31bf3856ad364e35_6.1.7601.18105_none_172530ffb11d766c 
Summary:
Seconds executed: 773
 Found 5 errors
 Fixed 3 errors
  CSI Payload File Missing Total count: 1
  CBS MUM Missing Total count: 4
  Fixed: CBS MUM Missing.  Total count: 3
  Fixed: CBS Paired File.  Total count: 4
Unavailable repair files:
 servicing\packages\Package_for_KB2817183~31bf3856ad364e35~amd64~~9.4.1.0.mum
I'll try and catch up with everything and post a fix for both the remaining errors, later today.
My System SpecsSystem Spec
14 Aug 2013   #8

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

I've uploaded a file - glrab.zip - to my SkyDrive at Noel's SkyDrive
Please download and save it.
Right-click on the downloaded file, and select Extract all…
Extract to the default location - which will create a new folder glrab in the same place.
Open this folder - there should be one folders inside it (Packages)

Copy the content of the Packages folder to the folder
C:\Windows\Temp\CheckSur\Servicing\Packages

Now run the CheckSUR tool again (it may take a while)

Post the new CheckSUR.log file, and the CheckSUR.persist.log file.

ALSO


I've uploaded a file - glrac.zip - to my SkyDrive at Noel's SkyDrive
Please download and save it.

Right-click on the saved file and select Extract all...
Change the target to C:\ and click on Extract
Close all windows (it would be a good idea to print these instructions!)
Now reboot to the Repair Environment - as soon as the machine restarts, start tapping F8 - this should bring up the Advanced Boot Menu, at the top of which should be the option 'Repair my Computer'
Pick that
You'll have to log in with your username and password.

Pick the option to use a Command Prompt
At the prompt type
DIR C:\glrac
hit the enter key - if you get a 'Not Found' error try
DIR D:\glrac
or
DIR E:\glrac


The drive letter in use when you find the folder will need to be substituted (for<drive>) into the following command...

XCOPY <drive>:\glrac <drive>:\windows\winsxs /y /i /s /v /h

(e.g.XCOPY P:\wfire P:\windows\winsxs /y /i /s /v /h )

run the command (it should take almost no time)and when the prompt returns, type
EXIT
and hit the Enter key to exit Command Prompt - reboot to Normal Mode Windows.

Now run SFC /SCANNOW in an Elevated Command Prompt
then reboot and upload the new CBS.log file to your SkyDrive Public folder, and post a new link

Also run a new MGADiag report, and post the result.
My System SpecsSystem Spec
15 Aug 2013   #9

XP Home, Pro, 98SE, 7 home premium, and Debian Linux
 
 

OK, sorry for the delay, NoelDP.
Attached are the CBS logs from after the first step (glrab)

I'll be doing the second step next, and will upload soon.

Thanks,
Greg
My System SpecsSystem Spec
16 Aug 2013   #10

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)
 
 

Great - that's fixed the problem with the MUM/CAT files, now all we need it the win32k.sys file replacement to work
My System SpecsSystem Spec
Reply

 *Only* IE10 install fails in Windows Update




Thread Tools



Similar help and support threads for2: *Only* IE10 install fails in Windows Update
Thread Forum
Update to IE10 fails! Windows Updates & Activation
Windows update for IE10 on win7 64 fails with error code 9c59 Windows Updates & Activation
Solved Update to IE10 fails Windows Updates & Activation
Cannot Install IE10 From Windows Update Windows Updates & Activation
Update to IE9 or IE10 after Windows 7 install Windows Updates & Activation
Solved Windows update fails for IE10 on Win7 error code 9C59 Windows Updates & Activation
IE10 fails to install, error 0x80070643 Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:58 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33