Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win7SP1 fails error 0x80070643 - was upgraded from Vista previously

16 Aug 2013   #1

Windows 7 Home Premium x86
Win7SP1 fails error 0x80070643 - was upgraded from Vista previously

Vista 32 bit machine.
Upgraded to Windows 7 Home Premium 32 bit.
Now trying to install Windows 7 SP1 and it fails every time. I tried all the suggestions from Microsoft's web site and still does not work.
Event log tells me that it's error 0x80070643.

I tried attaching the entire CBS folder but for some reason it won't attach so I attached the individual log files.

Please help!

My System SpecsSystem Spec

17 Aug 2013   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)

643 errors are difficult to solve - in your situation, it will probably be easier to do a repair install with an SP1 disk, than to attempt manual repair of the existing installation.

See here for the instructions - you will need the Home Premium SP1 U Media Refresh download -
My System SpecsSystem Spec

 Win7SP1 fails error 0x80070643 - was upgraded from Vista previously

Thread Tools

Similar help and support threads
Thread Forum
IE11 fails install, error 0x80070643
I have posted another thread complaining about this problem but without specifically stating the error code 0x80070643. So I have started this new thread hoping for a fresh start. I know that I need to upload a few files for diagnosis purposes so please let me know how to proceed. ...
Windows Updates & Activation
IE10 installation on Win7x64 fails, error 0x80070643
I am able to install all curent updates - including .NET packages - except for either IE10 or IE11. It's a homebuilt box. Checked for rootkits/infections, all clean. Running sfc /scannow tells me that there is a reboot pending and that I should try running it again after the system is restarted....
Windows Updates & Activation
IE11 fails install, error 0x80070643
Hello, First post here but have been using this forum as a resource to troubleshoot many problems in the past, thank you! I have done a search but could not find anything for IE11 install problems helpful. There were similar posts for IE10 install errors but none of the solutions seem to...
Windows Updates & Activation
.net 4 installation fails with error code: (0x80070643)
Hi, trying to install alps tpad drivers to get multitouch on win7 x64 dell laptop. the installer tries to load "Microsoft .net 4 client profile" but it fails with error (from log) "MSI (C:\3b228d38aff65874c154c648\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4...
IE10 fails to install, error 0x80070643
I get this error in the event viewer: "Installation Failure: Windows failed to install the following update with error 0x80070643: Internet Explorer 10 for Windows 7 for x64-based Systems." Attached are the CBS folder items. Any help would be appreciated. I've already run the SURT 3 times and...
Windows Updates & Activation
Previously Installed Windows 7 Fails to Start
Hey everyone, This happened to me a few weeks ago and I haven't been able to resolve it since, so I'm turning here for assistance. One fine evening, I come home and notice that my computer is giving me an error message: Windows failed to start. A recent hardware or software change might...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:04.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App